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Part 1:
Getting Started
DONE - Chapter 1:
About Hydrology, Watersheds
and GIS
This chapter includes:

· Description of the study of hydrology and watersheds
· Scope of detail in this text
Definitions: 
Hydrology XE "hydrology" : The geoscience that describes and predicts the occurrence, circulation, and distribution of the water of the earth and its atmosphere, and the geological, chemical, biological and societal processes that affect and are affected by water. Dingman, 2002 (Modified)

Watershed XE "watershed" : An area of land that drains water, sediment and dissolved materials to a common receiving body or outlet. The term is not restricted to surface water runoff and includes interactions with subsurface water. Watersheds vary from the largest river basins to just acres or less in size.

GIS XE "GIS" : A Geographic Information System (GIS) is a system designed to capture, store, manipulate, analyze, manage, and present all types of geographically referenced data. In the simplest terms, GIS is the merging of cartography, statistical analysis, and database technology.  

It is not the intent of this text to develop a thorough understanding of hydrology. Instead, the purpose of this text is to give the student step-by-step instructions for using GIS software to acquire and manipulate data defining characteristics of a watershed. By completing the case study in this text, the student will develop a basic knowledge of watersheds, one of the important features involved when analyzing hydrological data. Hopefully, this text will provide the student with motivation for more in-depth study of the interesting and expanding field of hydrology. 
For a more complete understanding of hydrology, a search of the internet will uncover more sources of current information.  A course, either online or at a local university, will develop understanding and provide hands-on opportunities to work with hydrological data.

Neither is this text meant to be a tutorial on use of GIS software and specifically, QGIS, the most popular open source GIS software in use at the time of writing this text. Although this text will guide the student through the steps of using QGIS to explore characteristics of the watershed, explanations are brief or missing regarding the functions of GIS. Again, an online class or university course are needed to gain a full understanding of GIS software.
https://www.worldbank.org/en/news/infographic/2019/06/10/in-vietnam-sound-water-development-approaches-yield-positive-benefits
https://www.worldbank.org/content/dam/infographics/780xany/2019/jun/InfoBig2.png
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DONE - Chapter 2:
Defining This Learning Project 
This chapter includes:

· Description of this learning project and its workflow
The purpose of this learning project is to build a reference map of watershed data that could serve as a starting point for further research. The step-by-step approach familiarizes the student with the workflow of map creation, identifies key sources of data and provides a technical reference for future efforts by the student/researcher. 

Multiple steps are needed to study the various characteristics of watersheds that can be observed and analyzed in this project:

 The workflow of the project will include:

1. Defining project learning goals 

2. Identifing a study area

3. Learning sources of data
4. Learning methods of analysis and visualization

5. Creating reference maps and adding relevant data

6. Ground truthing to confirm validity of data

7. Developing conclusions

DONE - Chapter 3:
Installing QGIS and 7-Zip
This chapter includes:

· Instructions to download and install QGIS 

· Instructions to download and install 7-Zip for uncompressing files
Step 1: QGIS Installation for Windows PC
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:

http://www.qgis.org/en/site/forusers/download.html
Choose QGIS Standalone Installer Version 3.10. or later

To see whether your computer has a 32 or 64-bit processor go to Control Panel > System and view the “System type” in the System section. 
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If you are unsure as to whether to install a 32 or 64-bit version of QGIS, select the 32-bit version.

Open the QGIS installer and follow the instructions.

NOTE: At the time this curriculum was prepared, the current version of QGIS was 3.10, dated October 2019.

Configure the QGIS default options:

Start QGIS
Select from menu option Settings > Options
Select General tab

Select Style that corresponds to your computer operating system

Change Icon Size to 32
Change Font to Arial (or your choice)

Change Size to 12 (or your choice)
OK
Select from menu option View > Toolbars > Manage Layers Toolbar

To correctly display foreign language characters

On the menu bar select Settings->Options->Data Sources
In the Data source handling section

Uncheck the box next to Ignore shapefile encoding declaration
OK

On the QGIS status bar along the bottom of the QGIS window
Check the Render box
On the menu bar select Project > Exit QGIS
Step 2: QGIS Installation for Mac
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:

http://www.qgis.org/en/site/forusers/download.html
Choose QGIS macOS Installer Version 3.10.

Perform same instructions as in Step 1

In addition, this change is needed to solve a bug related to clipping raster files

On the menu bar select QGIS 3.10 > Preferences > System 

Open Environment section

Click on the plus sign

In Apply column, select Append
In Variable column type PATH
In Value column copy / paste the following text

:/Library/Frameworks/GDAL.framework/Programs: /Library/Frameworks/PROJ.framework/Programs: /Library/Frameworks/SQLite3.framework/Programs:/Library/Frameworks/UnixImageIO.framework/Programs

When you are finished, your screen should look like this:
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OK

On the menu bar select QGIS 3 > Quit QGIS 3
Step 3. Software Installation - 7-Zip XE "7-Zip"  

Download and install 7-Zip from a trusted website such as CNET.com

Step 4. Learning to use QGIS software

Search the internet for resources for learning QGIS.

One online resource for learning QGIS is https://foss4geo.wordpress.com/
DONE - Chapter 4:
Locating GIS Boundary Maps
This chapter includes:

· Locating appropriate digital maps of administrative boundaries
One useful source of digital maps for GIS systems is the website for GADM Database of Global Administrative Areas which can be accessed at http://www.gadm.org/  

GADM XE "GADM"  is a spatial database of the location of the world's administrative areas (or administrative boundaries XE "administrative boundaries" ) for use in GIS software.  The coordinate reference system is latitude/longitude and the WGS84 datum. These maps can contain up to 4 levels of administrative subdivisions. A general understanding of concept of “administrative areas” is presented in Wikipedia at http://en.wikipedia.org/wiki/Administrative_division
Other useful sites containing data for roads, rivers, population data, etc:

http://www.diva-gis.org/gdata 

https://nationalmap.gov/small_scale/

DONE - Chapter 5:
Choosing a Study Area
and Creating a Reference Map
This chapter includes:

· Purpose and definition of a study area

· Purpose and definition of the reference map XE "reference map" 
· Tips on creating a reference map

· Sources and examples of reference maps

Purpose
We need to define a study area for our project. Our study area will be the Huong River watershed. To orient the viewer to our study area, we will create a reference map bounded by administrative boundaries. One example is to use the boundaries of a county in the US (province or district in many other countries). 

A second option for a reference map is to define an area by explicitly specifying its boundaries ourselves. We might define a rectangle by specifying the coordinates of its four corners or draw a rectangle of your study region in a map layer of your project. 

The purpose of creating a reference map is to provide a starting point for displaying data related to the main topic of our study project. 

Tips on creating a reference map
Use care in selecting how many detailed features to include on the reference map. Features should be included that will assist the user in interpreting the main topic of the map – the theme of the map. Features that do not add to the user’s understanding should be omitted. The simpler the map, the better; maps cluttered with too much detail can detract from the message you want to communicate. 

The GADM website is an excellent starting point that provides digital reference maps of regional boundaries (also called administrative areas). We will download a map from this website to begin the work of defining our study region.

Step 1: Define the study area XE "study area" 
The study area for this project is the Huong River basin in central Vietnam. 

Step 2: Locate and download map files that include the study region
Create a folder on the C drive for your work - name the folder Watersheds. 

In the Watersheds folder, create a sub-folder named TT-Hue
Download the administrative maps from the GADM website at http://www.gadm.org/ 

Select Data button
Click on the word country
Select Vietnam from the dropdown menu
Select Shapefile

The file will now be downloaded

Copy the downloaded file into the folder TT-Hue
Step 3: Start QGIS and create a map layer of your study area
Start QGIS

Select Project > New

In QGIS, add a vector layer for all the provinces in the Vietnam

On the QGIS menu bar

Select Layer > Add Layer > Add Vector Layer 

For Vector Dataset, browse to folder TT-Hue
Select the file named gadm36_VNM_shp
Open

Add

Select Select All
OK 
Close
Uncheck all layers except gadm36_VNM_1 

Right click the gadm36_VNM_1 layer > Properties
Select Source tab 

Select Query Builder button in the Provider feature filter section
Double click NAME_1 in Fields box 

Single click Operator “=” 

Choose “All” in Values box

Double click Thừa Thiên Huế 
OK > OK
Right click the gadm36_VNM_1 layer
Select Zoom to layer 

Right click the gadm36_VNM_1
Select Rename Layer

Type Province over the layer name of gadm36_VNM_1

Right click the gadm36_VNM_0
Select Rename Layer

Type Country over the layer name of gadm36_VNM_0
The following steps will clip XE "clip:vector"  the layers to remove all data except data for the province of our study region. This will make the QGIS project file load and redraw faster. 

On the QGIS menu bar
Select Vector > Geoprocessing Tools > Clip
Choose Input vector layer = gadm36_VNM_2
Choose Clip layer = Province
In the Clipped box, click browse icon at right end of line

Select Save to file 
Browse to folder named TT-Hue
In File Name box type Districts
In Save As Type box, select SHP files
Save 

Click on Run button
Close

Right click on layer named Clipped > Rename
Type Districts over the name Clipped > Enter
Right click the layer named gadm36_VNM_2

Remove Layer > OK
On the QGIS menu bar
Select Vector > Geoprocessing Tools > Clip
Choose Input vector layer = gadm36_VNM_3
Choose Clip layer = Province
In the Clipped box, click browse icon at right end of line

Select Save to file 
Browse to folder named TT-Hue
In File Name box type Communes
In Save As Type box, select SHP files
Save 

Click on Run button
Close

Right click on layer named Clipped > Rename
Type Communes over the name Clipped > Enter
Right click the layer named gadm36_VNM_3

Remove Layer > OK
Uncheck all layers except Province and District 
Step 4: Save your project

On the QGIS menu bar
Select Project > Save As 

Browse to the folder TT-Hue
Type File name ReferenceMap > Save
Step 5: Adjust layer properties

Change the study region to be transparent so that the layer only shows the borders as an outline.

Right click the Province layer > Properties
Select Symbology tab 

Click on Simple Fill
For Fill Style select no brush 
For Stroke Color select black 
For Stroke Style select Dash Line
For Stroke Width type 0.5

OK 
Right click the District layer > Properties
Select Symbology tab 

Click on Simple Fill
For Fill Style select no brush 
For Stroke Color select black 
For Stroke Style select Dash Line
For Stroke Width type 0.4
OK 
Select Labels tab 

Select Single labels in topmost box

In Label with box, select VARNAME 2
Click on Background tab
Check Draw background box

Click on Placement tab

Select Around Centroid circle

OK
Apply > OK
Example: the reference map of the study area should now look like this:
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Step 6: Save the project and exit
On the QGIS menu bar
Select Project > Save 

On the QGIS menu bar
Select Project > Exit QGIS
Part 2:
Collecting and Analyzing Data for the
Huong River Watershed
DONE - Chapter 6:
Defining the Goals
of the Huong River Watershed
Project 
This chapter includes:

· Describe the sources and path of the Huong River
· Define goals of the Huong River project
The Huong River XE "Huong River"  (Sông Hương or Hương Giang or Perfume River) flows through the city of Huế located in Thừa Thiên-Huế province of central Vietnam.
The river has two sources; both beginning in the Dãy Trường Sơn mountain range and meeting at Bằng Lãng Fork. The Tả Trạch (left tributary) originates in the Trường Đồng mountains and flows northwest towards the fork. The river then flows in a south-north direction past the temples of Hòn Chén and Ngọc Trản, then flows north-west, meandering through the Nguyệt Biều and Luong Quan plains. Continuing on, the Sông Hương (Hương River) flows to the northeast to Huế and passes the resting place of the Nguyễn emperors. The river continues, passing Hen islet and various villages, crossing the Sinh junction (capital of ancient Châu Hóa) before emptying into the Tam Giang lagoon.
From Bằng Lãng to the Thuan An estuary, the river is 30 km long and runs very slowly since the river level is not much above sea level. 
The goals of the Huong River project are:
Using QGIS software and various data sources, 
1. Create a reference map of TT-Hue province

2. Add the outline of the Huong River drainage area to the map

3. Add the Huong River to the map

4. Add elevation contour lines to the map

5. Add hillshading to the map

6. Add points of interest to the map (dams, reservoirs, etc.)

7. Verify some data by ground truthing methods

8. Identify and compare mapping results with other research data

9. Write a summary of observations from the project and suggest some topics for further investigation 
DONE - Chapter 7:
Introducing the HydroSHEDS website
This chapter includes:

· Introducing HydroSHEDS website
HydroSHEDS XE "HydroSHEDS"  (Hydrological data and maps based on Shuttle Elevation Derivatives at multiple Scales) provides hydrographic information in a consistent and comprehensive format for regional and global-scale applications. HydroSHEDS offers a suite of geo-referenced data sets in raster and vector format, including stream networks, watershed boundaries, drainage directions, and ancillary data layers such as flow accumulations, distances, and river topology information.
https://www.hydrosheds.org/
The goal of developing HydroSHEDS was to generate key data layers to support regional and global watershed analyses, hydrological modeling, and freshwater conservation planning at a quality, resolution and extent that has previously been unachievable. Available resolutions range from 3 arc-second (approx. 90 meters at the equator) to 5 minute (approx. 10 km at the equator) with seamless near-global extent.

HydroSHEDS has been developed by the Conservation Science Program of World Wildlife Fund (WWF), in partnership or collaboration with the U.S. Geological Survey (USGS); the International Centre for Tropical Agriculture (CIAT); The Nature Conservancy (TNC); McGill University, Montreal, Canada; the Australian National University, Canberra, Australia; and the Center for Environmental Systems Research (CESR), University of Kassel, Germany. Major funding for this project was provided to WWF by JohnsonDiversey, Inc. and Sealed Air Corporation.

HydroSHEDS data are free for non-commercial and commercial use. See License Agreement for specific restrictions and use requirements.
We will use data from the HydroSHEDS website in the following chapter.
DONE - Chapter 8:
Locating and Downloading
Watershed Data
This chapter includes:

· Download boundary for your watershed study area 
In chapter 5 the study area was identified as the Huong River watershed in Thua Thien – Hue province, Vietnam. The next task is to define the boundaries of the watershed and add those boundaries to the reference map.
Step 1: Create folders for saving data files
In the TT-Hue folder, create a sub-folder named ZippedData
In the TT-Hue folder, create a sub-folder named UnZippedData
Step 2: Access the HydroSHEDS website

http://www.hydrosheds.org
Step 3: Select drainage basin data
Click on Download button in header bar
Click on the arrow to the left of Basin outlines
Click on the arrow to the left of Basin outlines 15sec resolution
Click on the box labeled as_bas_15s_beta.zip
Click on the Download selected files button at the top of the pane
Enter your email address to receive notification when the download is available

Click on Submit request button
In your email folder you should receive two emails:

Request confirmation

HydroSHEDS download link
After the “download link” email arrives

Double click on the link to begin the download
After the download completes, 
Browse to locate the downloaded file

Rename the file by adding “Basin_” to the beginning of the file name

e.g., Basin_hydrosheds-……. 
Copy / paste the file to the folder Zipped_Data in the folder TT-Hue
Step 4: Uncompress the basin data file

Start 7-Zip program

Browse to the folder Zipped_Data
Select the file named Basin_hydrosheds-……. to unzip 

Select Extract icon > OK
In the Extract to box

Browse to the folder Unzipped_Data

OK > OK
Close the 7-Zip program
Step 5: Add data to the reference map 

Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder TT-Hue
Select File Name ReferenceMap
Open

On the QGIS menu bar 
Select Layer > Add Layer > Add vector layer

In Vector data set box 
Browse to folder UnZipped_Data
Select file beginning with Basin_Hydrosheds 
Open

Select file as_bas_15s_beta
Open 

Add
Select file as_bas_15s_beta.shp 

OK

Close

Right click on layer District
Select Move to top

Right click on layer District
Select Zoom to layer
Click on the Identify Features icon [image: image11.png]



Click anywhere inside the district of Hue 
Note the Basin ID = 300926 at the end of layer named as_bas_15s_beta
Right click on the as_bas_15s_beta layer > Properties
Select Source tab 

Select Query Builder button 
Double click BASIN_ID in Fields box 

Single click Operator “=” 

After the “=” type 300926
OK > Apply > OK
Right click the as_bas_15s_beta layer 

Select Export > Save Features As 

In Format box
Select ESRI Shapefile

In File name box
Browse to TT-Hue folder

Type HuongBasin
Save

OK
Right click the as_bas_15s_beta layer 

Select Remove Layer > OK 

Right click the HuongBasin layer > Open Attribute Table

Select Toggle Editing [image: image12.jpg]


 at the top of the screen to turn editing “on” 

Click on New field icon [image: image13.png]



In Name box, type BasinName
In Type box, select Text (string)
In Length box, type 32
OK 
In the newly added field BasinName
type Huong River Basin

Press the Tab key on keyboard

Select Toggle Editing [image: image14.jpg]


 on the toolbar to turn editing “off”  

Save 

Close the attribute table window
Right click the HuongBasin layer > Properties

Select Symbology tab 

Click on Simple Fill
For Fill style select No Brush 
For Stroke color select red > OK
For Stroke width type 0.6
For Stroke style select Dash Line 
Select Labels tab 

Select Single labels in topmost box

In Label with box, select BasinName

Click on Text tab
In Style box

Select Bold 
Click on Background tab
Check Draw background box

Click on Placement tab

Select Offset from Centroid circle

In first box of Offset X,Y, type -5.0
OK
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Step 6: Save Project

On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS > Save

DONE - Chapter 9:
Locating and Downloading
River Data
This chapter includes:

· Researching available river data for your watershed 

Step 1: Download river data XE "river data" 
http://www.hydrosheds.org
Click on Download button in header bar
Click on the arrow to the left of River network 
Click on the arrow to the left of River network 15sec resolution
Click on the box labeled as_riv_15s.zip

Click on the Download selected files button at the top of the pane
Enter your email address to receive notification when the download is available

Click on Submit request button
In your email folder you should receive two emails:

Request confirmation

HydroSHEDS download link

After the “download link” email arrives

Double click on the link to begin the download

After the download completes
Browse to locate the downloaded file

Rename the file adding “River_” to the beginning of the file name

e.g., River_hydrosheds-……. 
Copy / paste the file to the folder Zipped_Data in the folder TT-Hue
Step 2: Uncompress the river data file

Uncompress the downloaded data file (7-Zip is a commonly used program for this purpose)

Start 7-Zip program

Browse to the folder Zipped_Data
Select the file named River_hydrosheds-……. to unzip 
Select Extract icon > OK
In the Extract to box

Browse to the folder Unzipped_Data

OK > OK
Close the 7-Zip program

Step 3: Add river data to the map
Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder TT-Hue
Select File Name ReferenceMap
Open

On the QGIS menu bar 
Select Layer > Add Layer > Add vector layer

In Vector data set box 

Browse to folder UnZipped_Data
Select file beginning with River_hydrosheds-…….
Select file as_riv_15s

Open

OK

Add

Select file as_riv_15s.shp 

Close

On the QGIS menu bar 
Select Vector > Geoprocessing Tools > Clip
Choose Input vector layer = as_riv_15s
Choose Overlay layer = HuongBasin
In the Clipped box, click browse icon at right end of line

Select Save to file 
Browse to folder named TT-Hue
In File Name box type HuongRiver
In Save As Type box, select SHP files
Save 

Click on Run button
Close

Right click on layer named Clipped > Rename
Type HuongRiver over the name Clipped > Enter
Right click the as_riv_15s layer
Remove Layer > OK
Right click the HuongRiver layer > Properties

Select Symbology tab 

Click on Simple Line
For Color select blue > OK
For Stroke width type 0.6
For Stroke style select Solid Line 
OK
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Step 4: Add names of rivers to the attribute table
Add names to several of the main branches of the river.

Right click the HuongRiver layer 

Select Open attribute table 

Select Toggle Editing [image: image17.jpg]


 at the top of the screen to turn editing “on” 

Select the New Field icon 

In the Name box, type RiverName
In the Type box, select Text (string)
In the Length box, type 24
OK 

Locate the row of ARCID = 835832
In the RiverName box, type Huong
Locate the row of ARCID = 836378
In the RiverName box, type Huu Trach
Locate the row of ARCID = 836464
In the RiverName box, type Ta Trach
Press the Tab key on keyboard
Select Toggle Editing [image: image18.jpg]


 on the toolbar to turn editing “off”  

Save 

Close the Attribute table window. 

Step 5: Display names of rivers on the map
Right click the HuongRiver layer > Properties

Select Labels tab 

Select Single labels in topmost box

In Label with box, select RiverName

Click on Text tab
In Font box

Select Arial

In Size box

Select 9
Click on Background tab
Check Draw background box

Click on Placement tab

Select Curved circle

OK
Step 6: Save Project

On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS > Save

DONE - Chapter 10:
Adding Digital Elevation
Contour Lines
This chapter includes:

· About Digital Elevation Model (DEM) data 

· Instructions for adding elevation contour XE "elevation contours"  lines to a map

· Example of contour lines on a map
The goal of this exercise is to learn how to draw elevation contours  XE "contours:elevation"  lines on a map.

The Shuttle Radar Topography Mission (SRTM XE "SRTM" ) obtained elevation data on a near-global scale to generate the most complete high-resolution digital topographic database of Earth. SRTM consisted of a specially modified radar system that flew onboard the Space Shuttle Endeavour during an 11-day mission in February of 2000. 

Use the EarthExplorer website operated by the US Geodetic Survey as the source of data 
Step 1: Download Digital Elevation Model (DEM XE "DEM" ) data file
The EarthExplorer XE "EarthExplorer"  website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. 

In order to download files using EarthExplorer, you must first create a login. 

If you have not already set up an account, do so now.

Go to http://earthexplorer.usgs.gov
On the bar near the top of the page, select Register and complete the form. You may need to ask an instructor to provide some answers. When you are done, a registration confirmation will be sent to your email address. Follow the link to activate your account.

Be sure to record your username and password for future use.

Return to EarthExplorer’s main page. If you are not already logged in

On the Menu bar, select Login > Sign in with your username and password
In the box Address/Place > type Hue, Vietnam > Show
Select Huế, Thua Thien Hue, Vietnam from the list displayed in the Address/Place box

Select the Data Sets button 

Click the + box next to Digital Elevation
Click the + box next to SRTM
Check the box SRTM 1 Arc-second Global

Select the Results button at the bottom of the pane

Select Download Options icon [image: image19.png]


 for the map you want. 

Select the GeoTIFF 1 Arc-second option
Click the Download button

Browse to locate the downloaded file in the folder Downloads.
Copy the file and paste it into the folder TT-Hue.
After the download completes

On the EarthExplorer Menu bar, select Logout
Step 2: Run QGIS and load your reference map
Start QGIS

On the QGIS menu bar 
Select Project > Open Recent 
Select the project ReferenceMap
Right click the Province layer > Zoom to Layer 
Step 3: Install the Contour plugin for vector layers (one time only)
On the QGIS menu bar

Select Plugins > Manage and install plugins

Search Contour
Check box next to Contour plugin on the left
Click on Install Plugin button
Close

Step 4: Add the DEM raster 
On the QGIS menu bar 

Select Layer > Add Layer > Add Raster Layer 

Browse to the folder TT-Hue
Select the file n16_w107_1arc_v3
Open > Add
Close

On the QGIS menu bar 

Select Raster > Projections >Assign Projection

In the Input layer box 

Select the layer n16_w107_1arc_v3

In Desired CRS box
Select WGS 84 
Click on Run button
Close

Step 5: Clip the DEM raster to watershed area size
On the QGIS menu bar 
Select Raster > Extraction > Clip Raster by Mask Layer
In the Input layer box

Select the layer named n16_w107_1arc_v2
In the Mask layer box

Select the layer named HuongBasin
In the Clipped (mask) box, click browse icon at right end of line

Select Save to file 
Browse to folder named TT-Hue
In File Name box type HuongBasinDEM
In Save As Type box, select TIF files
Save 

Check box Match the extent of the clipped raster to the extent of the mask layer 
Click on Run button

Close

In the Layers panel

Right click on layer Clipped (mask)

Select Rename Layer

Type HuongBasinDEM in the layer name

Enter
Uncheck layer named n16_w107_1arc_v2
Step 6: Create the contour layer
On the QGIS menu bar 

Select Raster > Extraction > Contour
In the Input layer box 

Select the layer HuongBasinDEM

Open
Select Interval between contour lines = 500 meters
Scrool down to the Contours box
Select Save to File 

Browse to folder TT-Hue
Select Save as type = SHP files 

Type File Name = Contours

Save
Check box Open output file after running algorithm

Click on Run button
Close

Uncheck the layer HuongRiverDEM
Step 7: Label the elevation contour lines
Select the layer Contours
Right click the Contours layer > Properties

Select Labels tab 

On the dropdown menu that defaults to No labels
Select Single labels
In the Label with box select ELEV
Select the Text tab 

In Font box, select Arial 
In Style box, select Bold
In Size box, type 10

In Color box, select Black
Select Placement tab

Select Curved 
Select on line
Select Symbology tab

Click on Simple line

In Color box, select Green
In Stroke width box, type 0.5
Apply

OK
Your map should look similar to the following map:
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Step 8: Save Project

On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS > Save

Step 9: Analysis
Note that the Huong River generally flows through flat terrain with broad flood plains. The small contour circles north and west of Hue City are artifacts resulting from the vertical resolution accuracy of the SRTM radar being plus or minus 10 meters. These artifacts should be ignored.
DONE - Chapter 11:
Creating Hillshade
This chapter includes:

· How to create hillshade XE "hillshade" 
Hillshading is a technique for creating relief maps, showing the topographical shape of hills and mountains using shading (levels of gray) on a map, just to indicate relative slopes, mountain ridges, not absolute height.
The goal of this exercise is to learn how to create a hillshade view of the watershed on a map.

Note: QGIS offers a complete set of hydrological tools in the SAGA Toolbox. 

On the QGIS menu bar 

Select Processing > Toolbox > SAGA > Terrain Analysis > Hydrology 
Use of the SAGA tools is beyond the scope of this text.
Step 1: Run QGIS and load your reference map
Start QGIS

On the QGIS menu bar 

Select Project > Open Recent 
Select the project ReferenceMap
Uncheck all layers except HuongRiver, HuongBasin, Districts and HuongBasinDEM
Right click the HoungBasin layer > Zoom to Layer 

Step 3: Create hillshade
Right click on the HuongBasinDEM layer > Properties
Select the Symbology icon [image: image21.png]


 

In the Render Type box

Select Singleband Pseudocolor 
In the Interpolation box

Select Discrete

In the color ramp box

Select the dropdown arrow

Select All color ramps

Select BrBG 
Right click inside the color box

Select Invert Color Ramp

In the Mode box

Select Quantile 

Click the Classify button
In the Color Rendering section 

In the Blending Mode box

Select Multiply

In the Resampling section 

In the Zoomed: in box 

Select Bilinear

In the out box 

Select Average

Apply > OK
Your map should look similar to the following map:
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Step 4: Save Project

On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS > Save

DONE - Chapter 12:
Adding Dams, Reservoirs
and Other Points of Interest
This chapter includes:

· Locating information on dams XE "dams"  and reservoirs XE "reservoirs" 
· Adding other point data items
Three methods could be used for locating dams to be plotted in this exercise.
Visual - Google Earth

Local data – e.g., dam inspection report

Ground truthing – site visits

First, a visual search of Google Earth looking for water held in reservoirs yielded three results. It was not possible to determine the names of the reservoirs from Google Earth.

	Name
	Lat
	Lon

	
	16.432
	107.75

	
	16.312
	107.64

	
	16.317
	107.513


Second, local government offices might have useful information. This manner of data collection is left to the researcher. Some information may be posted on the internet. A dam safety report authored by the World Bank in 2019 was located using a Google search. The link is 
http://documents.worldbank.org/curated/en/274601555908465609/Environmental-and-Social-Impact-Assessment-for-Dam-Repair-and-Safety-Improvement-WB8-in-Thua-Thien-Hue-Province
This report listed 9 dams some of which were outside the Huong River basin.
According to the previously mentioned report, Vietnam has the largest dam network and infrastructure in the world besides China and the United States.
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Tabe 2.1. The subproject’s location of 9 reservoirs

	No
	Reservoir
	Construction level
	Location

	1
	Phu Bai 2
	II
	Thuy Phu Commune, Huong Thuy Town

	2
	Ta Rinh
	III
	Thuong Nhat commune, Nam Dong district

	3
	Cua
	IV
	Huong Van commune, Huong Tra town

	4
	Phu Nu
	IV
	Phong An commune, Phong Dien district

	5
	Ba Cua
	IV
	Phu Ke ward, Huong Thuy town

	6
	Khe Rung
	III
	Huong Tho commune, Huong Tra town

	7
	 Cay Coi
	IV
	Phong Xuan commune, Phong Dien district

	8
	Nam Lang
	III
	Thuy Phuong ward , Huong Thuy Town

	9
	Ka Tu
	IV
	Huong Phu commune, Nam Dong district


Third, if ground truthing is possible, additional data could be added to the spreadsheet.

Step 1: Create a data file of the dams in the watershed.  

In Excel create a data file of the following dams in the Huong River watershed of TT-Hue province. Save the file in Unicode Text format. The Unicode Text option will permit you to store Vietnamese characters with proper language markings. 
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TaRinh Nam Dong Thuong Nhat 16.141 107.753
Ta Trach Huong Thuy Duong Hoa village 16.313 107.632
Binh Dien Huong Tra  Binh Dien 16.317 107.503




Addition data could be added in Columns F and beyond. Some examples of additional data might be the power generation, surface area, elevation, etc. 

Start Excel spreadsheet program 

Enter the data shown in the previous table

Format cells in columns D and E as Number with 3 decimal places 

Select File > Save As > Dams in folder TT-Hue 

In the Save as type box, choose Unicode Text 

Save > OK > yes   

File > Exit > Don’t Save  

Step 2: Run QGIS and load your reference map
Start QGIS

On the QGIS menu bar 

Select Project > Open Recent 
Select the project ReferenceMap
Uncheck all layers except HuongRiver and HuongBasin.
Step 3: Add the dam data to the map
Add the dam data as a text layer to your QGIS reference map 

On the QGIS menu bar 
Select Layer > Add Layer > Add Delimited Text Layer 
Browse for the file Dams > Open 

On the File Format line, select Custom Delimeters
In Number of headers lines to discard type 0
In Geometry Definition select Point Coordinates 

The X Field box should contain Lon 
The Y Field box should contain Lat 

In Geometry CRS select Project CRS: ESPG: 4326 - WGS 84 
Click Add > Close
Right click on the Dams layer > Properties 

Select Labels tab  
In the topmost box, select Single Labels 
In the Label with box select Name 

In the Font box, select Arial 
In the Style box select Bold 
In the Color box select blue

Select Buffer tab 

Check box next to Draw Text Buffer 

OK  
Your map should look similar to the following: 
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Step 4: Save the project file 

On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS > Save

Other points of interest might include: water treatment facility inflow, waste water outflow (treated and untreated), water level gauges, etc.
Three reservoirs are clearly visible in Google Earth. Add those resevoirs to the map.

Step 5: Run the Google Earth XE "Google Earth"  program and locate a reservior
Start Google Earth Pro
In the Google Earth search box, type Ta Trach, Vietnam > Search
Step 6: Set the Google Earth coordinate system to match the QGIS project coordinate system
The coordinate system used for this QGIS project must be the same as the coordinate system defined in Google Earth so that the file created in Google Earth will register correctly when imported into the QGIS project.

The coordinate system being used in this QGIS project is WGS 84
On Google Earth menu
Select menu item Tools > Options 

Select the 3D View tab 

In the Show Lat/Long box

Choose the Decimal Degrees button

Apply > OK

Step 7: Draw a polygon around the reservoir
On Google Earth menu

Select the Add Polygon [image: image26.png]


 icon

In the Name box, type Ta Trach Reservoir
You may need to move the parameters box out of the way by left clicking in the title bar, then, while holding the left click button down, drag the box to an unused position on your screen.

Position the cursor at a point on the edge of the water near the dam 
Left click

Move the cursor to a nearby point on the water’s edge and left click

Continue to move and left click going around the water’s edge until the starting point is reached.

OK
Step 8: Save the polygon as a KML file XE "KML file" 
On the main menu File > Save > Save Place As 

Browse to folder named TT-Hue 

Type File Name = Ta Trach Reservoir
Select File Type = KML
Save

Step 9: Add the KML file of the reservoir to QGIS project
Start QGIS
On the main menu select Project > Open 

Browse to the folder where your project is located
Select your project file

Open
On the QGIS side tabs select Add Vector Layer icon [image: image27.png]



For Dataset, browse to folder TT-Hue
In the box to the right of File Name select file type KML
Select the file named Ta Trach Reservoir
Open > Add> Close
Select the Ta Trach Reservoir layer > Properties
Select Symbology tab 

Click on Simple Fill
For Fill Color select blue > OK

Apply > OK
Step 10: Add other reservoirs

Repeat Steps 7 through 10 for the Binh Dien Reservoir
In the Google Earth search box, type 16.31, 107.507 > Search

Repeat Steps 7 through 10 for the Ta Rinh Reservoir
In the Google Earth search box, type 16.14, 107.75 > Search 
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Step 11: Save the Project

On the QGIS main menu 

Select Project > Save 
On the QGIS main menu 

Select Project > Exit QGIS > Save
DONE - Chapter 13:
Rainfall Analysis

This chapter includes:

· Plotting rainfall XE "rainfall"  statistics

· Analyzing rainfall patterns in the watershed

Rain is the primary source of water in the watershed. Knowledge of the characteristics of rainfall patterns adds understanding of hydrological ecology.
Step 1: Run QGIS and load your reference map
Start QGIS

On the QGIS menu bar 

Select Project > Open Recent 
Select the project ReferenceMap
Uncheck all layers except HuongRiver and HuongBasin.
Step 2: Install the Contour plugin for vector layers (one time only)
On the QGIS menu bar

Select Plugins > Manage and install plugins

Search Contour
Check box next to Contour plugin on the left
Click on Install Plugin button
Close
Step 3: Create data for rainfall amounts

Some data was obtained from local sources.
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[image: image30.png]Table 3.3: Annual rainfall (mm) in months at different elevations in Thua Thien Hue province

(1996 —2006)

Month Hue Namdong Aluoi
(10m) (60m) (572 m)
January 89.4 94.2 384
February 61.3 59.1 544
March 29.0 73.5 41.1
April 51.7 107.9 193.2
May 82.9 184.3 257.2
June 114.3 148.0 127.4
July 80.0 158.1 173.7
August 2253 281.0 346.2
September 481.7 511.8 506.0
October 764.8 804.9 756.1
November 618.4 720.0 633.2
December 317.0 338.8 405.4
Year 29158 3,481.5 3,5324

Source: Weather stations of Thua Thien Hue province





In Excel create a data file of the following fictional rainfall gauge measurements during the month of December in the Huong River watershed of TT-Hue province. 
Save the file in Unicode Text format. The Unicode Text option will permit you to store Vietnamese characters with proper language markings. 

Start Excel spreadsheet program 

Enter the data shown in the following table

Format cells in columns D and E as Number with 3 decimal places 

Format cells in columns F and G as Number with 0 decimal places 

Before rainfall can be plotted for this study, more data was needed. Local agencies may have data on rain gauge locations and records. For this case, fictional rainfall data was add at the dam sites to enable elementary plotting.

NOTE: The following data is fictional and is only intended for demonstrating the technique of analyzing rainfall data.
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Name District Commune/wa Lat Lon Elev (m) Rainfall D
Héng Thuong A Ludi Héng Thuong  16.21667 107.2833 590
Thuong L& Nam Déng Thuong L& 16.16666 107.7167 550
Hué Huong Thuy  Thay Bang 16.4333 107.5833 375
Ta Rinh Nam Déng Thuong Nhat 16.141 107.753 620
Ta Trach Huong Thuy DuongHoavilla 16.313 107.632 450

Binh Dién HuongTra  Binh Dién 16.317 107.503 510




Select File > Save As > Rain Gauges in folder TT-Hue 

In the Save as type box, choose Unicode Text 

Save > OK > yes   

File > Exit > Don’t Save  
Step 4: Add a map layer for rainfall 

On the QGIS menu bar 

Select Layer > Add Layer > Add Delimited Text Layer 
Browse for the file Rain Gauges > Open 

On the File Format line, select CSV 

In Number of headers lines to discard type 0

In Geometry Definition select Point Coordinates 

The X Field box should contain Lon 
The Y Field box should contain Lat 

In Geometry CRS select Project CRS: ESPG: 4326 - WGS 84 
Click Add > Close
Step 5: Draw contour lines for rainfall
In  the Layer panel,  uncheck all layers except HuongBasin, HuongRiver, Rain Gauges 
On the QGIS menu bar 

Select Vector > Contour

In the Point layer box, select Rain Gauges
In the Data value box, select RainFall Dec (mm)
In the Contouring section, select contour lines
In the Methods box, select Fixed contour interval

In the Interval box, type 100
In the Label precision box, type 0
In the Units box, type mm
Add > Close

Right click on the Rain Gauges expr layer > Properties 

Select Symbology tab 

Click on Simple Fill
For Stroke Color select black 
For Stroke Style select Dash Line
For Stroke Width type 0.7
Select Labels tab  
In the topmost box, select Single Labels 
In the Label with box select label 

Select Text tab 

In the Font box, select Arial
In the Style box select Bold 
Select Buffer tab 

Check box next to Draw Text Buffer 

OK
Your map should look similar to the following: 
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Step 6: Discussion of results

The hypothetical map shows the maximum rainfall of 600+ mm occurred in the mountainous area of the watershed. Rainfall gradually decreases as the observer moves toward the outflow of the Huong River at the ocean. 

Since this is hypothetical rainfall data, the pattern is quite uniform. In a situation using real data, the pattern would probably not be so uniform.
DONE - Chapter 14:
Investigating Land Use
and Land Coverage

This chapter includes:

· Assessing the characteristics of land use and land coverage

The characteristics of land use XE "land use"  and land coverage XE "land coverage"  directly affect the process of rain falling on the land followed by water infiltration into the soil or runoff of water that the soil can not absorb. Consequently, being knowledgeable about how the land in the watershed is used will affect the study of hyrdology. 

Generally, land use / coverage maps are a popular topic of study and are widely available. The researcher should identify land use maps that provide information relevant to the specific topics under study by contacting local governmental and NGO agencies.

If not land use maps are available, a map of land use and coverage can be prepare using the instructions found in Volume 4, Using QGIS and Remote Sensed Images to AnalyzeLand Use. 
DONE - Chapter 15:
Flow Measurements and
Flood Forecasting

This chapter includes:

· Locating information on flow measurements

· Locating information on flood forecasting

River flow XE "flow"  measurements are critical inputs to flood forecasting XE "flood forecasting" . 
The researcher should identify the agencies responsible for flood forecasting and vist those agencies to understand their information gathering methods and records. The locations of flow measurement instruments should be known by local agencies who are responsible for their operation and maintenance. 
It is left to the researcher to gather data regarding flow volumes. Then the data can be formatted in an Excel table similar to the workflow of Chapter 13 for plotting on the map.
DONE - Chapter 16:
Ground Truthing
This chapter includes:

· Definition of ground truthing

· Using GPS in ground truthing data collection

· Field trip experience

Ground truthing XE "ground truthing"  is a term used to refer to information collected on location. Ground truth information allows digital image data to be related to real features and materials on the ground.

Ground truthing is usually done on site, performing observations and measurements of various properties of the features of the ground resolution cells that are being studied on the map. 

Note-taking: Take detailed notes of your observations when you are on-site. You think you will remember the details – but a few months later, some details will be forgotten or remembered inaccurately.

Local knowledge XE "local knowledge" : Talking with a local person may uncover useful information that is not obvious to your observations. Make a list of questions you need answered the next time you encounter a person who is familiar with your study area.

GPS: When using a GPS XE "GPS"  to determine the coordinates of a location, set the GPS datum to the same datum used by the digital maps in your GIS. One of the most commonly used datums is WGS 84. You can determine the datum used in your digital map by using your GIS software to look in the map’s metadata.

Set the GPS’s coordinate unit format to meet the input requirements of your GIS software, e.g., QGIS input requires that latitude and longitude be formatted as a decimal number so you must set the GPS coordinate unit’s format to degrees and decimals of degrees.

Photos: Photography is a valuable method of preserving your observations of time, place and conditions. Photos taken with a mobile device usually contain embedded latitude and longitude data if locations services are turned on (geotagging). An app such as ExifViewer downloaded to your mobile device will display metadata for each photo including lat / lon. Photos can be displayed on GIS maps if geotagging is enabled in the camera.
Drones: Photos taken from a drone allow you to “visit” locations in your study area that may not be accessible on foot. Although technically, drone photos are classified as another form of remote sensing, viewing your study area from a few hundred feet up can be almost like “being there”.
Internet research: Some ground truthing information can be found on property parcel map websites usually maintained in the US at the county level. The reason for maintaining parcel information at this level is because parcels are the basis for property taxation. 

DONE - Chapter 17:
Printing Maps and Images
This chapter includes:

· Learning how to prepare maps for distribution

· Creating template for the map

· Adding titles, legends and text boxes to the map

These instructions will help you create a template that will make it much easier to recreate a map with the same legend and symbology. This will save you a lot of time; you will not have to recreate the legend and symbology over and over for each map.

Step 1: Start QGIS

Start QGIS
On the QGIS menu bar 

Select Project > Open Recent 
Select the project ReferenceMap
Step 2: Create a new template for printing the map

Select the map layers you want to appear on the printed map XE "printing maps" . 
In the Layers panel on the left of the screen, uncheck layers you don’t want to print. 

Position the map in the screen as you want it to appear when printed. 

(optional) Select the Zoom In icon [image: image33.png]


 and, while holding down the left click button, draw a rectangle around the area that you want to appear when the map is printed.

On the QGIS menu bar 

Select Project > New Print Layout
Type HuongBasin in the Title box
OK

On the menu bar
Select Add Item > Add Map 

Hold down the left click button, draw a rectangle around the area where you want to the map to appear

If the map does not appear the way you want, 

Go back to the main map to adjust the view 

Return to Layout Manager
If the map does not render clearly or sharply

Click on the Refresh icon [image: image34.png]



To keep the map from being accidentally moved, lock its position

Click anywhere inside the map

Right click inside the map

Select menu option Items 

Check Lock Selected Items 
Select menu option Layout  

Select Save as template

Browse to folder TT-Hue 

File Name = HuongBasin
Save 

Step 3: Add Legend XE "legend" : 

A useful feature for formatting the legend titles is the “wrap” feature. You can define a “wrap character” and insert that character in the legend title to force the text following the wrap character to move onto the next line.

On the menu bar
Select Add Item > Add Legend

Click in the map at the position where you want the legend to appear
OK
Right click with the cursor inside the Legend box

Select Item Properties tab

In Main Properties section

In Title box type Legend
Define a Word wrap character (one-time only)

In Wrap Text On box type a character such as @
Open Legend Items section 

Click to remove the check mark in the Auto Update box
Click on any layer you do not want to appear in the legend

Select Delete [image: image35.png]


 icon
Open Fonts section
Click on Title Font > Arial > Font Style > Bold > Size 24 > OK

Click on Sub-Group Fonts > Arial > Font Style > Bold > Size 16 > OK
In Item Font select a font of your choice > OK
Resize the frame of the text box by dragging the edges to fit text
Drag the legend to the upper right corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 4: Add Scale Bar XE "scale bar" :

On the menu bar
Select Add Item > Add Scale Bar

Left click in the lower right corner of the map at the position where you want the Scale Bar to appear
In Height box, type 20
OK
In the Item Properties section

In Scalebar Units box select Kilometers
In the Label Unit Multiplier box type 1.0

In the Label for Units box type Kilometers
In Segments select Left 0 and Right 3
Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Drag the scale bar to the lower right corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 5: Add Map Title XE "title" :

On the menu bar
Select Add Item > Add Label

Click in the map at the position where you want the title to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type Huong River Watershed
Select Font > Arial > Font Style > Bold > Size 16 > OK
Select Alignment Horizontal = Left 

Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Step 6: Add Data Source Labels:

On the menu bar
Select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type an appropriate title for the map

Data Sources:

- World Bank

- HydroSHEDS 
- GADM Database of Global Administrative Areas 

- Google Earth
- USGS
Select Font > Arial > Font Style > Bold > Size 10 > OK
Select Alignment Horizontal = Left 

Check Frame and Background boxes
Position the Data Source text box in the lower left corner of the map.

Resize the frame of the text box by dragging the edges to fit text
Step 7: Add Date and Author Label

On the menu bar, select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK

In the Item Properties section
Date and author name
Select Font > Arial > Font Style > Bold > Size 10 > OK
Select Alignment Horizontal = Left 

Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Position the date label box in the upper part of the map in a place where it does not cover any site labels.

Step 8: Add Grid Lines
Double click in the map 

Select Item Properties
In the Item Properties section
Scroll down to the item Grids
Click on + sign

Click on Modify Grid button

Type 0.2  in both X and Y box

Check Draw coordinates box
Step 9: Create image file of map 

Select menu option Layout 

Select Export as Image 
Choose Files of Type jpg
Name file with an appropriate name

Save

Step 10: Print your map from the saved image

Open the JPG Image of your map using any program that will open a JPG file

File > Print > uncheck fit picture to frame
Print

Step 11: Save as Template:

Select menu option Layout > Save as Template

Browse to folder = TT-Hue 

File name = HuongBasin
Save > Yes

Select menu option Layout > Close
Step 12: Save Project

On the QGIS main menu 
Select Project > Save 

On the QGIS main menu 
Select Project > Exit QGIS

DONE - Chapter 18:
Comparing Results with
Other Researchers

This chapter includes:

· Examine the results produced by other researchers
· Interpret the results of the comparison
Locating other presentations of similar watershed information is left to the researcher.

Appendixes:


Appendix A: References

1. Introduction to Remote Sensing, Fifth Edition, Campbell and Wynne, The Guilford Press, 2011
2. Physical Hydrology, Dingman, Second Edition, Prentice Hall, 2002
3. PMU OF “DAM REHABILITATION AND SAFETY IMPROVEMENT (WB8) IN THUA THIEN HUE PROVINCE” PROJECT, 2019
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