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Preface

This curriculum is the fourth in a series of five volumes on the topic of using QGIS open source software. The intended purpose of these volumes is to provide detailed instructions that can be used as curriculum in GIS classes. Special attention has been paid to English syntax so the text can be easily translated into other languages. Currently the text is available in English and Vietnamese.

Volume One is an introduction to QGIS open source software intended for the first-time user of GIS software. 

Volume Two introduces the use of QGIS for analyzing forest coverage changes using Landsat remote sensed images.

Volume Three is intended for users having basic familiarity with the use of GIS software but who are not necessarily proficient in using QGIS. The instructions in this volume uses a case study that follows the growth of a corn crop from planting through harvesting by analyzing selected Landsat images. 

This volume, the fourth in the series, teaches the use of QGIS software for analyzing land use and land coverage characteristics by classifying values in remote sensed images according to patterns of interest to the user.

Volume Five teaches the use of QGIS software and System Dynamics modeling software (Vensim) for exploring topics in the ecology of water. The curriculum will explore issues such as flow patterns, droughts, flooding, salinity intrusion, sea-level rise and climate change impacts. This volume is still being written as of May 2019.
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Part 1:
General Principles of Remote Sensing
Chapter 1:
About Remote Sensing 
This chapter includes:

· Description of the study of remote sensing
Remote Sensing Definition: Remote sensing is the science of deriving information about an object from measurements made at a distance from that object. 

Examples of methods of acquiring remote-sensed data: aerial photography, satellite-captured images, RADAR(Radio Detection And Ranging), LIDAR(Light Detection And Ranging), etc. 

Uses of remote sensing: agriculture crop monitoring, forestry management, weather forecasting, military intelligence, urban planning, mapping, and many other fields.
Equipment used for remote sensing: satellites, airplanes, drones, cameras, GPS, computers, and a variety of other devices.

Software used in remote sensing: GIS software, Google Earth, internet websites, computer data archives of images, etc.

It is important to understand that many components of the remote sensing process act as parts of a system and cannot be isolated from one another.

For a more complete understanding of remote sensing, a search of the Internet will uncover many sources of current information.  An instructional course, either online or at a local university, will develop understanding and provide hands-on opportunities to work with remote-sensed data.

It is not the intent of this text to develop a thorough understanding of remote sensing. Instead, the purpose of this text is to give the student step-by-step instructions for using GIS software to acquire and manipulate remote-sensed data. By completing the case study in this text, the student will develop a basic understanding of some of the processes involved in analyzing remote-sensed data and learn to draw conclusions from that analysis. Hopefully, this text will motivate students toward more in-depth study of this interesting and expanding field. 

It also is not the intent of this text to be a tutorial on the use of GIS software or, specifically, QGIS, the most popular open source GIS software in use at the time of writing. Although this text will guide the student through the steps of using QGIS to process remote-sensed images, explanations regarding the functions of GIS are brief. Again, an online class or university course is needed to gain a full understanding of GIS software.
Chapter 2:
Defining the Project 
This chapter includes:

· Description of the study project and its goals
This project will analyze satellite images acquired by Landsat 8 satellites to classify different types of land usage (anthropogenic) and land cover (natural).
Multiple steps are needed to study the different types of land use and land coverage that can be observed and analyzed:

First, identify the location of the study area using parameters consistent with satellite image georeferencing. Latitude and longitude coordinates can be determined by GPS. 
Next, view the area using Google Earth using the area’s latitude and longitude. Comparing visible imagery from Google Earth and satellite images helps visualized pattern correlation between difference types of remotely sensed images.

Analyze satellite images using the supervised and unsupervised classification methods.

At the time of this writing, an excellent explanation of supervised and unsupervised classification of remote sensed images was posted on YouTube at  https://www.youtube.com/watch?v=5Gp5xLbiAr0

Practice ground truthing to verify information in your study area and assess accuracy of the analysis of the images.
Finally, draw some conclusions from the various observations.

Part 2:
Creating Maps
Using GIS
Chapter 3:
Installing QGIS and 7-Zip
This chapter includes:

· Instructions to download and install QGIS 
· Instructions to download and install 7-Zip for uncompressing files

Step 1: QGIS Installation for Windows PC
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:

http://www.qgis.org/en/site/forusers/download.html
Choose QGIS Standalone Installer Version 3.6. or later
To see whether your computer has a 32 or 64-bit processor go to Control Panel > System and view the “System type” in the System section. 
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If you are unsure as to whether to install a 32- or 64-bit version of QGIS, select the 32-bit version.

Open the QGIS installer and follow the instructions.

NOTE: At the time this curriculum was prepared, the current version of QGIS was 3.6.3, dated April 2019.

Configure the QGIS default options:

Start QGIS
Select from menu option Settings > Options
Select General tab

Select Style that corresponds to your computer operating system

Change Icon Size to 32
Change Font to Arial (or your choice)

Change Size to 12 (or your choice)
OK
Select from menu option View > Toolbars > Manage Layers Toolbar

To correctly display foreign language characters

On the menu bar select Settings->Options->Data Sources
In the Data source handling section

Uncheck the box next to Ignore shapefile encoding declaration
OK

On the QGIS status bar along the bottom of the QGIS window
Check the Render box
On the menu bar select Project > Exit QGIS
Step 2: QGIS Installation for Mac
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:

http://www.qgis.org/en/site/forusers/download.html
Choose QGIS macOS Installer Version 3.6.

Perform same instructions as in Step 1

In addition, this change is needed to solve a bug related to clipping raster files

On the menu bar select QGIS 3.6 > Preferences > System 

Open Environment section

Check box Use custom variables
Click on the plus sign

In Apply column, select Append
In Variable column type PATH
In Value column copy / paste the following text

:/Library/Frameworks/GDAL.framework/Programs: /Library/Frameworks/PROJ.framework/Programs: /Library/Frameworks/SQLite3.framework/Programs:/Library/Frameworks/UnixImageIO.framework/Programs

When you are finished, your screen should look like this:
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OK

On the menu bar select QGIS 3 > Quit QGIS 3
Step 3. Software Installation - 7-Zip XE "7-Zip"  

(Windows User) Download and install 7-Zip from this website:



https://www.7-zip.org
Open the 7-Zip installer and follow the instructions.


Any similar program, such as WinRAR, can be used as well.

(Mac Users) Download and install Keka from this website: 

https://www.keka.io 

Open the Keka installer and follow the instructions. 

Then set Keka as the default extraction application using this website:

https://github.com/aonez/Keka/wiki/Default-application

Follow instructions under Set Keka as the Default Extraction Application

Doing this will help in Chapter 7: Acquiring Remote Sensed Data, Step 4. It will allow Keka to automatically uncompress or extract the downloaded files.

Step 4. Learning to use QGIS software

Search the internet for resources for learning QGIS.

One online resource for learning QGIS is https://foss4geo.wordpress.com/
Chapter 4:
Locating GIS Maps 
This chapter includes:

· Locating appropriate digital maps
One useful source of digital maps for GIS systems is the website for GADM (Database of Global Administrative Areas), which can be accessed at http://www.gadm.org/  

GADM XE "GADM"  is a spatial database of the location of the world's administrative areas (or administrative boundaries) for use in GIS software.  The coordinate reference system is “latitude/longitude” and uses the datum WGS84. These maps can contain up to 5 levels of administrative subdivisions. A general understanding of the concept of “administrative areas” is presented on Wikipedia at http://en.wikipedia.org/wiki/Administrative_division
Other useful sites containing data for roads, rivers, population data, etc.:

http://www.diva-gis.org/gdata 

https://nationalmap.gov/small_scale/

Chapter 5:
Defining the Project
Study Area
This chapter includes:

· Define the purpose of the study

· Define the area to be studied
Purpose
As discussed in Chapter 2, the purpose of this study is to analyze satellite images acquired by Landsat satellites to classify different types of land usage (anthropogenic) and land cover (natural). More specifically, the analysis will identify the different land usage in a mixed urban/rural location in a river valley of northern Idaho, USA.

The center of the study area is near N46.4, W117.0
[image: image5.jpg]



Google Earth image - 2018

The study area provides some general orientation to the geography to be analyzed. The surrounding characteristics of the study area may provide some helpful clues to aid in the analysis.

Note: It is often helpful to see both the instructions in this Word document and the QGIS application on the computer screen at the same time. One way to do this is to “split the screen”. How to split the screen depends on what version of the operating system you are running on your computer. Search the internet for how to split the screen for your version, e.g. “How to split the screen in Windows 10”. On iMac, you can resize the windows manually, but there is not a function for it.
Step 1: Create folders for this project
Create a folder on the C drive for your work - name the folder GISRemoteSensing
In the GISRemoteSensing folder, create a sub-folder named Valley 

In the Valley folder, create a sub-folder named Classify
In the Valley folder, create a sub-folder named Landsat
In the Landsat folder, create a sub-folder named Clipped
In the Landsat folder, create a sub-folder named Reflectance
Step 2: Start QGIS and save the project file
Start QGIS

Select Project > New
On the QGIS menu bar 
Select Project > Save As 

Browse to the folder Valley
Type File name LandUse
Save
Step 3: Exit QGIS
(PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 

Select QGIS > Quit QGIS > Save
Part 3:
Adding Remote Sensed Data in GIS
Chapter 6:
Locating Remote Sensed Data
This chapter includes:

· Identifying sources of remote sensed images

· Understanding the data available in the Landsat archive

Identifying sources of remote sensed images
The Landsat archive is one of the largest and most accessible sources of remote sensed images. For our exercises, we will use Landsat images. However, after you become familiar with the process of using remote sensed images in GIS, you should research and bookmark other sources of images to provide a strong variety of tools for your future remote sensing and GIS needs.

The Landsat XE "Landsat"  satellite imaging program was designed by scientists and sponsored by the US government to make large-scale, continuous surveys of the Earth's land areas. Today, the Landsat image library contains the longest continuous record of environmental conditions of land areas covering our world.

To date, eight Landsat satellites have been launched, beginning with Landsat 1 in 1972, up to Landsat 8 in 2013. Currently, both Landsat 7 and 8 are operational. Each satellite makes a complete orbit every 99 minutes, completes about 14 full orbits each day, and crosses every point on Earth once every 16 days. The satellites’ orbits are offset to allow 8-day repeat coverage of any Landsat scene area on the globe. Between the two satellites, more than 1,000 scenes are added to the USGS archive each day.
Although sensing equipment has been continuously improved, great effort has gone into keeping the format, resolution, and spectral sampling parameters consistent. This consistency allows for comparison of land area characteristics to analyze changes during the 40+ years of Landsat data collection.

For our purposes, one of the most attractive features of Landsat images is that the US government has made all 40+ years of data available on the internet for downloading at no cost to the public. We will make use of the Landsat image data in this textbook as one of our primary sources in learning about remote sensing.

This textbook is meant to give you only a very brief introduction to Landsat imagery; a complete discussion of the history and specifications of Landsat are beyond the scope of this textbook. For more information on Landsat, visit the USGS website at www.usgs.gov.  Another excellent source of Landsat information can be found in Chapter 6 of Introduction to Remote Sensing, Fifth Edition, by James B. Campbell and Randolph H. Wynne. Wikipedia also contains useful information about Landsat at https://en.wikipedia.org/wiki/Landsat_program.

EarthExplorer XE "EarthExplorer" 

 XE "USGS website:EarthExplorer" 
The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. 

In order to download files using EarthExplorer, you must first create a login. 

If you have not already set up an account, do so now.

Go to http://earthexplorer.usgs.gov
On the bar near the top of the page, select Register and complete the form. You may need to ask an instructor to provide some answers. When you are done, a registration confirmation will be sent to your email address. Follow the link to activate your account.

Be sure to record your username and password for future use.

Return to EarthExplorer’s main page. If you are not already logged in, on the bar near the top of the page, select Login > Sign in with your username and password.

In the Address/Place box > type Lewiston, ID > Show
Select Lewiston, ID, USA
In the Coordinates box, select the Decimal tab.

Record the latitude and longitude, which will be used in the next step. Note that the longitude has a negative sign.

On the EarthExplorer menu bar, select Logout.

GLOVIS XE "GLOVIS"  (USGS Global Visualization Viewer)
GLOVIS is another format for viewing Landsat images. 

Go to http://glovis.usgs.gov
Click on the Launch GLOVIS button.

If asked “Would you like a tour?”, select No Tour Please.
In the upper right corner of the screen, click on the [image: image6.png]


button and select Lat/Lng.
Type the latitude and longitude from the previous step.

Click on the Jump to Location button

You can explore the many features of GLOVIS later.

LandsatLook XE "LandsatLook" 

 XE "USGS website:LandsatLook"  
Another place to search for remote sensed image data is on the easy-to-use USGS website http://landsatlook.usgs.gov This site allows you to search for a location and then zoom in to see the full resolution data of all Landsat scenes available. When you select an image to download, the request will be processed by EarthExplorer.

Esri’s Landsat Explorer provides quick and easy access to more than 500,000 Landsat images. Normalized Difference Vegetation Index analysis are available for world-wide locations; however, the resolution is not detailed enough for use in classification of this project.
http://landsatexplorer.esri.com/ 

Chapter 7:
About Semi-Automatic Classification Plugin (SCP)
This chapter includes:

· Introduction to Semi-Automatic Classification Plugin (SCP)
· Installing the SCP plugin in QGIS
· Learning about SCP capabilities and operation
The Semi-Automatic Classification Plugin (SCP XE "SCP" ) is a free open source plugin for QGIS that allows for the semi-automatic classification (supervised and unsupervised) of remote sensing images. Also, it provides several tools for the download of free images (Landsat, Sentinel-2, Sentinel-3, ASTER, MODIS), the preprocessing of images, the postprocessing of classifications, and accuracy assessment. Citing: Congedo Luca (2016). Semi-Automatic Classiﬁcation Plugin Documentation
Current SCP plugin version 6.2.9 as of 4 March 2019

Step 1: Installing SCP plugin in QGIS (One time only) 

Start QGIS
On the QGIS menu bar

Select Plugins > Manage and install plugins

Search Semi-Automatic Classification Plugin
Check box next to Semi-Automatic Classification plugin on the left
Click on Install Plugin button
Close
Note: Some problems were encountered installing on Mac. 

Follow the instructions carefully. 

If some modules are not found
Start terminal

type python3.6 -m pip install –U numpy and push enter
type python3.6 -m pip install –U scipy and push enter
type python3.6 -m pip install –U matplotlib and push enter
Configurating available RAM is recommended to reduce processing time. 

On the QGIS menu bar
Select SCP > Settings > Processing
Set the Available RAM (MB) to a value of half of the system RAM. 
For instance, if your system has 2GB of RAM, set the value to 1024MB
Step 2: Learning about SCP capabilities and operation

On the QGIS menu bar 

Select SCP > Show Plugin

In the SCP dock panel are links to tutorials and the SCP user manual. These are good tools for learning the details of the many features of SCP
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Step 3: Save and exit QGIS

 (PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar

Select Project > Save
Select QGIS > Quit QGIS> Save
Chapter 8:
Acquiring Remote Sensed Data
This chapter includes:

· Researching available data for your study area 
· Downloading Landsat data

· Some useful facts about Landsat data

The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. You will download Landsat images covering your study area. A good description of the Landsat program can be found at http://en.wikipedia.org/wiki/Landsat_program
Two versions of Landsat images are available. 
Landsat Level 1 XE "Landsat Level 1"  images are georeferenced for consistency but are not corrected for atmospheric conditions. Level 1 images are available very quickly after the image is captured by the Landsat sensors.

Landsat Level 2 XE "Landsat Level 2"  images have atmospheric corrections applied to Level 1 data to produce surface reflectance measurements. Surface Reflectance products provide an estimate of the surface spectral reflectance as it would be measured at ground level in the absence of atmospheric scattering or absorption. Level 2 images must be “ordered” from USGS and are not delivered until several days after the order is placed. Level 1 images are available for immediate download.

Why use Level 2 instead of Level 1? The primary reason is that Level 2 images have been atmospherically corrected so the consistency between images captured on different days is much higher.
The process of producing Level 2 images can best be researched online for those interested in the details but is beyond the scope of this curriculum.

SCP has the capability of immediate downloading of Level 1 images and the capability to apply atmospheric corrections to the Level 1 images.

Two methods can be used to add Landsat images to QGIS: 
1) manual download and 
2) semi-automated download. 
Acquire Data (2 methods)
Method 1 – Download from the USGS website

Go to http://earthexplorer.usgs.gov/
On the EarthExplorer menu bar, select Login > Sign in with your username and password. If you have not already set up an account, follow the instructions in the previous chapter.   
Step 1: Define the parameters for Landsat images
In the box Address/Place > type Lewiston, ID > Show
Select the location you want to find from the list displayed in the Address/Place box
Select a Date Range 
For this exercise choose the date range of 08/01/2013 to 8/30/2013. 
Select the Data Sets button 
Click the + box next to Landsat
Click the + box next to Landsat Collection 1 Level 1
Check the box Landsat 8 ORI/TIRS C1 Level 1
Click on the Additional Criteria button
Select Land Cloud Cover amount of less than 20%
Select the Results button at the bottom of the pane
Select image dated August 15, 2013 
Select Download Options icon 
[image: image8] for the map you chose
Click the Download button next to Level 1 GeoTIFF Data Product
After the Landsat file download completes
on the EarthExplorer menu bar, select Logout 
Step 2: Uncompress the Landsat file

Uncompress the downloaded Landsat file (7-Zip is a commonly used program for this purpose)
Browse to the folder Landsat
Right click on the Landsat gz file and select 7-Zip (or whatever program you use to uncompress files)
Select Extract Here option
Right click on the Landsat tar file and select 7-Zip (or whatever program you use to uncompress files)
Select Extract Here option
(Mac Users) Using Keka (Mac version of 7-Zip), skip this step. Setting Keka as the default extraction application in Chapter 3, Step 3 will allow Keka to automatically uncompress or extract the downloaded Landsat file.
When you are finished, you can delete the gz and tar files to save disc space
Copy the downloaded Landsat files ending in b2 through b7 into the folder named Landsat

Step 3: Load Landsat images into QGIS

Start QGIS
On the QGIS menu bar
Select Project > Open Recent
Browse to the folder Valley
Select LandUse
In QGIS, add raster layers that contains the image bands to be classified

On the QGIS menu bar
Select Layer > Add layer > Add Raster Layer 
For Raster Dataset, browse to folder Landsat 

In the box to the right of File Name select GeoTIFF

Select the file names ending in b2,b3,b4,b5,b6,b7
Open > Add > Close
Method 2 – download Landsat images using SCP


Step 1: Login Information
Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to the folder Valley
Select LandUse
On the QGIS menu bar
Select SCP > Download products

Select the Login data tab

In ers.cr.usgs.gov section

In User box, type the user-name from Chapter 6
In Password box, type password from Chapter 6
Check the Remember box

Select the Search tab

In UL X(Lon) box, type -117.1
In UL Y(Lat) box, type 46.4

In LR X(Lon) box, type -116.9
In LR Y(Lat) box, type 46.1

In Products box, select L8 ORI/TIRS
In Date from box, type 20130625
In Date to box, type 20130630

In Max cloud cover (%) box, select 20 
Click the Find icon [image: image9.png]



Select the Landsat image displayed in the Product window
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Select the Download options tab

Check only Landsat bands 2, 3, 4, 5, 6, 7 and the ancillary data boxes
Uncheck Only if preview in layers

Uncheck Preprocess images

Click Run button
In Folder box, browse to Landsat folder

Click on Select Folder icon

The download could take a few minutes depending on your internet connection speed. The download progress is displayed in a bar on the main QGIS screen.
Click X in upper right to close the SCP panel
Step 2: Define the Band Set XE "Band Set" 
Defining the band set is a requirement of SCP functions
On the QGIS menu bar
Select SCP > Band set

In the Single band list section
Click the Refresh button to access the layer list [image: image11.png]



Click the Select All button [image: image12.png]



Uncheck the band ending in BQA.TIF
Click the plus sign button to add the layers to Band set 1 [image: image13.png]



In Quick wavelength settings box, select Landsat 8 OLI
Check Create virtual raster of band set box

Click Run button

In Folder box, browse to Landsat folder

Click on Select Folder button
Click X to exit the SCP activity

[image: image14.png]Q Landuse - QGIS - o x
Project Edit View Layer Settings Plugins Vecth Raster Database Web Mesh SCP Processing Help
DEERRY I$pLS ¢
B@V: /0 'EJ R 28
oo B2 - 2o oBEOMMx e« 1sr0,0:3 MinG S mav 1 o BTN 102 S2:s= @0imiim

Layers

n
21424
v ¥LCO8_L1TP_O...
n0
27064
Vv ¥1C08_L1TP_O...
L)
33291
v ¥LCO8_L1TP_0...
n0
28512
v ¥LCO8_L1TP_O...
n0
25684

‘

SOHDDIENBAS

Tvpe to locate (... 1 legerdir 495484.5143298 % :1:109467 ~ &1n 10092 a 0.0 <2 v Render ®#FPSG:32611 @




Select the layer with name ending in vrt (layer at top of list)

Hint: Expand the Layers box to show the full file name
In RBG box, type 4-3-2
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Press the Enter Button
(may need to select the drop-down menu, so a new layer, ‘Virtual band set 1’ will appear)
Uncheck all layers except Virtual Band Set 1 
Step 3: Clip images XE "Clip images" 
Clip the data images to limit their size to the study area and reduce processing time.

Move the cursor to near the coordinate 496000,5140600

Notice that two rivers meet near this location

This will be the center of the area to be studied

Click on Zoom in icon [image: image16.png]



Move cursor over the location where the two rivers meet

Click left mouse button 
At the same location, click left mouse button twice more

Select SCP > Preprocessing > Clip Multiple Rasters 
In Select input band set box, select 1
In Clip coordinates section
Click on plus sign next to Show [image: image17.png]



Switch to the QGIS main panel by minimizing the box
Left click in vicinity of upper left corner of box in illustration below

Right click in vicinity of lower right corner of box in illustration below
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Switch back to SCP panel

Click Run button

In Folder box, browse to Clipped folder

Click on Select Folder button
Open

Click X to exit the SCP plugin
In the layer panel on the left side of the screen

Left click on the first layer with name starting with LC
Hold down the Shift key and left click the last LC layer

With the cursor inside the group of selected layers

Right click and select Remove layer > OK

In the layer panel on the left side of the screen

Left click on the Virtual Band Set 1 layer 

Right click and select Remove layer > OK
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Step 4: Redefine the Band Set
Select SCP > Band set
In Band set definition section

Click on Reset icon to clear the list [image: image20.png]



Yes
In the Single band list section
Click the Refresh button to access the layer list [image: image21.png]



Highlight bands 2 through 7

Click the plus sign button to add the layers to Band set 1 [image: image22.png]



In Band set definition section 
In Quick wavelength settings box, select Band order
In Quick wavelength settings box, select Landsat 8 OLI
In Band set tools section

Check Create virtual raster of band set box

Click Run button

In Folder box, browse to Landsat folder

Click on Select Folder button or Open button
Click X to exit SCP plugin
Select layer ending in vrt 
In RBG box, select 3-2-1 
Select the virtual band layer
In RBG box, select 4-3-2
Uncheck all layers starting with clip
Right click layer Virtual Band Set 1

Select Move to top

Click on Zoom to input image extent icon [image: image23.png]


 

[image: image24.jpg]



Step 5: Save and Exit
 (PC users) On the QGIS menu bar
Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 
Select Project > Save
Select QGIS > Quit QGIS
Part 4:
Analyzing
Remote Sensed
Data
Chapter 9:
Image Interpretation

This chapter includes:

· Interpreting single images
· Interpreting analyzed images
Interpreting single images XE "Interpreting images" 
 XE "Interpretation" Photos and satellite images are useful primarily because they can be used to identify the position and properties of features that are of interest. Interpreters use size, shape, color, brightness, texture and location to identify features and convert images into information. Image interpreters must have some familiarity with the features of interest. Ground truthing is essential to developing the local knowledge required for accurate image interpretation. 
The practice of image interpretation is a well-developed discipline and uses many specialized techniques. A detailed description of image interpretation is beyond the scope of this handbook. Books and internet resources are available that teach this skill in detail. 
Satellite images are like maps: they are full of useful and interesting information, provided you have a key. It is important to remember that satellite images are an overhead view -- an unfamiliar perspective.  The following is a review a few of the highlights of image interpretation focusing on satellite images. 
Look for a Scale: One of the first things people want to do when they look at a satellite image is to identify the places that are familiar to them: their home, school, or place of business; a favorite park or tourist attraction; or a natural feature like a lake, river, or mountain ridge. The level of detail depends on the image’s spatial resolution. Like digital photographs, satellite images are made up of little dots called pixels. The width of each pixel is the satellite’s spatial resolution. For the Landsat images we will be using, the resolution for one pixel is 30 meters on each side (900 sq meters).

Look for patterns, shapes, and textures: Bodies of water—rivers, lakes, and oceans—are often the simplest features to identify because they tend to have unique shapes and they show up on maps. Other obvious patterns come from the way people use the land. Farms usually have geometric shapes—circles or rectangles—that stand out against the more random patterns seen in nature. When people cut down a forest, the clearing is often square or has a series of herring-bone lines that form along roads. A straight line anywhere in an image is almost certainly human-made, and may be a road, a canal, or some type of boundary made visible by land use.

Define Colors: The colors in an image will depend on what kind of light the satellite instrument measured. True-color images use visible light—red, green and blue wavelengths—so the colors are similar to what a person would see from space. False-color images incorporate infrared light and may take on unexpected colors.

Water: Water absorbs light, so it is usually black or dark blue. 
Plants: Plants come in different shades of green, grasslands tend to be pale green, while forests are very dark green. Land used for agriculture is often much brighter in tone than natural vegetation. In some locations (high and mid latitudes), plant color depends on the season. Spring vegetation tends to be paler than dense summer vegetation. Fall vegetation can be red, orange, yellow, and tan; leafless and withered winter vegetation is brown. For these reasons, it is helpful to know when the image was collected.

Find North: If you know where north is, you can figure out if that mountain range is running north to south or east to west, or if a city is on the east side of the river or the west. These details can help you match the features to a map

Consider your Prior Knowledge: Perhaps the most powerful tool for interpreting a image is knowledge of the place. If you know that a wildfire burned through a forest last year, it’s easy to figure out that the dark brown patch of forest is probably a burn scar, not a volcanic flow or shadow.

Interpreting analyzed images

Because most of us are not trained and experienced interpreters of remote sensed images, we will use some techniques of automated image analysis to help us understand the image data we are viewing. One specialized analysis technique is Normalized Difference Vegetation Index (NDVI XE "NDVI" ). 
Using established processes such as NDVI transfers our interpretation requirements from examining raw remote sensed image data to understanding and interpreting automated analysis methods and outputs. 
Chapter 10:
Ground Truth Sampling

This chapter includes:

· Definition of ground truthing

· Using GPS in ground truthing data collection

· Sources of useful information for ground truthing
Ground truthing XE "Ground truthing"  is a term used in remote sensing to refer to information collected on location. Ground truth information allows digital image data to be related to real features and materials on the ground.

Ground truthing is usually done on site, performing observations and measurements of various properties of the features of the ground resolution cells that are being studied on the remotely sensed digital image. 

Note-taking: Take detailed notes of your observations when you are on-site. You think you will remember the details – but a few months later, some details will be forgotten or remembered inaccurately.

Local knowledge XE "Local knowledge" : Talking with a local person may uncover useful information that is not obvious to your observations. Make a list of questions you need answered the next time you encounter a person who is familiar with your study area.
GPS: When using a GPS to determine the coordinates of a location, set the GPS datum to the same datum used by the digital maps in your GIS. One of the most commonly used datums is WGS 84. You can determine the datum used in your digital map by using your GIS software to look in the map’s metadata.

Set the GPS’s coordinate unit format to meet the input requirements of your GIS software, e.g., QGIS input requires that latitude and longitude be formatted as a decimal number so you must set the GPS coordinate unit’s format to degrees and decimals of degrees.

Photos: Photography is a valuable method of preserving your observations of time, place and conditions. Photos taken with a mobile device usually contain embedded latitude and longitude data if locations services are turned on (geotagging). An app such as ExifViewer downloaded to your mobile device will display metadata for each photo including lat / lon. Photos can be displayed on GIS maps if geotagging is enabled in the camera.
Drones: Photos taken from a drone allow you to “visit” locations in your study area that may not be accessible on foot. Although technically, drone photos are classified as another form of remote sensing, viewing your study area from a few hundred feet up can be almost like “being there”.
Internet research: Some ground truthing information can be found on property parcel map websites usually maintained in the US at the county level. The reason for maintaining parcel information at this level is because parcels are the basis for property taxation. 

Chapter 11:
Supervised Classification
This chapter includes:

· Purpose and process of classification
· Creating a classification layer
Purpose and process of classification
Digital image classification XE "Classification"  is the process of assigning pixels to classes. Usually each pixel is treated as an individual unit composed of values in several spectral bands. By comparing pixels to one another and to pixels of known identity, it is possible to assemble groups of similar pixels into classes that are associated with the informational categories of interest to users of remotely sensed data. These classes form regions on a map or an image, so that after classification the digital image is presented as a mosaic of uniform parcels, each identified by a color or symbol. These classes are, in theory, homogeneous: Pixels within classes are spectrally more similar to one another than they are to pixels in other classes. In practice, of course, each class will display some diversity, as each scene will exhibit some variability within classes. (Introduction to Remote Sensing, Fifth Edition, 2011, Campbell and Wynne, Guilford, p 335)
At the time of this writing, an excellent explanation of supervised and unsupervised classification of remote sensed images was posted on YouTube at  https://www.youtube.com/watch?v=5Gp5xLbiAr0

Perhaps the most widely used classification system for land use and land coverage is the U.S. Geological Survey’s Land Use and Land Cover classification system, developed in the 1970s. This classification system is sometimes referred to as the Anderson Land Use Classification Scheme, named after one of the developers.
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Source: JAMES R. ANDERSON, ERNEST E. HARDY, JOHN T. ROACH, and RICHARD E. WITMER, 1976, GEOLOGICAL SURVEY PROFESSIONAL PAPER 964, A revision of the land use classification system as presented in U.S. Geological Survey Circular 671, p. 8, Fourth printing 1983, For sale by the Distribution Branch, U.S. Geological Survey, 604 South Pickett Street, Alexandria, VA 22304

Supervised vs. unsupervised classification:

In this exercise we are performing supervised classification. In supervised classification pixels are selected that represent a classification for the software to search for and organize. We will set 4 classes and label them to look for distinct pixel characteristics.

In unsupervised classification the software organizes the pixels based on common characteristics but does not classify them (useful for large amounts of data), the number of classes can be specified and an appropriate classification algorithm is chosen, but the classes are not specified like in supervised classification

An understanding of the use of the Normalized Difference Vegetation Index (NDVI) is necessary to perform the steps in this section. Information about NDVI can be found in Volume 3, Using QGIS and Landsat Images to Monitor Seasonal Crop Development, chapter 9. More resources describing the use of NDVI can be found on the internet.

The goal of this project is to classify the pixels in the study area into four distinct categories: 
· Class 1 = Water (e.g. surface water);

· Class 2 = Built-up (e.g. artificial areas, buildings and asphalt);

· Class 3 = Vegetation (e.g. grassland or trees);

· Class 4 = Bare soil (e.g. bare soil or low vegetation).

Step 1: Select the band set from clipped images
Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to the folder Valley
Select LandUse
Redefine the bands set following the instructions in Step 4 of Chapter 8. 

Step 2: Convert bands to reflectance
On the QGIS menu bar 

Select SCP > Preprocessing > Landsat

In Directory containing Landsat images box
Browse to folder Clipped containing the clipped Landsat bands

Click on Select folder button or Open button
In Select MTL file box
Browse to file in folder Landsat 

Browse to folder name starting with LC08
Select file with name ending in MTL 
Click on Open button
Check Apply DOS1 atmospheric correction box

Check only to blue and green bands box
Check Create Band set and use Band set tools box
Click Run button
Select Reflectance folder
Wait for process to complete

Click X to exit SCP plugin
In the layer panel on the left side of the screen

Left click on the first layer with name starting with clip
Hold down the Shift key and left click the last clip layer

With the cursor inside the group of selected layers

Right click and select Remove layer > OK

In the layer panel on the left side of the screen

Left click on the Virtual Band Set 1 layer 

Right click and select Remove layer > OK

Select layer with name ending in vrt (layer at top of list)
In RBG box, select 3-2-1 
Select Virtual Band Set 1

In RGB box, select 4-3-2

Uncheck all layers except Virtual Band Set 1 
Click on Zoom to input image extent icon [image: image26.png]
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Step 3: Create the Training Area Input file
On the QGIS menu bar 

Select SCP > Show Plugin

Click on X to close the popup window

Click on SCP Dock tab at bottom of the panel on left

Select Training Input tab (vertical on left)
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Click the Create a new training input icon [image: image29.png]



Browse to folder Valley
In the File Name box, type Training
Save 
Step 4: Create a Region of Interest (ROI) for water
ROIs are polygons used for the definition of the spectral characteristics of land cover classes. Spectral signatures of classes are calculated from the ROIs and those spectral signatures are then used in the classification process.

Four Regions of Interest (ROIs) will be defined:
1. MC ID = 1 and MC Info = Water (e.g. surface water);
2. MC ID = 2 and MC Info = Built-up (e.g. artificial areas, buildings and asphalt);
3. MC ID = 3 and MC Info = Vegetation (e.g. grassland or trees);
4. MC ID = 4 and MC Info = Bare soil (e.g. bare soil or low vegetation)
A good starting point is to classify some of the most obvious features in the image. The two rivers that meet in the center of the image are a good place to begin.

Create and save an ROI defining the rivers using the Region Growing Algorithm
The Region Growing Algorithm (RGA) is useful for creating training areas. 

The Region Growing Algorithm XE "Region Growing Algorithm"  selects a group of pixels similar to a seed pixel by considering the spectral similarity (i.e. spectral distance) of adjacent pixels. 
The RGA is activated by clicking on the Activate ROI pointer icon [image: image30.png]


 in the SCP Working Toolbar
Once this pointer is activated, moving the cursor over any pixel in the image will show the NDVI value of that pixel. This is helpful in exploring the surrounding pixel’s NDVI values to see how similar neighboring pixel values are.

The parameter distance (Dist)  XE "Dist" is related to the similarity of pixel values to the seed pixel - the lower the value, the more similar are the selected pixels. In the following example, the red band was calculated using DIST=0.01 and blue band was calculated using DIST = 0.06 with all other values constant. Note that the 0.06 setting would include more “similar” pixels than the 0.01 setting. 
[image: image31.png]sanjen




Another useful parameter is the maximum width (Max)  XE "Max" which is the length of the side of a square centered on the seed pixel for potential pixels to evaluate for including in the training area. If all the pixels had the same value, the training area would be a square with side length = Max. Note that if the Max is set to 400 then 400 times 30 m = 12 km.

The minimum size (Min)  XE "Min" is used as a constraint (for every single band), selecting at least the pixels that are more similar to the seed pixel until the number of selected pixels equals the minimum size.
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Set Dist to 0.04 
Set Min to 60 

Set Max to 900 

Click the Activate ROI pointer icon [image: image33.png]



Move the cursor over some points in the middle of the river

Note that the NDVI values are in the range of -0.04 to -0.035

Move the cursor over a pixel whose value is about -0.04 near the location where the two rivers meet
Left click and wait for the region to grow 

The ROI should look like the brown area in this image

[image: image34.jpg]



Click in MC Info box and type Water 

Click in C Info box and type Rivers 
Click on the Save temporary ROI to training input icon [image: image35.png]


 
Click on Macroclass list tab

Double click in the Color column of the MC Id box = Water 
Select blue color

OK
Step 5: Preview a classification of the image
Experiment with previewing a classification of the image with only the rivers ROI active.

Click on Classification tab

Check Use MC ID box

When using Macroclass ID all the spectral signatures are evaluated separately, and each pixel is classified with the corresponding MC ID (i.e. there is no combination of signatures before the classification).

In Algorithm section
Select Maximum Likelihood algorithm from the drop down menu
Set the Threshold = 0.0
In Land Cover Signature Classification section
Check Use LCS box

On the SCP menu bar, set the value in the S box to 600 
Click on Activate classification preview pointer icon [image: image36.png]



Move the cursor near the location where the two rivers meet

Left click 
A preview is created of the classification for the MC-ID =1 signature
[image: image37.png]



Analysis: The ROI for the Water / River is blue. The black area contains unclassified pixel values that were NOT within the range of values defined for the river.
Step 6: Assess the spectral signatures of ROIs
Click on Preview icon [image: image38.png]


 to turn off the preview.

Click on Training Input tab in the SCP Dock
Click on ROI Signature List tab

Select line 1 in the list to highlight

Click on the Add highlighted signatures  icon [image: image39.png]


 to display the signature plot for water

Double click the color in the Plot Signature list to change the line color to blue.

Landsat 8 Bands shown as vertical dashed lines – from left to right

2. Blue

3. Green

4. Red

5. Near-Infrared

6. Short Wavelength Infrared

7. Short Wavelength Infrared
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The solid blue line indicates that the mean of reflectance values of pixels in each spectral band are low with the highest mean value in the red band (third from left). Pay special attention to the two bands, red band 4 and near-IR band 5, used to calculate NDVI. 
To compute the area XE "Area"  of the ROI, click on the Signature details icon [image: image41.png]


 and note the count of pixels. Multiply the count of pixels by 900 (square meters in each 30x30 m pixel). Divide by 10,000 to calculate the area of the ROI in hectares.

Step 7: Save and Exit
 (PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 

Select Project > Save
Select QGIS > Quit
Chapter 12:
Adding More Regions of Interest
This chapter includes:

· Defining additional ROIs

· Evaluating ROI signature characteristics 
Now that you understand more about the classification process and the interpretation of the outputs, let’s use this technique to define more ROIs.

From this point on, the images included as examples probably will not be exactly the same as the images you produce due to small differences in how each ROI is created and saved.
Create ROIs for healthy vegetation.

Step 1: Create Region of Interest for vigorous vegetation
Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to the folder Valley
Select LandUse
Redefine the bands set following the instructions in Step 8 of Chapter 8. 

Left click on the SCP Dock tab in the lower left corner of the screen
Left click on the Training input tab 

Left click on the ROI Signature list tab 

Create and save an ROI for healthy vegetation
Set Dist to 0.11 (pixel value variance to include in ROI)
Set Min to 60 

Set Max to 200
Click the Activate ROI pointer icon [image: image42.png]



Move the cursor to near the coordinates 498047,5139292
Ground truthing identifies this as a cemetery with trees and grass
Note that the NDVI values are in the range of 0.67 to 0.75
Move the cursor over a pixel whose value is about 0.70
Left click and wait for the region to grow 

Select MC ID = 3 
Click in MC Info box and type Vegetation 

Select C ID = 2 
Click in C Info box and type Grass
Click on the Save temporary ROI to training input icon [image: image43.png]


 

Click on Macroclass list tab

Double click in the Color column of the MC Id box = Vegetation 
Select green color

OK
Define a second ROI of vegetation

Click the Activate ROI pointer icon [image: image44.png]



Move the cursor to near coordinates 493930,5140393

Ground truthing identifies this as a golf course with mixed trees and grass
Note that the NDVI values are in the range of 0.75 to 0.83
Move the cursor over a pixel whose value is about 0.80

Left click and wait for the region to grow 

Left click on the ROI Signature list tab 

Select MC ID = 3 
Click in MC Info box and type Vegetation 

Select C ID = 3 
Click in C Info box and type GrassTrees
Click on the Save temporary ROI to training input icon [image: image45.png]


 

Step 2: Preview a classification of the image
View a temporary classification of the pixels in the image using the ROIs

Click on Zoom to input image extent icon [image: image46.png]



Click on Activate classification preview pointer icon [image: image47.png]



Move the cursor over the first ROI – the cemetery

Left click

A preview is created of the classification for river and vegetation ROIs

[image: image48.png]



Analysis: Ground truthing identifies the two green areas in the lower left as golf courses. The green area to the right of the cemetery is a large park. Other small green areas are small parks, trees and lawns. Large areas of the image are still black, meaning that they are unclassified.
Step 3: Assess the spectral signatures of ROIs
Assessing the spectral signatures characteristics of ROIs

Click on Preview icon [image: image49.png]


 to turn off the preview.

Click on Training Input tab

Click on ROI Signature List tab

Click on line 1 in the list to highlight

Hold down the Shift key and

Click on line 3 in the list to highlight

Click on the Add highlighted signatures … icon [image: image50.png]


 to display the signature plot for vegetation and for water
Click on the Automatically fit the plot to data icon [image: image51.png]


 on the plot panel
Double click the color in the first line of the Plot Signature list and change the line color to blue

Double click the color in the second line of the Plot Signature list and change the line color to dark green
Double click the color in the third line of the Plot Signature list and change the line color to light green
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The solid green lines indicate that the mean of reflectance values of pixels in each spectral band for vegetation are very different from the blue line plotted for water. The greatest difference is in the near-IR band 5 (fourth from left), used to calculate NDVI. Importantly, the vegetation bands do not overlap with the water bands; there is not conflict concerning which classification category each pixel represents. If spectral signatures used for classification are too similar, pixels could be misclassified because the algorithm is unable to discriminate correctly between signatures.
Since the two vegetation ROI signatures are very similar, they can be combined into one signature.

Click on RIO Signature list tab

Highlight the two vegetation ROIs in the ROI Signature List panel

Click on the Merge highlighted signatures … icon [image: image53.png]


 

Yes 
Highlight the two signatures that were merged

Click on the Delete highlighted items icon [image: image54.png]



Yes

Click the newly created line
Click on the Add highlighted signatures … icon [image: image55.png]


 to display the signature plot for the merged ROIs for vegetation

Highlight the two signatures that were merged

Click on the Delete row icon [image: image56.png]



Yes
Double click on the name beginning with merged and change to Grass/Trees

Change color to green
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Step 4: Save and Exit
 (PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 

Select Project > Save
Select QGIS > Quit
Chapter 13:
Adding ROIs for Natural 
Vegetation
This chapter includes:

· Defining additional ROIs for natural vegetation

· Evaluating ROI signature characteristics 

From this point on, these instructions will not include every keystroke of direction. By now you should be familiar enough with how QGIS works to find you way around various features. The important information will still be included to teach new features but familiar, oft-repeated actions may be omitted.

Step 1: Create Region of Interest – ROI for natural / undeveloped areas
In the summer, the naturally-occurring vegetation on the hillsides of the study area is mostly dried grass.

Start QGIS
Open the QGIS project LandUse
Redefine the band set following the instructions in Step 8 of Chapter 8. 

Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Create and save an ROI for natural areas

Set Dist to 0.065
Set Min to 60 

Set Max to 900 
Click the Activate ROI pointer icon [image: image58.png]



Move the cursor to near coordinates 495605,5142731

Ground truthing identifies this as an area of natural vegetation

Note that the NDVI values are in the range of 0.2 to 0.3

Move the cursor over a pixel whose value is about 0.21
Left click and wait for the region to grow 

[image: image59.jpg]



Select MC ID = 4 
Click in MC Info box and type BareSoil
Select C ID = 4 
Click in C Info box and type Natural
Click on the Save temporary ROI to training input icon [image: image60.png]


 

Click on Macroclass list tab

Double click in the Color column of the MC Id box = BareSoil
Select brown color

Step 2: Preview a classification of the image
View a temporary classification of the pixels in the image using the ROIs

Click on Zoom to input image extent icon [image: image61.png]



Click on Activate classification preview pointer icon [image: image62.png]



Move the cursor over the first ROI – the cemetery

Left click

A preview is created of the classification for river, vegetation and natural area ROIs

[image: image63.png]



Analysis: The ground in this area is appears to be mostly bare soil. As we slowly classify each part of the area, there are fewer black (unclassified) areas. 
Step 3: Assess the spectral signatures of ROIs
Assessing the spectral signatures characteristics of ROIs

Click on Training Input tab > ROI Signature List tab

Click on line 1 in the list to highlight

Hold down the Ctrl key and

Click on lines 2 and 3 in the list to highlight

Click on the Add highlighted signatures … icon [image: image64.png]


 to display the signature plot for water, healthy vegetation and natural areas

Click on the Automatically fit the plot to data icon [image: image65.png]


 on the plot panel

Double click the color in the third line of the Plot Signature list and change the line color to brown
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Step 4: Add an ROI polygon for fallow field 
The areas that remain unclassified (black) appear to be urban areas in the city and some rather large areas on the right side of the image. 
Remember reading about “image interpretation” in Chapter 8?  “Look for patterns, shapes, and textures: …. obvious patterns come from the way people use the land. Farms usually have geometric shapes—circles or rectangles or areas with straight sides —that stand out against the more random patterns seen in nature.” 
Since one of the rectangular-shaped unclassified areas is next to a green area (healthy vegetation), most likely the unclassified areas with similar shape characteristics are farm fields that are left fallow (plowed but left unsown for a time in order restore its fertility). Since the Landsat image is from 2013, it is not possible to ground truth this as fact, but we will assume this is true. 
Let’s add an ROI for the unclassified areas at the right of the image and name the areas “fallow fields”.
Create and save a ROI for fallow fields
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Click the Activate ROI pointer icon [image: image67.png]



Move the cursor to near coordinates 506208,5136826

Ground truthing identifies this as an area of fallow field

Note that the NDVI values are in the range of 0.21 to 0.24

Zoom in to the area shown in the following image

Select the Create an ROI polygon icon [image: image68.png]



Left click on the map to define the ROI vertices and right click to define the last vertex closing the polygon. An orange semi-transparent polygon is displayed over the image, which is a temporary polygon (i.e. it is not yet saved in the Training input). 

Draw the polygon while staying away from the edges of the field so that pixels are not included that might be part fallow field and part some other surfaces.

Temporary polygons can be redrawn (the previous one will be overridden) until the shape covers the intended area.

[image: image69.png]



Select MC ID = 4 
Select C ID = 5 
Click in C Info box and type FallowField 1
Click on the Save temporary ROI to training input icon [image: image70.png]


 
Step 5: Create Region of Interest – ROI for plowed fields
Perform a classification preview. The fallow field is now classified as BaseSoil but the field immediately above the fallow field is still unclassified. Check the NDVI values in the unclassified field; those values are higher than the values of the fallow field. 
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Create and save an ROI for the unclassified field 
Set Dist to 0.03 
Set Min to 60 

Set Max to 900 
Click the Activate ROI pointer icon [image: image71.png]



Move the cursor to near coordinates 505701,5137867

Ground truthing identifies this as a plowed field

Note that the NDVI values are in the range of 0.25 to 0.40
Move the cursor over a pixel whose value is about 0.32
Left click and wait for the region to grow 
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Select MC ID = 4 
Click in MC Info box and type BareSoil
Select C ID = 6
Click in C Info box and type FallowField 2
Click on the Save temporary ROI to training input icon [image: image73.png]


 

In the upper right of the image inside the bend in the river is another unclassified area. Ground truthing identifies this as a waste treatment pond of a nearby industrial site
Set Dist to 0.05 
Click the Activate ROI pointer icon [image: image74.png]



Move the cursor to near coordinates 503553,5141669
Note that the NDVI values are in the range of -0.08 to 0.08
Move the cursor over a pixel whose value is about 0.047
Left click and wait for the region to grow 

Select MC ID = 1 
Select C ID = 7 
Click in C Info box and type WastePond
Click on the Save temporary ROI to training input icon [image: image75.png]


 

Step 6: Assess the spectral signatures of ROIs
Left click on the Training input tab > ROI Signature list tab 
Click on all lines in the list to highlight

Click on the Add highlighted signatures … icon [image: image76.png]


 to display the signature plot for water

Click on the Automatically fit the plot to data icon [image: image77.png]


 on the plot panel

Examine the spectral signature plots and note differences and similarities of the shapes and amplitudes.
Step 7: Save and Exit
 (PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 

Select Project > Save
Select QGIS > Exit QGIS > Save
Chapter 14:
Adding ROIs for Urban Areas

This chapter includes:

· Defining additional ROIs for urban areas

· Evaluating ROI signature characteristics 

Classifying urban areas is challenging. The urban area in this case study is a mix of commercial buildings, houses, streets and trees. Many of the commercial buildings have large roof areas and are often surrounded by paved areas for parking vehicles. These areas are not difficult to isolate.

The residential areas are more of a challenge because of the mix of houses, trees and roads, none of which fill an entire 30 meter by 30 meter pixel resulting in mostly “mixed pixels”. Mixed pixel XE "Mixed pixel"  values vary over a wide range and are difficult to lump into one class.

It seems best to define a few ROIs for the commercial buildings and solve the mixed pixel problem using another method.
By using RGB= type 3-4-6 color composite on the Virtual Image, the urban areas are shown in purple and vegetation is in green. You can notice that this color composite RGB = 3-4-6 highlights roads more than natural color (RGB = 3-2-1)

Step 1: Add a new color composition 
Start QGIS

Open the QGIS project LandUse
Redefine the band set following the instructions in Step 8 of Chapter 8. 

On the QGIS menu bar 

Select SCP > Basic Tools > RGB List 
Click on Add row icon [image: image78.png]



Type 3-4-6 in added row

Click X to close panel
In the layer panel, select Virtual Band Set 1
Right click and select Move to top
In the RBG box, select 3-4-6
Step 2: Photo-interpretation using Google Earth when created ROIs
If the internet is accessible, add a Google satellite image for “ground truthing”. Note that the dates of the Google image and the date of the Landsat image are not the same, so caution must be exercised in using the Google image for “truth”.

On the QGIS menu bar  
Select View > Panels > check mark Browser 
Right click on tab next to XYZ Tiles > New Connection
Type in Name box Google Satellite
Copy & Paste into URL box https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z}
OK
Under XYZ Tiles double click on Google Satellite
Right click on the Google satellite layer

Select Move to top
Right click on the Google satellite layer

Select Properties
Select Transparency tab

Move slider in Global Opacity section to about 35%

Select Apply > OK

Click the X on the Browser in the Layer panel to close it
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Step 3: Create Regions of Interest – ROIs for commercial buildings
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Create and save an ROI for the unclassified field 

Set Dist to 0.1 
Set Min to 60 

Set Max to 200 
Click the Activate ROI pointer icon [image: image80.png]



Move the cursor to near coordinates 497945,5139660
Ground truthing identifies this as a university campus
Note that the NDVI values are in the range of 0.04 to 0.2
Move the cursor over a pixel whose value is about 0.091
Left click and wait for the region to grow 

Select MC ID = 2
Click in MC Info box and type Built-up

Select C ID = 8 
Click in C Info box and type Buildings1
Select the Save temporary ROI to training input icon [image: image81.png]


 

Click on Macroclass list tab

Double click in the Color column of the MC Id box = Built-up
Select pale yellow color
Use Google Satellite layer to locate other areas of commercial buildings such as this one:

Click the Activate ROI pointer icon [image: image82.png]



Move the cursor to near coordinates 498227,5140690
Ground truthing identifies this as a group of commercial businesses
Note that the NDVI values are in the range of 0.02 to 0.12
Move the cursor over a pixel whose value is about 0.02
Left click and wait for the region to grow 

Select MC ID = 2
Click in MC Info box and type Built-up

Select C ID = 9 
Click in C Info box and type Buildings2
Select the Save temporary ROI to training input icon [image: image83.png]


 

Step 4: Preview a classification of the image
Classify the pixels in the image using the ROIs

Select the Zoom to input image extent icon [image: image84.png]



Select the Activate classification preview pointer icon [image: image85.png]



Move the cursor over the first ROI – the cemetery

Left click

[image: image86.png]



Analysis: There are many black pixels indicating that those pixels did not fall within any spectral signature – those pixels are still unclassified.
Step 5: Create Region of Interest – ROI for pavement (optional)
Roads are easiest to identify near the bridges that cross the river. Note the airport in the bottom center of the image. Most roads are only one pixel wide so creating a classification category is difficult. Give it a try if you want to.
Step 6: Save and Exit
 (PC users) On the QGIS menu bar

Select Project > Exit QGIS > Save
(Mac users) On the QGIS menu bar 

Select Project > Save
Select QGIS > Quit QGIS
Chapter 15:
Classifying Land Use and Coverage

This chapter includes:

· Classifying images using several different methods
· Analyze classification outputs
Now let’s make a deeper exploration of the various classification techniques that are available to use.
The classification images included as examples will probably not be exactly the same as what you produce due to small differences in how the ROIs were created and saved.

Step 1: Start QGIS 
Start QGIS

Open the QGIS project LandUse
Redefine the band set following the instructions in Step 8 of Chapter 8. 

Step 2: Classify the image using LCS and analyze the output
If LCS is checked, the Land Cover Signature Classification is used. A full description of LCS is included in the SCP User Manual. 

Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Select Classification tab

Check Use MC ID box 
In Algorithm box

Select Maximum Likelihood algorithm

Threshold = 0.0
Check Use LCS box

Uncheck Use Algorithm box
Uncheck Use only overlap box
Select RUN button

Browse to Classify folder

In File Name folder, type Run1_LCS 
Save
[image: image87.png]



On the QGIS menu bar 

Select SCP > Postprocessing > Classification Report

Select the Input bar

Select Refresh icon 

In the Select the classification, select Run1_LCS
Select the RUN button

Browse to Classify folder

In File Name folder, type Run1_LCS_report 
Save 
Note the following values in Output section. Your values may differ somewhat but should be close to the following values.
	Value
	Description
	Percent coverage

	-1000
	Overlap
	0.5

	0
	Unclassified
	43.2

	1
	Water
	5.5

	2
	Built-up
	3.7

	3
	Vegetation
	4.9

	4
	Bare soil
	42.2


Analysis: Many pixels remain unclassified. The black pixels did not fall within any Macroclass spectral signature. One method of reducing the number of unclassified pixels would be to define more ROIs in the unclassified areas. Careful ground truthing is needed to determine the nature of the ground cover at these points. The Google Earth satellite layer is often helpful.
The spectral signatures for ROIs created for these areas should be compared to previously defined ROIs. Consideration should be given to merging ROI signatures that have similar patterns.

Step 3: Classify the image using LCS and algorithm and analyze the output
If Algorithm is checked, the selected algorithm is used for unclassified pixels of the Land Cover Signature Classification.
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Click on Classification tab

Check Use MC ID box 

In Algorithm box

Select Maximum Likelihood algorithm

Threshold = 0.0
Check Use LCS box

Check Use Algorithm box
Uncheck Use only overlap box
Click on RUN button

Browse to Classify folder

In File Name folder, type Run2_Algorithm 
Save 
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On the QGIS menu bar 

Select SCP > Postprocessing > Classification Report

Select the Input bar

Select Refresh icon 

In the Select the classification, select Run2_Algorithm
Select the RUN button

Browse to Classify folder

In File Name folder, type Run2_Algorithm_report 
Save 
Note the following values in Output section. Your values may differ somewhat but should be close to the following values.
	Value
	Description
	Percent coverage

	-1000
	Overlap
	0.0

	0
	Unclassified
	0.0

	1
	Water
	5.2

	2
	Built-up
	22.1

	3
	Vegetation
	16.4

	4
	Bare soil
	56.2


Analysis: The purpose of using this method is to classify all pixels in the image using the algorithm to resolve previously unclassified pixels. Note that 43% of the pixels that were unclassified in Run 1 have now been classified.  The Built-up area increased from 4% to 22%, Vegegation area from 5 to 16%, Bare soil area from 42 to56%. Water remained unchanged.
Step 4: Classify the image using LCS, algorithm and only overlap and analyze the output
If only overlap is checked, the selected algorithm is used only for class overlapping pixels of the Land Cover Signature Classification; unclassified pixels of the Land Cover Signature Classification are left unclassified

Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Click on Classification tab

Check Use MC ID box 

In Algorithm box

Select Maximum Likelihood algorithm

Threshold = 0.0
Check Use LCS box

Check Use Algorithm box
Check Use only overlap box
Click on RUN button

Browse to Classify folder

In File Name folder, type Run3_Overlap 
Save 
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On the QGIS menu bar 

Select SCP > Postprocessing > Classification Report

Select the Input bar

Select Refresh icon 

In the Select the classification, select Run3_Overlap
Select the RUN button

Browse to Classify folder

In File Name folder, type Run3_Overlap_report 
Save 
Note the following values in Output section. Your values may differ somewhat but should be close to the following values.
	Value
	Description
	Percent coverage

	-1000
	Overlap
	0.0

	0
	Unclassified
	36.1

	1
	Water
	5.0

	2
	Built-up
	2.1

	3
	Vegetation
	3.4

	4
	Bare soil
	53.3


Analysis: Not surprising, this classification looks a lot like Run 1. The reason is that in Run1 there were few “overlap” pixels – pixels that fell within two different Macroclass spectral signatures. In other circumstances, this method might be useful but was not useful in this case study.
Step 5: Classify the image using Class ID and analyze the output
Note: that in this classification the Use box selection will be changed from the previously used Macroclass ID (MC-ID) to Class ID (C-ID).
Choosing meaningful colors for displaying different signatures is a very important step in preparing the resulting output for viewing by the intended user of the map. Colors should be chosen that will communicate the message of the map without using words. For example, the color green “says” “vegetation” to the brain without the use of words. Likewise, blue says “water”; red says “danger”. Choose colors thoughtfully and be consistent.

Change colors for the C-ID signatures to resemble this example

Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Scroll to the far right to find the Color column

Double click on any color box and select an appropriate color
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Click on Classification tab

Check Use C ID box (note this changed selection)
In Algorithm section
Select Maximum Likelihood algorithm

Threshold = 0.0
Check Use LCS box

Check Use Algorithm box
Uncheck Use only overlap box
Click on RUN button

Browse to Classify folder

In File Name folder, type Run4_C-ID 
Save 
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On the QGIS menu bar 

Select SCP > Postprocessing > Classification Report

Select the Input bar

Select Refresh icon 

In the Select the classification, select Run4_C-ID
Select the RUN button

Browse to Classify folder

In File Name folder, type Run4_C-ID_report 
Save 
Step 6: Additional refinements
Further refinement of this case study is left to the student.

Step 7: What do you see?

Study the image that was created in Step 5. In 150-200 words write about what you interpret from the classified image regarding this study area. Write as though you are presenting this image to an audience and must explain its message.
Step 8: Save and Exit
 (PC users) On the QGIS menu bar
Select Project > Exit QGIS

(Mac users) On the QGIS menu bar 

Select Project > Save

Select QGIS > Quit GIS
Chapter 16:
Accuracy Assessment
This chapter includes:

· Purpose 

· Creating an accuracy assessment
· Interpreting the accuracy assessment

Purpose

Accuracy assessment of land cover classification is useful for identifying map errors. Usually, accuracy assessment requires ancillary data and a field survey. However, it is also possible to use photo interpretation to create the necessary input.

Classification error occurs when a pixel belonging to one category (as determined by ground truthing) is assigned to a different category during the classification process. 

Errors are present in any classification – achieving 100% accuracy in classification is an unrealistic goal. But achieving an acceptable error rate is the goal of accurate classification. 

A very simple landscape composed of large, uniform, distinct categories is easier to classify accurately than one with small, indistinct parcels arranged in a complex pattern such as a residential neighborhood composed of rooftops, trees, streets and driveways.  A common source of misclassification errors relates to the difficulty of classifying mixed pixels that lie on the boundary of two different elements such as the shoreline of a body of water or the edge of a road that passes through a forested area. 
For a full understanding of classification errors, read Chapter 14 of Introduction to Remote Sensing, Fifth Edition by Campbell and Wynne. 
In this exercise a random sampling method will be used to create ROIs for manual classification by ground truthing. How many samples are enough? The answer varies – see if you can give some reasons why.
Step 1: Start QGIS 
Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to the folder Valley
Select LandUse
Perform Step 8 of Chapter 8 to define the band set
Step 2: Automatic creation of ROIs at random points
Left click on the SCP Dock tab 
On the SCP menu bar

In Dist box type 0.02 - the interval which defines the maximum spectral distance between the seed pixel and the surrounding pixels (in radiometry unit)
In Min box type 3 - the minimum area of a ROI (in pixel unit

In Max box type 5 - the maximum width of a ROI (in pixel unit)
On the QGIS menu bar

Select SCP > Basic Tools > Multiple ROI creation
In Number of points box type 20 (total ROIs to create)
Check inside grid box 
In inside grid box type 3000 (size of grid in meters)
Check min distance box 
In min distance box type 1000 (distance from other ROIs in meters)
Click on Create points box [image: image92.png]



Uncheck Calculate sig box 

Click on Run icon
Wait for ROIs to be created and added into the ROI signature list
In this case study, the study area is approximately 15,000 meters wide by 9,000 meters deep. Verify these measurements using the Measure icon [image: image93.png]1

-



 on the QGIS toolbar. For these values, the study area width in grid units would be 15,000 / 3,000 = 5 grids. The depth would be 3 grids (9,000 / 3,000) and so the total study area would contain 5 x 3 = 15 grids.
from http://fromgistors.blogspot.com/2014/09/accuracy-assessment-using-random-points.html
Step 3: Photo-interpretation of created ROIs
If the internet is accessible, add a Google satellite image for “ground truthing”. Note that the dates of the Google image and the date of the Landsat image are not the same, so caution must be exercised in using the Google image for “truth”.

Click on Layers tab
Uncheck all layers except Training

Right click on the Training layer

Select Move to top
Examine the random ROIs that have been created noting their distribution and sizes
Check the Google satellite layer

Right click on the Google satellite layer

Select Move to top
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Double click on the R in the first ROI with R in the Type column
The pixel choice of this ROI will be displayed
Left click on the Layers tab

Toggle on and off the layers Training and Google
Choose one of the four categories that characterizes the ROI

· Class 1 = Water (e.g. surface water);

· Class 2 = Built-up (e.g. artificial areas, buildings and asphalt);
· Class 3 = Vegetation (e.g. grassland or trees); 
· Class 4 = Bare soil (e.g. bare soil or low vegetation).

Left click on the SCP Dock tab

Double click on the MC ID and change to the correct Class value

In some cases, the ROI will contain mixed pixels. Consider deleting that ROI if it might unfairly contaminate the results of the accuracy analysis.

Repeat the evaluation of each added ROI and update each MC ID
Left click on the SCP Dock tab > Training input tab > ROI Signature list tab 
Double click on any entry in the S column to “select all”
Click on Classification tab

Check Use MC ID box 

In Algorithm box

Select Maximum Likelihood algorithm

Threshold = 0.0
Check Use LCS box

Check Use Algorithm box
Uncheck Use only overlap box

Click on RUN button

Browse to Classify folder

In File Name folder, type Run5 
Save 
Step 4: Calculation of classification accuracy
On the QGIS menu bar
Select SCP > Post processing > Accuracy

Select Input bar
For Classification to assess box, click the Refresh icon

In Classification to assess box, select Run5
For Reference vector or raster box, click the Refresh icon

In Reference vector or raster box, select Training
In Vector field select MC ID
Click on RUN button

Browse to Classify folder

In File Name folder, type AccuracyRun1 
Save 

Step 5: Evaluate accuracy results
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Kappa hat – the measure of the difference between the observed agreement between two maps (diagonals) and the agreement expected solely by chance matching of the two maps.

A discussion of the theory of computing Kappa hat is left to the math and statistics experts. However, typical Kappa hat values greater than 0.80 (i.e, 80%) represent strong agreement between the remotely sensed classification and the reference data while values between 0.4 and 0.8 represent moderate agreement. Anything below 0.4 is indicative of poor agreement. 
Accuracy results are a function of the number of ROIs evaluated as well as the size and sensitivity (Dist) of the ROIs. 

Step 6: Save and Exit
 (PC users) On the QGIS menu bar

Select Project > Exit QGIS

(Mac users) On the QGIS menu bar 

Select Project > Save
Select QGIS > Quit QGIS
Chapter 17:
Unsupervised Classification
This chapter includes:

· Purpose

· Creating an unsupervised classification
Purpose
Clustering can be used for unsupervised classification. While Supervised Classification produces a classification with the classes identified during the training process, the classes produced by clustering (i.e. clusters) have no definition and consequently the user must assign a land cover label to each class. The main advantage of clustering resides in automation. 

Step 1: Start QGIS 
Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to the folder Valley
Select LandUse
Perform Step 8 of Chapter 8 to define the band set
Step 2: Automatic creation of ROIs at random points
On the QGIS menu bar

Select SCP > Band Processing > Clustering 

Select K-means button

Uncheck Distance threshold box

Select Number of classes = 4
Select Max number of iterations = 4
Select Use signature list as seed values box

Select Minimum distance button for Distance algorithm
Run

Browse to Classify folder

In File Name folder, type ClusterRun1

Save

To be completed later.
Chapter 18:
Final Analysis and Conclusions

Chapter 19:
Telling the Story
This chapter includes:

· Creating a PowerPoint of the story the data is telling

· Preparing spoken presentation

PowerPoint outline
Introduction

Purpose and significance of the study

Materials and Methods

Study area

Data resources

Methodology

Results

Status at baseline

Change over time

Discussion

Expectations

Timing

Anomalies

Conclusions

Acknowledgements

Guidelines on speaking presentation
· Practice at least twice before your presentation 

· Look at your audience – not at the PowerPoint
· Try to relax – breath normally
· The PowerPoint should only be bullet points outlining what you are going to say

· Use colors for text that have high contrast with the color of the background
· Enlarge pictures as big as possible
· When speaking, speak SLOWLY and pause occasionally
Part 5: 
Useful Tools
Chapter 20:
Printing Maps and Images
This chapter includes:

· Learning how to prepare maps for distribution

· Creating template for the map

· Adding titles, legends and text boxes to the map

These instructions will help you create a template that will make it much easier to recreate a map with the same legend and symbology. This will save you a lot of time; you will not have to recreate the legend and symbology over and over for each map.

Step 1: Start QGIS

Start QGIS
On the QGIS menu bar

Select Project > Open Recent
Browse to folder Valley
Select File Name = LandUse 
Open

Step 2: Create a new template for printing the map

Select the map layers you want to appear on the printed map. 

In the Layers Panel 

Uncheck layers you don’t want to print
Select the layer named Run5 
Position the map in the screen as you want it to appear when printed. 
(optional) Select the Zoom In icon [image: image95.png]


 and, while holding down the left click button, draw a rectangle around the area that you want to appear when the map is printed.

On the QGIS menu bar

Select Project > New Print Layout
In the Create print layer Title box type Run5 

OK

On the Layout icon panel 

Select the Add New Map icon [image: image96.png]


 
Hold down the left click button, draw a rectangle around the area where you want to the map to appear

If the map does not appear the way you want, 
Go back to the main map to adjust the view 
Return to Layout Manager
If the map does not render clearly or sharply

Click on the Refresh icon [image: image97.png]



To keep the map from being accidentally moved, lock its position

Click anywhere inside the map

Right click inside the map

Select Item Properties

In the Layers section, check mark Lock Layers
Select Layout on the menu bar
Select Save as template

Browse to folder Valley 
File Name = Run5
Save
Step 3: Add Legend XE "Legend" : 
A useful feature for formatting the legend titles is the “wrap” feature. You can define a “wrap character” and insert it in the legend title to force the text following the wrap character to move onto the next line.

On the menu bar
Select Add Item > Add Legend
Click in the map at the position where you want the title to appear

In Height box, type 20 or a height of your choice
OK
Right click with the cursor inside the Legend box

Select Item Properties tab on the right

In Main Properties section

In Title box type Classifications
Define a Word wrap character (one-time only)

In Item Properties

Select Wrap Text On box and type any character, such as @
Open Legend Items section 

Uncheck the Auto Update box
Click on any layer you do not want to appear in the legend

Select Delete [image: image98.png]


 icon
Open Fonts section
Click on Title Font
Font > Arial > Font Style > Bold > Size 24 > OK

Click on Subgroup Font 
Font > Arial > Font Style > Bold > Size 16 > OK
In Item Font select a font of your choice > OK
Resize the frame of the text box by dragging the edges to fit text
Drag the legend to the lower right corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 4: Add Scale Bar XE "Scale bar" :

On the menu bar, 
Select Add Item > Add Scale Bar
Click in the map at the position where you want the title to appear

In Height box, type 20 or a height of your choice
OK

In the Item Properties section

In Scalebar units box select Meters
In the Label unit multiplier box type 1.0

In the Label for units box type meters
In Segments select Left 0 and Right 3
Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Drag the scale bar to the lower left corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 5: Add Map Title XE "Title" :

On the menu bar
Select Add Item > Add Label
Click in the map at the position where you want the title to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type an appropriate title for the map, such as:

Land Use, Lewiston, ID 19 April 2018
Select Font 
Font > Arial > Font Style > Bold > Size 28 > OK
Select Horizontal alignment = Left 

Uncheck Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Step 6: Add Data Source Labels:

On the menu bar
Select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK
In the Item Properties section
In the Main Properties box type an appropriate title for the data sources, and add a list of them:
Data Sources:

- USGS
Select Font 
Font > Arial > Font Style > Bold > Size 12 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes
Position the Data Source text box in the lower center of the map.

Resize the frame of the text box by dragging the edges to fit text
Step 7: Add Date and Author Label:

Select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type your name and the date the map was created
Select Font 
Font > Arial > Font Style > Bold > Size 10 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes
You can resize the frame of the text box by dragging the edges to fit text
Position the date label box in any part of the map.
Step 8: Add North Arrow XE "North arrow" 
On the menu bar

Select Add Item > Add Picture 
Left click in the lower right corner of the map at the position where you want the North Arrow to appear -> OK
On the right panel select Main Properties tab 

Click on Search directories section to expand 

Choose the north arrow you prefer from icon table 

In the Placement dropdown box, select Top Left 

Uncheck the Background box 

You can resize the frame of the text box by dragging the edges to fit text
Position the north arrow box above the scale bar.
Step 9: Create image file of map 
Select menu option Layout 
Select Export as Image 
Browse to folder Valley
In Save as type choose JPG format (*. Jpeg)
Name file with an appropriate name

Save > Save
Step 10: Print your map from the saved image

Select menu option Layout 
Select Page Setup

Choose Orientation = Landscape

OK
Select menu option Layout 
Select Print

Select printer

Print
Step 11: Save as Template:

Select menu option Layout > Save as Template

Browse to folder = Valley 
File name = Run5
Save > Yes

Select menu option Layout > Close
Step 12: Save Project

(PC users) On the QGIS menu bar

Select Project > Exit QGIS

(Mac users) On the QGIS menu bar 

Select QGIS > Exit QGIS
Chapter 21:
Investigating Features and 
Challenges
This chapter includes:

· Challenge to investigate features and compare results

· Sentinel images compared to Landsat images

· USGS Landsat Level 2 images compared to SCP corrected Level 1 images
Here are some challenges for the curious to investigate.

Are there advantages for using Sentinel images in place of Landsat images?

Would it be better to use USGS-corrected Landsat Level 2 images in place of SCP-corrected Level 1 images? Instructions for downloading Level 2 images can be found in Volume 3 of this series. A reference for this topic can be found at
https://fromgistors.blogspot.com/2015/01/landsat-8-surface-reflectance.html?spref=yml
Appendixes:


Appendix A: References

1. Introduction to Remote Sensing, Fifth Edition, Campbell and Wynne, The Guilford Press, 2011
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