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[bookmark: _Hlk2765960]Preface

[bookmark: _GoBack]This curriculum is the third in a series of five volumes on the topic of using QGIS open source software. The intended purpose of these volumes is to provide detailed instructions that can be used as curriculum in GIS classes. Special attention has been paid to English syntax so the text can be easily translated into other languages. Currently the text is available in English and Vietnamese.

Volume One is an introduction to QGIS open source software intended for the first-time user of GIS software. 

Volume Two introduces the use of QGIS for analyzing forest coverage changes using Landsat remote sensed images.

This volume, the third in the series, is intended for users having basic familiarity with the use of GIS software but who are not necessarily proficient in using QGIS. The instructions in this volume will direct the learner using a case study that follows the growth of a corn crop from planting through harvesting by analyzing selected Landsat images. 

Volume Four teaches the use of QGIS software for analyzing land use and land coverage characteristics by classifying values in remote sensed images according to patterns of interest to the user.

Volume Five teaches the use of QGIS software and System Dynamics modeling software (Vensim) for exploring topics in the ecology of water. The curriculum will explore issues such as flow patterns, droughts, flooding, salinity intrusion, sea-level rise and climate change impacts. This volume is still being written as of May 2019.
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[bookmark: _Toc369960523][bookmark: _Toc9345671]Part 1:
General Principles of Remote Sensing
	

[bookmark: _Toc9345672]Chapter 1:
About Remote Sensing 

This chapter includes:
· Description of the study of remote sensing

Definition: Remote sensing is the science of deriving information about an object from measurements made at a distance from that object. 

Examples of methods of acquiring remote-sensed data: aerial photography, satellite-captured images, RADAR, LIDAR, etc. 

Uses of remote sensing: agriculture crop monitoring, forestry management, weather forecasting, military intelligence, urban planning, mapping, and many other fields.

Equipment used for remote sensing: satellites, airplanes, drones, cameras, GPS, computers, and a variety of other devices.

Software used in remote sensing: GIS software, Google Earth, internet websites, computer data archives of images, etc.

It is important to understand that many components of the remote sensing process act as parts of a system and cannot be isolated from one another.

For a more complete understanding of remote sensing, a search of the Internet will uncover many sources of current information.  An instructional course, either online or at a local university, will develop understanding and provide hands-on opportunities to work with remote-sensed data.

It is not the intent of this text to develop a thorough understanding of remote sensing. Instead, the purpose of this text is to give the student step-by-step instructions for using GIS software to acquire and manipulate remote-sensed data. By completing the case study in this text, the student will develop a basic understanding of some of the processes involved in analyzing remote-sensed data and learn to draw conclusions from that analysis. Hopefully, this text will motivate students towards a more in-depth study of this interesting and expanding field. 

It also is not the intent of this text to be a tutorial on the use of GIS software or, specifically, QGIS, the most popular open source GIS software in use at the time of writing. Although this text will guide the student through the steps of using QGIS to process remote-sensed images, explanations regarding the functions of GIS are brief. Again, an online class or university course is needed to gain a full understanding of GIS software.
[bookmark: _Toc9345673]Chapter 2:
Defining the Project 

This chapter includes:
· Description of the study project and its goals

During the growing season of 2018, I observed the changes in a corn field near Monroe, Washington, USA. I watched the crop as it developed from seeds planted in bare earth to sprouted shoots to maturity and, finally, to harvest. 

This project will examine satellite images acquired by Landsat satellites to determine how the vegetation coverage of this corn field changed during the 2018 growing season as “observed” using satellite data. 

You can use the skills developed in this course to monitor a crop development project of your own. You should look for an area to monitor the development of a crop that is important to the economy of your local region. 

Multiple steps are needed to study the changes over time that can be observed and analyzed related to this project:

First, the location of the crop field needs to be identified by parameters consistent with Landsat image georeferencing. Latitude and longitude coordinates can be determined by GPS. 

Next, view the area using Google Earth using the field’s latitude and longitude. Comparing visible imagery from Google Earth and satellite images helps visualize pattern correlation between difference types of remotely sensed images.

Analyze Landsat images using the NDVI analysis method.

Practice ground truthing to verify information in your study.

Combine GIS and other software tools to visualize the data collected in your study.

Finally, draw some conclusions from your various observations.

QGIS - define study area (5)
QGIS - create reference map (5)
Download Landsat images (7)
QGIS - load Landsat images (8)
QGIS - perform NDVI analysis (10-13)
QGIS - print maps (14)
Download Admin maps (4)
Ground Truthing (15)
Download QGIS software (3)




[bookmark: _Toc369960528]

[bookmark: _Toc9345674]Part 2:
Creating Maps
Using GIS
	

[bookmark: _Toc369960530][bookmark: _Toc9345675]Chapter 3:
Installing QGIS and 7-Zip

This chapter includes:
· Instructions to download and install QGIS 
· Instructions to download and install 7-Zip for uncompressing files

Step 1: QGIS Installation for Windows PC
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:
http://www.qgis.org/en/site/forusers/download.html

Choose QGIS Standalone Installer Version 3.6. or later

To see whether your computer has a 32 or 64 bit processor go to Control Panel > System and view the “System type” in the System section. 

[image: ]

If you are unsure as to whether to install a 32 or 64-bit version of QGIS, select the 32-bit version.

Open the QGIS installer and follow the instructions.

[bookmark: _Hlk517940296]NOTE: At the time this curriculum was prepared, the current version of QGIS was 3.6, in April 2019.

Configure the QGIS default options:

Start QGIS

[bookmark: _Hlk517939953]On the QGIS menu bar 
Select Settings > Options
Select General tab
	If settings are locked, click the Override system locale box on the top left
Select Style that corresponds to your computer operating system
Change Icon Size to 32
Change Font to Arial (or your choice)
Change Size to 12 (or your choice)

On the QGIS menu bar 
Select View > Toolbars > Manage Layers Toolbar

To correctly display foreign language characters

Select Settings > Options > Data Sources
In the Data source handling section
Uncheck the box next to Ignore shapefile encoding declaration
OK


On the QGIS menu bar 
Select Project > Exit QGIS

Step 2: QGIS Installation for Mac
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:
http://www.qgis.org/en/site/forusers/download.html

Choose QGIS macOS Installer Version 3.6.

Perform same instructions as in Step 1

In addition, this change is needed to solve a bug related to clipping raster files

On the menu bar select QGIS 3 > Preferences > System 
Open Environment section
Check box Use custom variables
Click on the plus sign
In Apply column, select Append
In Variable column type PATH
In Value column copy / paste the following text

:/Library/Frameworks/GDAL.framework/Programs: /Library/Frameworks/PROJ.framework/Programs: /Library/Frameworks/SQLite3.framework/Programs:/Library/Frameworks/UnixImageIO.framework/Programs

		Click on OK box

When you are finished, your screen should look like this:

[image: ]

OK

On the menu bar select QGIS 3 > Quit QGIS 3


Step 3. Software Installation - 7-Zip 

For Windows download and install 7-Zip from this website:
https://www.7-zip.org
Open the 7-Zip installer and follow the instructions.
	Any similar program, such as WinRAR, can be used as well.

For Mac download and install Keka from this website:
https://www.keka.io
Open the Keka installer and follow the instructions.
Then set Keka as the default extraction application using this website:
https://github.com/aonez/Keka/wiki/Default-application
Follow instructions under Set Keka as the Default Extraction Application
Doing this will help in Chapter 7: Acquiring Remote Sensed Data, Step 4. It will allow Keka to automatically uncompress or extract the downloaded files.

Step 4. Learning to use QGIS software

Search the internet for resources for learning QGIS.

One online resource for learning QGIS is https://foss4geo.wordpress.com/
[bookmark: _Toc369960531][bookmark: _Toc9345676]Chapter 4:
Locating GIS Maps 

This chapter includes:
· Locating appropriate digital maps

One useful source of digital maps for GIS systems is the website for GADM (Database of Global Administrative Areas), which can be accessed at http://www.gadm.org/  

GADM is a spatial database of the location of the world's administrative areas (or administrative boundaries) for use in GIS software.  The coordinate reference system is “latitude/longitude” and uses the datum WGS84. These maps can contain up to 5 levels of administrative subdivisions. A general understanding of the concept of “administrative areas” is presented on Wikipedia at http://en.wikipedia.org/wiki/Administrative_division

Other useful sites containing data for roads, rivers, population data, etc.:

http://www.diva-gis.org/gdata 

https://nationalmap.gov/small_scale/

We will not be using administrative maps in this case study but these references may be useful for other projects


[bookmark: _Toc9345677]Chapter 5:
Defining a Study Area
and Reference Map

This chapter includes:
· Purpose and definition of a study area
· Creating a reference map of the study area

Note: It is often helpful to see both the instructions in this Word document and the QGIS application on the computer screen at the same time. One way to do this is to “split the screen”. How to split the screen depends on what version of the operating system you are running on your computer. Search the internet for how to split the screen for your version, e.g. “How to split the screen in Windows 10”. 

Purpose

The study area gives us some general orientation to the geography around the corn field we plan to monitor. The surrounding characteristics of the study area may provide some helpful clues to aid in our analysis.

We will define our study area by specifying its boundaries. We can define a rectangle by specifying the coordinates of its four corners or we can draw a rectangle of our study area in a map layer of our project. 

As we discussed in Chapter 2, the purpose of our study is to analyze satellite remote sensed images to observe changes in vegetation coverage of a corn field near Monroe, Washington, USA, during the 2018 growing season.


Step 1: Start QGIS

Start QGIS

On the QGIS menu bar 
Select Project > New

[bookmark: _Hlk510526095]Step 2: Create a folder for this project

Create a folder on the C: drive for your work - name the folder GIS Remote Sensing. 
In the GIS Remote Sensing folder, create a sub-folder named Monroe.

On the QGIS menu bar 
Select Project > Save As 
Browse to the folder Monroe
Type File name CropMonitoring
Save

Step 3: Define the study area

For our study area, we will use a river valley in Snohomish County in western Washington, USA. The area chosen for this study is a broad, flat river valley where a variety of crops are grown. The most common crops are alfalfa, blue berries and corn for cattle feed. By choosing this area, we can see how the Landsat images depict both the crops and the natural features of the landscape.

Define the corners of our study area by longitude and latitude coordinates. For this study, the boundaries are provided for you using coordinates determined by GPS. For your own projects, you will need to set your own boundaries for your study area.

We will create a vector layer in QGIS using the corners of our study area which are:

Lon,Lat
-122.0242,47.8147
-122.0054,47.7644
-121.9597,47.7651
-121.9581,47.8161

Copy and paste the lines above into a text (.txt) file using Notepad.

For Mac: Copy and paste the lines above into Pages and export as Plain Text (.txt)

Open Pages
File > New > Blank
Copy and Paste the lines above
File > Export to > Plain Text
Select Next 

Name the file AreaCornerPoints and save (for Mac Select Export) the file in the folder Monroe

On the QGIS menu bar 
Select Layer > Add Layer > Add Delimited Text Layer
In File Name box 
Browse to the folder Monroe
Select file AreaCornerPoints 
Open
On the File Format box
Select CSV
In the Record and Fields Options box
Select 0 in Number of header lines to discard
Select check mark in box next to First record has field names
On the Geometry Definition box
Select Point Coordinates
In the Geometry CRS box
Select Project CRS:ESPG:4326 WGS 84
Add
Close

Step 4: Create a new shapefile layer 

On the QGIS menu bar 
Select Layer 
Select Create Layer > New Shapefile Layer
Choose Geometry Type Polygon
In the CRS box
Click on the globe icon at the end of the CRS line [image: ]
In the Filter box, type 10N
In the Coordinate reference systems of the world
Select WGS 84 / UTM zone 10N 
OK > OK

[image: ]


Each shapefile has an attribute table where data about its features can be stored. Add any attribute fields you want in the New Attribute section. Adding fields is optional; fields can always be added later

In New Field box
In Name box type Name
Select Text data in Type box
In Length box type 48
Click on the Add to fields list button

In File Name box, browse to the folder Monroe 
Type File Name StudyArea
Save
OK

Your new StudyArea layer will automatically be added to the navigation menu on the left of your screen. In addition, the shapefile named StudyArea will now be saved in the folder Monroe.

Step 5: Draw the boundaries of your study area 

On the QGIS menu bar 
Select View > Toolbars > Select check mark for Digitizing Toolbar

Right click on the layer AreaCornerPoints
Select Zoom to Layer

Left click on the StudyArea layer
Select the Toggle Editing icon [image: ]  on the toolbar to turn editing “on”
Select the Add Polygon Feature icon [image: ] on toolbar

Draw a polygon around your study area 
Position the cursor at the upper left point of your area and left click
Move the cursor to the upper right point of your area and left click
Move the cursor to the lower right point of your area and left click
Move the cursor to the lower left point of your area and left click
Right click to finish the polygon
Your polygon will disappear, this is OK

Type number “1” in the id box
Type Corners in the Name box
OK
Select the Toggle Editing icon [image: ] on the toolbar to turn editing “off”
Save

Right click the StudyArea layer > Properties
Select Symbology tab 
Click on Simple Fill
For Fill style select No Brush 
For Stroke color select red > OK
For Stroke width type 1
For Stroke style select solid line 
Apply > OK

Step 6: Adjust the boundaries of your study area 

If you want to adjust the shape of your study area 

Left click on the StudyArea layer
Select the Toggle Editing icon [image: ] on the toolbar to turn editing “on”
Select the Vertex Tool icon [image: ] on the toolbar
(the cursor will change to a cross +)
Move the “cross” cursor over the corner point you want to move 
Click left mouse button to select the point then release the mouse button
Move the cursor to a new location 
Click the left mouse button to reposition the point

When you are finished moving the corner points of your Study Area polygon
Select Toggle Editing icon [image: ]on the toolbar to turn editing “off” 
Save 

Step 7: Save the Project

The new shapefile named StudyArea defining your study area has been saved in folder Monroe.

Delete the CSV layer AreaCornerPoints
Right click on the layer AreaCornerPoints
Select Remove Layer > OK

On the QGIS menu bar 
Select Project > Save 

The vector shapefile named StudyArea can now be used to “clip” images, so they only contain data for the defined study area. More about this later.

[image: ]

Step 8: Define the crop field to be studied

Within our study area, we will identify one crop to monitor during the growing season of May to October. The crop we will analyze is “corn” which is used for cattle feed. 

Define the corners of our crop field study area by longitude and latitude coordinates. For this study, the boundaries are provided for you using coordinates determined by GPS. For your own projects, you will need to set your own boundaries for your study area.

We will create a vector layer in QGIS using the corners of our study area which are:

Lon,Lat
-121.9996,47.8078
-121.9957,47.8079
-121.9940,47.8085
-121.9849,47.8084
-121.9842,47.8059
-121.9935,47.8058
-121.9937,47.8051
-122.0000,47.8050

For Windows: Copy and paste the lines above into a text (.txt) file using Notepad
For Mac: Copy and paste the lines above into Pages and export as Plain Text (.txt)
Name the file CropCornerPoints and save the file in the folder Monroe.

On the QGIS menu bar 
Select Layer 
Select Add Layer
Select Add Delimited Text Layer
In File Name box 
Browse to the folder Monroe
Select file CropCornerPoints 
Open
In the File Format box
Select CSV
In the Record and Fields Options box
Select 0 in Number of header lines to discard
Select check mark in box next to First record has field names
On the Geometry Definition line
Select Point Coordinates
In the Geometry CRS box
Select ESPG:32610 WGS 84 / UTM zone 10N
Add
Close

Now, follow the instructions in Steps 4-7 to create a crop area layer by connecting the corner points of the crop area layer. Be careful to substitute the name “Crop” for “Study”

Note: this area is 116 acres / 47 hectares

The crop area on our computer screen should look similar to this image:

[image: ]

Step 9: Save the project and exit

On the QGIS menu bar 
Select Project > Save 
On the QGIS menu bar 
Select Project > Exit QGIS > Save

Note: If you have access to Google Earth via internet, an alternate method of defining your study area and crop area can be used – see Chapter 18.


[bookmark: _Toc369960534][bookmark: _Toc9345678]Part 3:
Adding Remote Sensed Data in GIS


[bookmark: _Toc369960535][bookmark: _Toc9345679]Chapter 6:
Locating Remote Sensed Data

This chapter includes:
· Identifying sources of remote sensed images
· Understanding the data available in the Landsat archive

[bookmark: _Toc369960536]Identifying sources of remote sensed images

The Landsat archive is one of the largest and most accessible sources of remote sensed images. For our exercises, we will use Landsat images. However, after you become familiar with the process of using remote sensed images in GIS, you should research and bookmark other sources of images to provide a strong variety of tools for your future remote sensing and GIS needs.

The Landsat satellite imaging program was designed by scientists and sponsored by the US government to make large-scale, continuous surveys of the Earth's land areas. Today, the Landsat image library contains the longest continuous record of environmental conditions of land areas covering our world.

To date, eight Landsat satellites have been launched, beginning with Landsat 1 in 1972, up to Landsat 8 in 2013. Currently, both Landsat 7 and 8 are operational. Each satellite makes a complete orbit every 99 minutes, completes about 14 full orbits each day, and crosses every point on Earth once every 16 days. The satellites’ orbits are offset to allow 8-day repeat coverage of any Landsat scene area on the globe. Between the two satellites, more than 1,000 scenes are added to the USGS archive each day.

Although sensing equipment has been continuously improved, great effort has gone into keeping the format, resolution, and spectral sampling parameters consistent. This consistency allows for comparison of land area characteristics to analyze changes during the 40+ years of Landsat data collection.

For our purposes, one of the most attractive features of Landsat images is that the US government has made all 40+ years of data available on the internet for downloading at no cost to the public. We will make use of the Landsat image data in this textbook as one of our primary sources in learning about remote sensing.

This textbook is meant to give you only a very brief introduction to Landsat imagery; a complete discussion of the history and specifications of Landsat are beyond the scope of this textbook. For more information on Landsat, visit the USGS website at www.usgs.gov.  Another excellent source of Landsat information can be found in Chapter 6 of Introduction to Remote Sensing, Fifth Edition, by James B. Campbell and Randolph H. Wynne. Wikipedia also contains useful information about Landsat at https://en.wikipedia.org/wiki/Landsat_program.

EarthExplorer

The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. 

In order to download files using EarthExplorer, you must first create a login. 
If you have not already set up an account, do so now.

Go to http://earthexplorer.usgs.gov

On the bar near the top of the page, select Register and complete the form. You may need to ask an instructor to provide some answers. When you are done, a registration confirmation will be sent to your email address. Follow the link to activate your account.

Be sure to record your username and password for future use.

Return to EarthExplorer’s main page. If you are not already logged in, on the bar near the top of the page, select Login > Sign in with your username and password.

In the Address/Place box > type Monroe, WA > Show

Select Monroe, WA, USA

In the Coordinates box, select the Decimal tab.

Record the latitude and longitude, which will be used in the next step. Note that the longitude has a negative sign.

On the EarthExplorer menu bar, select Logout.

GLOVIS (USGS Global Visualization Viewer)

GLOVIS is another format for viewing Landsat images. 

Go to http://glovis.usgs.gov

Click on the Launch GLOVIS button.

In the upper right corner of the screen, click on the [image: ]button and select Lat/Lng.

Type the latitude and longitude from the previous step.

Click on the Jump to Location button

You can explore the many features of GLOVIS later.

LandsatLook 

Another place to search for remote sensed image data is on the easy-to-use USGS website http://landsatlook.usgs.gov This site allows you to search for a location and then zoom in to see the full resolution data of all Landsat scenes available. When you select an image to download, the request will be processed by EarthExplorer.

Esri’s Landsat Explorer provides quick and easy access to more than 500,000 Landsat images. Normalized Difference Vegetation Index analysis are available for world-wide locations; however, the resolution is not detailed enough for use in the crop monitoring of our project.

http://landsatexplorer.esri.com/ 
[bookmark: _Toc9345680]Chapter 7:
Acquiring Remote Sensed Data

This chapter includes:
· Researching available data for your study area 
· Downloading Landsat data
· Some useful facts about Landsat data

The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. You will download Landsat images covering your study area. A good description of the Landsat program can be found at http://en.wikipedia.org/wiki/Landsat_program

Two versions of Landsat images are available. 

Level 1 images are georeferenced for consistency but are not corrected for atmospheric conditions. Level 1 images are available very quickly after the image is captured by the Landsat sensors.

Level 2 images have atmospheric corrections applied to Level 1 data to produce surface reflectance measurements. Surface Reflectance products provide an estimate of the surface spectral reflectance as it would be measured at ground level in the absence of atmospheric scattering or absorption. Level 2 images are available within 1-3 days following the time the images are captured by the Landsat satellite sensors.

Why use Level 2 instead of Level 1? The primary reason is that Level 2 images have been atmospherically corrected so the consistency between images captured on different days is much higher.

The process of producing Level 2 images can best be researched online for those interested in the details but is beyond the scope of this curriculum.

For our study, from this point forward, we will use Landsat Level 2 images.

Step 1: Create a folder for saving Landsat images

In the Monroe folder, create a sub-folder named Landsat.

Step 2: Log into the USGS website

Go to http://earthexplorer.usgs.gov/

On the EarthExplorer menu bar, select Login > Sign in with your username and password. If you have not already set up an account, follow the instructions in the previous chapter.   

Step 3: Define the parameters for your request for Landsat images Level 2

When choosing date ranges for images, think carefully about the vegetation condition of crops at various times of the year - planting, growing, harvest, fallow. 

On 15 May 2018 the condition of the field being studied was freshly plowed and the corn seed was planted that day. This is the view seen from a drone of half of the field 2 days after planting. The green “fingers” are drainage ditches.

[image: ]

Now look for the Landsat image nearest the date of planting.

In the box Address/Place > type Monroe, WA > Show

Select Monroe, WA, USA from the list displayed in the Address/Place box.

Select a Date Range 
For this exercise choose the date range of 05/13/2018 to 05/15/2018

Select the Data Sets tab 
Click the + box next to Landsat 
Click the + box next to Landsat Collection 1 Level 2 (on demand)
Click the box next to Landsat 8 OLI/TIRS C1 Level-2

Select the Results button at the bottom of the pane

For the image for Path 46 Row 27
Select Order Scene icon  [image: ] for the map you chose
Select the View Item Basket button
Select the Proceed to Checkout button
Click the title of the Data Set in the item basket
Select the Submit Order button

Select Logout 

In your email folder you should receive the following emails:
· Order confirmation
· Processing the order
· Processed order available for download (might take some time to receive)

After the third email arrives (“available for download”)
Note the last four digits of the order number
Double click on the link to begin the download
Select the file with correct order number to download (usually the topmost)
Click on Download

After the download completes, browse to locate the downloaded file
Copy / paste the file to the folder Landsat in the folder Monroe

Step 4: Uncompress the Landsat Level 2 file

For Mac using Keka (Mac version of 7-Zip), skip this step. Setting Keka as the default extraction application in Chapter 3, Step 3 will allow Keka to automatically uncompress or extract the downloaded Landsat file.

Uncompress the downloaded Landsat file (7-Zip is a commonly used program for this purpose)
Browse to the folder Landsat
Uncompress Landsat images in gz file using 7-Zip (or whatever program you use to uncompress files)
Uncompress Landsat images in tar file using 7-Zip (or whatever program you use to uncompress files)
Select folder Landsat as the destination for the unzipped files

Step 5: Organize files

Browse to the folder Landsat
Create folders with these names:
14-May-2018
15-Jun-2018
8-Jul-2018
24-Jul-2018
3-Sep-2018
19-Sep-2018
12-Oct-2018

Copy the downloaded Landsat files ending in sr-band4 and sr-band5 into the folder named 14-May-2018

Step 6: Cleanup files

When you are finished, you can delete the gz and tar files to save disc space
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Analyzing
Remote Sensed
Data



[bookmark: _Toc369960538][bookmark: _Toc9345682]Chapter 8:
Image Interpretation

This chapter includes:
· Interpreting single images
· Interpreting analyzed images

Interpreting single images

Photos and satellite images are useful primarily because they can be used to identify the position and properties of features that are of interest. Interpreters use size, shape, color, brightness, texture and location to identify features and convert images into information. Image interpreters must have some familiarity with the features of interest. Ground truthing is essential to develop the local knowledge required for accurate image interpretation. 

The practice of image interpretation is a well-developed discipline and uses many specialized techniques. A detailed description of image interpretation is beyond the scope of this handbook. Books and internet resources are available that teach this skill in detail. 

Satellite images are like maps: they are full of useful and interesting information, provided you have a key. It is important to remember that satellite images are an overhead view -- an unfamiliar perspective.  The following is a review of a few of the highlights of image interpretation focusing on satellite images. 
Look for a Scale: One of the first things people want to do when they look at a satellite image is to identify the places that are familiar to them: their home, school, or place of business; a favorite park or tourist attraction; or a natural feature like a lake, river, or mountain ridge. The level of detail depends on the image’s spatial resolution. Like digital photographs, satellite images are made up of little dots called pixels. The width of each pixel is the satellite’s spatial resolution. For the Landsat images we will be using, the resolution for one pixel is 30 meters on each side (900 sq meters).
Look for patterns, shapes, and textures: Bodies of water—rivers, lakes, and oceans—are often the simplest features to identify because they tend to have unique shapes and they show up on maps. Other obvious patterns come from the way people use the land. Farms usually have geometric shapes—circles or rectangles—that stand out against the more random patterns seen in nature. When people cut down a forest, the clearing is often square or has a series of herring-bone lines that form along roads. A straight line anywhere in an image is almost certainly human-made, and may be a road, a canal, or some type of boundary made visible by land use.

Define Colors: The colors in an image will depend on what kind of light the satellite instrument measured. True-color images use visible light—red, green and blue wavelengths—so the colors are similar to what a person would see from space. False-color images incorporate infrared light and may take on unexpected colors.
Water: Water absorbs light, so it is usually black or dark blue. 
Plants: Plants come in different shades of green, grasslands tend to be pale green, while forests are very dark green. Land used for agriculture is often much brighter in tone than natural vegetation. In some locations (high and mid latitudes), plant color depends on the season. Spring vegetation tends to be paler than dense summer vegetation. Fall vegetation can be red, orange, yellow, and tan; leafless and withered winter vegetation is brown. For these reasons, it is helpful to know when the image was collected.
Find North: If you know where north is, you can figure out if that mountain range is running north to south or east to west, or if a city is on the east side of the river or the west. These details can help you match the features to a map
Consider your Prior Knowledge: Perhaps the most powerful tool for interpreting an image is knowledge of the place. If you know that a wildfire burned through a forest last year, it’s easy to figure out that the dark brown patch of forest is probably a burn scar, not a volcanic flow or shadow.
Interpreting analyzed images

Because most of us are not trained and experienced interpreters of remote sensed images, we will use some techniques of automated image analysis to help us understand the image data we are seeing. One specialized analysis technique we will learn in the next chapter is Normalized Difference Vegetation Index (NDVI). Instead of attempting to interpret individual images, we will use QGIS software to analyze two images and produce a visualization that is customized for the interpretation of vegetation health. 

Using established processes such as NDVI transfers our interpretation requirements from examining raw remote sensed image data to understanding and interpreting automated analysis methods and outputs. More on this topic in the next chapter.


[bookmark: _Toc369960539][bookmark: _Toc9345683]Chapter 9:
Normalized Difference
Vegetation Index (NDVI)

This chapter includes:
· Definition of NDVI
· Instructions for completing NDVI analysis
· Examples of NDVI outputs

The Normalized Difference Vegetation Index (NDVI) has been used for many years to measure and monitor plant growth (vigor), vegetation cover, and biomass production from multispectral satellite data. We will create NDVI image maps using Landsat data in the visible red and near infrared regions of the electromagnetic spectrum. 

NOTE: – For images from Landsat satellites 1-7; band 3 is used for red and band 4 for near-infrared. For Landsat 8 the band designations changed; red is now band 4 and near-infrared is now band 5.

NDVI for Landsat 8 is calculated as follows: 
NDVI = (Band 5 – Band 4) / (Band 5 + Band 4)

The principle behind NDVI is that Band 4 is in the visible red-light region of the electromagnetic spectrum where chlorophyll causes considerable absorption of incoming sunlight. Band 5 is in the near-infrared region of the spectrum where a plant's spongy mesophyll leaf structure creates considerable reflectance. As a result, vigorously growing healthy vegetation has low red-light reflectance and high near-infrared reflectance, and hence, high NDVI values. 

[image: ]

This relatively simply algorithm produces output values in the range of -1.0 to 1.0. 
· Negative values of NDVI (values approaching -1) correspond to deep water.
· Values near zero (-0.1 to 0.1) generally indicate non-vegetated features such as barren surfaces (rock and soil) and water, snow, ice, and clouds. 
· Low, positive values represent shrub and grassland (approximately 0.2 to 0.4). 
· High values indicate temperate and tropical rainforests (values approaching 1). 
· Typical range of values is between about 0.2 (for a not very green area) to 0.9 (for a very green area)

[bookmark: del2]Step 1: Define our study area

In Chapter 5 we defined our study area and created a shapefile named StudyArea that we will use in this exercise. If you have not already created the study area map, follow the instructions in Chapter 5 now.

Step 2: Add Landsat images to the QGIS project

At the time these instructions were prepared, the current version of QGIS is 3.4. When later versions are released, some changes to these instructions may be needed.

Start QGIS

[bookmark: next]On the QGIS menu bar 
Select Project > Open 
Browse to folder Monroe
Select File Name CropMonitoring
Open

Next, load the Landsat images downloaded in Chapter 7 into QGIS and clip the data images to only include data for the study area. Only images from spectral bands red and near infrared (NIR) will be used to calculate NDVI. 

The following instructions assume the use of images from Landsat 8. If using images from Landsat 1-7, change the band numbers to 3 and 4.
On the QGIS side bar select the Add Raster Layer icon [image: ]
Browse to the folder 14-May-2018 in folder Landsat
Select the file ending in sr-band4 (band 4)
Select the file ending in sr-band5 (band 5)
Open > Add
Close

Step 3: Clip Landsat images to the size of the study area

Clip the Landsat images to the size of the study area. Note: it is important to perform these steps in the following order.

On the QGIS menu bar 
Select Raster > Extraction > Clip Raster by Mask Layer
In the Input layer box, select the file ending in sr-band4 (band 4)
In the Mask layer box, select StudyArea

Check box Match the extent of the clipped raster to the extent of the mask layer 
Click on Run button

Close

In the Layers panel
Right click on layer Clipped (mask)
Select Rename Layer
Type band4 in the layer name
Enter

Repeat the previous actions in this step for the layer ending in sr-band5 (band5)"

Right click the first Landsat image layer with the long name ending in..sr_band4
Remove Layer > OK
Right click the second Landsat image layer with the long name ending in .sr_band5
Remove Layer > OK

Right click on the layer StudyArea
Select Zoom to Layer 

On the QGIS menu bar 
Select Project > Save 

Landsat data for the study area displayed on your computer screen should now look similar to this: (see below)


[image: ]

Step 4: Perform calculations to create the NDVI raster layer

Each Landsat image is a single band grayscale raster with integer pixel values (1-65536). Since NDVI is “normalized” the values are always fractions. Therefore, it is necessary to first multiply the raster band5 by 1.0 to convert it to a real value. Otherwise the result will be an integer, leaving the whole computed NDVI raster with values rounded to 0. 

On the QGIS menu bar 
Select Raster > Raster calculator

 Click on the box to the right of Output layer box
Browse to the folder 14-May-2018 in folder Landsat
Type NDVI-14-May-2018 in File Name box
Save

In the Output CRS box
Select ESPG:32610 WGS 84 / UTM zone 10N

Enter the following expression in the Raster calculator expression box
(Enter this formula by double-clicking on each item and operator on the screen. The number “1.0” must be typed in). do not copy paste (it won't work)

("band5@1" * 1.0 - "band4@1") / ("band5@1" + "band4@1")

OK

Step 5: Create an NDVI color ramp 
(it is only necessary to perform this step one time)

GIS software uses a “color ramp” to assign various colors to represent a range of reflectance values. One example of a color ramp looks like this:

[image: ]

Define a color ramp in QGIS by performing a one-time action to create a custom NDVI color ramp. This step creates a custom color ramp file that will be used in the following steps.

Select and Copy the following text 

[bookmark: _Hlk518735519]# QGIS Generated Color Map Export File – Landsat Level-2
INTERPOLATION:DISCRETE
0.0,0,76,255,255,Water
0.2,191,163,124,255,Bare Surface / Clouds
0.7,177,223,171,255,Scattered Vegetation
0.8,61,166,89,255,Moderate Vegetation
0.99,0,87,27,255,Dense Vegetation

Start Word (or compatible program such as Notepad)
File > New to create a blank document
Paste the copied text into the blank document
File > Save As 
Browse to the folder Landsat
Name the file NDVIColorRamp-Level2
Select Save as type Plain Text 
Save > OK
File > Close

In QGIS uncheck all the layers except the layer named NDVI-14-May-2018

Right click on NDVI-14-May-2018
Properties > Symbology 
In Render type select Singleband psuedocolor 
In Interpolation select Discrete
Click on the file folder icon [image: ]
Browse to folder Landsat
Select NDVIColorRamp-Level2
Open

The color ramp should now look similar to this:

[image: ]

Click on down arrow to the right of the box labelled Style at the bottom-left of the page[image: ]
Select Save Style
Browse to the folder Landsat
In File name box, type NDVI_Color_Ramp
Save > OK

Step 6: Adjust the colors of the NDVI raster map

Positive NDVI values, shown in increasing shades of green in the NDVI image, indicate increasing amounts of healthy vegetation. NDVI values near zero and negative values indicate non-vegetated features such as barren surfaces (rock and soil) and water, snow, ice, and clouds. 

Right click on the layer named NDVI-14-May-2018
Properties > Symbology 
Click on down arrow to the right of the box labelled Style
Select Load Style
Browse to the folder Landsat
Select the file named NDVI_Color_Ramp
Open

The color ramp should look similar to this:
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When a pixel value falls between two numbers, the color of the higher number in the range will be rendered.

Select OK

At this point your screen should look something like this:

[image: ]


NDVI Level-2 analysis of study area for 14 May 2018

Step 7: Making changes to the color ramp

For this case study, the color ramp does not need any change. However, if a change is necessary based on ground truthing data, changes can be made by following this method:

Select layer NDVI-14-May-2018 > Properties > Symbology

To change a Value, Color or Label
Double click on the item to be changed
Type a different value 
Press Tab key
OK

Step 8: Update metadata for the NDVI layer

Select layer NDVI-14-May-2018 > Properties > Metadata 
In the Title box of the Identification tab, copy and paste the following text
NDVI Level 2 – 14 May 2018
In the Abstract box, copy and paste the following text
Data source: USGS, Landsat 8, Path 46 / Row 27
Acquisition Date: 14-May-2018
In the Access tab, in the Rights (attribution or copyright) box
Click on + button
Copy and paste the following text
Landsat images courtesy of the U.S. Geological Survey
Apply > OK

Step 9: Cleanup

Right click the layer named band4
Remove > OK

Right click the layer named band5
Remove > OK

Step 10: Save the project and exit

On the QGIS menu bar 
Select Project > Save 
On the QGIS menu bar 
Select Project > Exit QGIS > Save

Step 11: Interpretation

Recall from the definition of NDVI that the intense green is the most complete coverage of healthy vegetation. At the opposite extreme in the example using the custom color ramp is blue indicating water surfaces. Large areas of brown indicate non-vegetative surfaces which, at this time of the year, is likely bare earth or a mix of bare earth with sparse vegetation such as weedy areas. 

Exercise: The resolution of Landsat images is 30 by 30 meters. This means that when calculating the NDVI values, each pixel value represents an area of 900 square meters. To get an idea of the size of the area represented in one pixel of the Landsat image, go outside and do the following:
· Locate an open area
· Mark a starting point with an object large enough to be seen from a distance
· Walk away from the object while counting your steps
· Count until you reach 35 normal steps
· Look back to your starting point
· Imagine that the line between your current location and the starting point is one side of a square
· Envision the size of the square which is the area represented by one pixel of a Landsat image


[bookmark: _Toc9345684]Chapter 10:
Applying NDVI Analysis
To Crop Field Area

This chapter includes:
· Clip NDVI analysis area to selected crop field
· Interpretation of completed NDVI analysis

In Chapter 5 a corn field was chosen to follow for the study of crop development. Clip the study area NDVI image to only contain values inside the crop area.

Note: the term “crop” has two different meanings in the following text. 
· Crop (noun) a cultivated plant that is grown as food, e.g., a grain, fruit, or vegetable
· Crop (verb) to cut very short, trim, snip 

Step 1: Open the QGIS project file

Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder Monroe
Select File Name = CropMonitoring
Open

Step 2: Clip NDVI image to the size of crop field area

On the QGIS menu bar 
Select Raster > Extraction > Clip raster by mask layer
In the Input layer box
Select the layer NDVI-14-May-2018
In the Mask layer box
Select the layer CropArea

Check the box 
Match the extent of the clipped raster to the extent of the mask layer

In the Clipped (mask) box, select Save to File
Browse to folder 14-May-2018 in folder Landsat
In File Name box type NDVI-Crop-14-May-2018
Save

Click on Run button
Close

In the Layers panel
Right click on layer Clipped (mask)
Select Rename Layer
Type NDVI-Crop-14-May-2018 in the layer name
Enter

Uncheck the box next to the layer NDVI-14-May-2018

Check the box next to the layer CropArea

Right click on the layer CropArea
Select Zoom to Layer 

(optional) Right click on the layer NDVI-14-May-2018
Select Remove Layer > OK 
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Step 3: Adjust the colors of the NDVI raster map

Positive NDVI values, shown in increasing shades of green in the NDVI image, indicate increasing amounts of healthy vegetation. NDVI values near zero and negative values indicate non-vegetated features such as barren surfaces (rock and soil) and water, snow, ice, and clouds. 

Select layer NDVI-Crop-14-May -2018
Properties > Symbology 
In Render type select Singleband pseudocolor 
In Interpolation select Linear
Scroll down 
Click on the file folder icon [image: ]
Browse to folder Landsat
Select NDVIColorRamp-Level2
Open
OK

At this point the screen should look similar to the following image. Instructions for adding a legend, scale bar and comments are covered later in Chapter 16.
[image: NDVI-15-May]
NDVI Level-2 analysis for 14 May 2018

Step 4: Interpretation  

From the NDVI analysis we draw the conclusion, that, on 14 May 2018, most of the field is bare dirt (brown) but some scattered vegetation (light green) is growing in the drainage ditches and at the edges of the plowed field.

In QGIS 
Select the layer NDVI-Crop-14-May-2018 
Click on the “information icon” [image: ]
In the lower left corner of the Identify Feature panel
In the View box, choose Tree

Move the cursor over some light green cells, left click, and read values in the range of 0.3 to 0.4. Examine values in some brown cells.



[bookmark: _Toc9345685]Chapter 11:
Ground Truth Sampling

This chapter includes:
· Definition of ground truthing
· Using GPS in ground truthing data collection
· Sources of useful information for ground truthing

Ground truthing is a term used in remote sensing to refer to information collected on location. Ground truth information allows digital image data to be related to real features and materials on the ground.

Ground truthing is usually done on site, performing observations and measurements of various properties of the features of the ground resolution cells that are being studied on the remotely sensed digital image. 

Field note-taking: Take detailed field notes of observations when you are on-site. You think you will remember the details – but a few weeks or months later, some details will be forgotten or remembered inaccurately.

Local knowledge: Talking with a local person may uncover useful information that is not obvious to your observations. Make a list of questions you need answered the next time you encounter a person who is familiar with your study area.

GPS: When using a GPS to determine the coordinates of a location, set the GPS datum to the same datum used by the digital maps in your GIS. One of the most commonly used datums is WGS 84. You can determine the datum used in your digital map by using your GIS software to look in the map’s metadata.

Set the GPS’s coordinate unit format to meet the input requirements of your GIS software, e.g., QGIS input requires that latitude and longitude be formatted as a decimal number so you must set the GPS coordinate unit’s format to degrees and decimals of degrees.

Photos: Photography is a valuable method of preserving your observations of time, place and conditions. Photos taken with a mobile device usually contain embedded latitude and longitude data if locations services are turned on (geotagging). An app such as ExifViewer downloaded to your mobile device will display metadata for each photo including lat / lon. Photos can be displayed on GIS maps if geotagging is enabled in the camera.

Drones: Photos taken from a drone allow you to “visit” locations in your study area that may not be accessible on foot. Although technically, drone photos are classified as another form of remote sensing, viewing your study area from a few hundred feet up can be almost like “being there”.

Internet research: Some ground truthing information can be found on property parcel map websites usually maintained in the US at the county level. The reason for maintaining parcel information at this level is because parcels are the basis for property taxation. 

The following information on our corn field is from http://gis.snoco.org/maps/property/index.htm  You can see that our corn field covers three parcels, the parcel with the red dot as well as the parcels to its left and right.

Parcel Number: 27062300400500
Parcel Owner: TULALIP TRIBES OF WA, 8802 27TH AVE NE, TULALIP, WA 98271
Size: 39.89 acres
Use code: 830 Open Space Agriculture RCW 84.34
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Developing a Color Ramp for NDVI

One important use of ground truthing data is for defining the values for the NDVI color ramp. You want to have confidence the colors displayed in your map legend accurately represents the reality of conditions in the study area.

General ranges of values in NDVI layers start with water at 0.0 (low end) and go to 1.0 (high end) for extremely healthy dense vegetation.

For this case study, define five categories of ground cover:
	Category
	Upper limit pixel value
	Color
	Color sample

	Water
	0.0
	Blue
	……

	Bare Surface / clouds
	0.2
	Brown
	……

	Scattered vegetation
	0.7
	Lt Green
	……

	Moderate vegetation
	0.8
	Med Green
	……

	Dense vegetation
	0.99
	Dark Green
	……



Start the definition process at the lower end of NDVI values – those are the NDVI values of radiance from deep water. Locate a body of deep water on your map and note the coordinates. At that location on your NDVI layer, use the Identify Features icon to “read” the pixel values at several locations well inside the boundaries of the body of water. The highest value you observe will be the value defined as the upper limit for “water’. Normally, this upper limit for deep water is near zero.

Note: Shallow water such as puddles will have slightly positive values generally below 0.2. The same phenomenon is seen around the shoreline of deep-water bodies.
Next, move attention to the highest NDVI values – dense, healthy vegetation. It is best to visit some locations that have a dense canopy of tree cover. The size of the area should be at least 200 meters by 200 meters. As close as possible, use a GPS device to identify the coordinates of the center of the dense area. If an on-the-ground visit is not possible, an alternate method is to use Google Earth to determine coordinates of the center of an area of dense, healthy vegetation. Again, note the coordinates. At that location on your NDVI layer, use the Identify Features icon to “read” the pixel values at several locations well inside the boundaries of the dense vegetation. The lowest value you observe will be the value defined as the lower limit for “dense vegetation”.
Then, locate an area of bare surface or pavement. Get some help from Google Earth if necessary. 

On the QGIS menu bar 
Select View > Panels > Browser
Click on plus sign next to XYZ Tiles
Double click on Google Satellite

If Google Satellite is not shown
On the QGIS menu bar
Select View > Panels > check mark Browser
Right click on tab next to XYZ Tiles > New Connection
Type in Name box Google Satellite
Copy & Paste into URL box https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z}
OK
Under XYZ Tiles double click on Google Satellite

Choose a 200x200 meter area and identify the coordinates of the center of the area. At that location on your NDVI layer, use the Identify Features icon to “read” the pixel values at several locations well inside the boundaries of the bare surface / pavement. The highest value observed will be the value defined as the upper limit for “bare surface / pavement”.
The values between “bare surface” and “dense vegetation” are not as easy to define. We will define two categories, “scattered vegetation” and “moderate vegetation”. Scattered vegetation for our purposes will represent the case where up to 50 % of the surface is covered by vegetation. 

One method of defining color ramp values for scattered vegetation is to wait for the crop under observation to be planted and then choose a time when the vegetation covers no more than 50% of the ground and the other 50% is bare soil. Use the technique described earlier to identify the location and sample the pixel values in the NDVI image to set the “scattered vegetation” value in the color ramp. 

Moderate vegetation for our purposes will represent the case where 50 to 80 % of the surface is covered by vegetation. When coverage is about 75% vegetation, repeat the steps for “moderate vegetation”. This range will also include the situation where vegetation is not healthy. 
These color ramp value definitions are only approximations. Adjust the color ramp values to agree with the conditions observed during ground truthing. 



[bookmark: _Toc9345686]Chapter 12:
Analyzing Images during
the Growing Season

This chapter includes:
· Compute NDVI for a time series of different crop maturity stages
· Interpret the results of the analysis

We can analyze the change of vegetation as the corn crop matures.

Step 1: Calculate NDVI for the yellow highlighted dates using Level 2 images

	Activity
	Date
	Height (in)
	Path
	Row

	Too wet to plow
	4/19/2018
	0
	47
	27

	Pre-till
	5/5/2018
	0
	47
	26

	Planted
	5/14/2018
	0
	46
	27

	Sprouted
	5/22/2018
	2
	47
	27

	Part veg/part dirt
	5/30/2018
	5
	46
	27

	Part veg/part dirt
	6/6/2018
	8
	47
	27

	50% coverage – sct clouds
	6/15/2018
	13
	46
	27

	No cloud-free image
	6/23/2018
	27
	
	

	No cloud-free image
	7/1/2018
	48
	
	

	100% coverage
	7/8/2018
	60
	47
	27

	Pre-tassel
	7/17/2018
	80
	46
	27

	Tasseled
	7/24/2018
	80
	47
	27

	No cloud-free image
	8/2/2018
	80
	
	

	Full-tasseled
	8/9/2018
	80
	47
	27

	Full-tasseled
	8/18/2018
	80
	46
	27

	No cloud-free image
	8/25/2018
	80
	
	

	Full-tasseled
	9/3/2018
	80
	46
	27

	Drying out – sct clouds
	9/10/2018
	80
	47
	27

	Drying out
	9/19/2018
	80
	46
	27

	No cloud-free image
	9/26/2018
	80
	
	

	No cloud-free image
	10/5/2018
	80
	
	

	Harvested
	10/12/2018
	0
	47
	27




Step 2: Planting corn in the field

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 14 May 2018. 

Analysis: The field is bare dirt as verified by ground truthing. The Landsat satellite image agrees with ground truthing after defining color ramp values for “bare surface”.

Step 3: Partial Coverage – vegetation versus bare surface

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 15 June 2018. (it should look like this)
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Analysis: Clouds cover the left end of field and one small area in right half of field 

[image: ]

After verifying that the light brown areas are actually clouds, make a change to this layer’s color ramp

Select layer NDVI-15-Jun-2018 > Properties > Symbology
To change the color brown to white (clouds)
Double click on the color brown in the Color column
Select the white area in color triangle of the Change color panel
In the Label column of the same row, delete the words Bare surface
Press Tab key
OK

(Optional) Chapter 21 describes one method of looking for cloud outlines in Landsat images. If you are interested, try this technique on the Landsat image for 15 June 2018.

Step 4: Vegetation coverage is nearly 100% of field

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 8 July 2018


Note: Optionally, the NDVI images can be efficiently clipped and analyzed using the QGIS Model Builder saving time, effort and eliminating errors. See Chapter 19 to learn to create and run NDVI analysis using Model Builder.

Analysis: The amount of dark green vegetation has increased – about what we expected at this time in the growing season. However, the area on the left side of the image shows less vigorous growth; this was the water-covered area observed in April by the drone photos.

Chapter 10, Step 3 results
[image: ]

Step 5: Corn grows tassels

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 24 July 2018

[image: DJI_0163]

Analysis: The uniform dark green indicates healthy vegetation covers most of the field. Ground truthing shows that the corn has begun to develop tassels. The lighter green areas show lingering effects of the wet areas – what else could be causing retarded growth in these two areas?

Chapter 10, Step 3 results

[image: ]

Step 6: Maturing

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 3 Sep 2018

Analysis: Ground truthing determines that the corn has reached maximum height and is maturing. Some change is indicated by the scattered areas of lighter green.


Chapter 10, Step 2 results
[image: ]

Chapter 10, Step 3 results
[image: ]

Step 7: Drying out

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 19 Sep 2018

Analysis: The vegetation began drying out between 3 and 10 September. There has been little rain in the past two months. The goal for harvesting is for the corn to be 30-35% dry weight – in other words, when a sample of the corn is dried by heating, the liquid that evaporates is 65-70% of the undried corn’s weight.

Chapter 10, Step 2 results
[image: ]

Chapter 10, Step 3 results
[image: ]

Step 8: Harvest

Complete the steps in Chapter 7, step 2 through Chapter 12, step 7 to analyze for NDVI for the date 10 Oct 2018

Analysis: Ground truthing verifies that the corn has now been cut and removed from the field. Some stalks and scattered leaves remain on the ground. The uniform light green color is what is expected for this condition.

[image: ]

October 12, 2018 NDVI Result, it should look like this

[bookmark: _Toc9345687]Chapter 13:
Sampling Point Data

This chapter includes:
· Selecting sampling points for monitoring different crop maturity stages
· Viewing sampled data on time scale

Landsat images are made up of digital values measured for each 30x30 meter pixel. If we select some meaningful locations in our study area, we can monitor the change in pixel values at that location over time. 

The pixel values we define will be helpful in setting the values for the NDVI color ramp such as was used in Chapter 10. 

Step 1 – Define the sampling points

The locations we will monitor are:
· Three locations in the middle of crop area (presumably health vegetation)
· An area observed as “wet” in early spring
· Vegetation in a drainage ditch

Step 2 – Add the points to QGIS map (this is a one-time action)

Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder Monroe
Select the File Name named CropMonitoring
Open

Add the following points to your QGIS map. Note that the coordinates are in UTM format – this is a required by the QGIS Plugin we will use.. 

ID,Type, Lon,Lat
1,Crop 1,-121.9893,47.8073
2,Crop 2,-121.9939,47.8069
3,Crop 3,-121.9963,47.8070
4,Wet,-121.9995,47.8062
5,Ditch,-121.9912,47.8067

Copy and paste the lines above into a text (.txt) file using Notepad
Name the file SamplePoints and save the file in the folder Monroe.

On the QGIS menu bar 
Select Layer 
Select Add Layer
Select Add Delimited Text Layer
In File Name box 
Browse to in the folder Monroe
Select file SamplePoints 
Open

On the File Format box
Select CSV
Select 0 in Number of header lines to discard
Select check mark in box next to First record has field names
On the Geometry Definition line
Select Point Coordinates
In the Geometry CRS box
Select Project CRS: WGS 84

[image: ]

Add
Close

Label the points

Right click the layer SamplePoints > Properties
Select Labels tab 
Select Single labels in topmost box
In Label with box, select Type
Click on Background tab
Check Draw background box
Click on Placement tab
Select Around Point circle
In Distance box, type 2
OK

Step 3 – Create an Excel spreadsheet

Create an Excel spreadsheet with the following columns and rows (This is a one-time action)


[image: ]

Save the Excel file in the folder Monroe with the file name CropData

Step 4 – Enter the sample point values into the Excel spreadsheet

Select the layer NDVI-Crop-14-May-2018 

Check the box next to the layer SamplePoints
Click on the “information icon” [image: ]
In the lower left corner of the Identify Feature panel
In the View box, choose Tree

Move the cursor over the Crop 1 sample point and left click
Enter the value from the field Band1 in row 2 of the Excel table
Repeat for each sample point

The formula for cells in row 9 is the average of rows 2,3 and 4.

Step 5 – Calculate the Mean and Standard Deviation for the Crop Area

Right click on layer NDVI-Crop-14-May-2018 
Select Properties > Information
Copy the value of STATISTICS_MEAN
Copy the value of STATISTICS_STDDEV 
OK

Enter the mean and the standard deviation in the Excel table rows 7 and 8

Step 6 – Graph the values for data visualization

After processing the seven Landsat images in the case study, enter the data for each image following the pattern in Step 5. In Excel create a graph of the data in rows 7 and 9. When the case study is completed in Chapter 12, your graph should look similar to the following chart:

[bookmark: _Toc9345688]Chapter 14:
Final Analysis and Conclusions




The graph is about what we expected – no surprises. After the peak about Jul 23 the corn leaves begin to dry (no rain) and the graph lines decreases slightly. If data were plotted for every Landsat satellite pass (8 day intervals) the graph lines would be smoother.


[bookmark: _Toc369960542][bookmark: _Toc9345689][bookmark: _Toc369960540]Chapter 16:
Printing Maps and Images

This chapter includes:
· Learning how to prepare maps for distribution
· Creating template for the map
· Adding titles, legends and text boxes to the map

These instructions will help you create a template that will make it much easier to recreate a map with the same legend and symbology. This will save you a lot of time; you will not have to recreate the legend and symbology every time for each map.

Step 1: Start QGIS

Start QGIS

On the QGIS menu bar 
Select Project > Open Recent
Browse to folder Monroe
Select File Name = CropMonitoring 
Open

Step 2: Create a new template for printing the map

Select the map layers you want to appear on the printed map. 

In the Layers Panel on the left of the screen, uncheck layers you don’t want to print. 

Select any layer whose name begins with NDVI-Crop 

Position the map in the screen as you want it to appear when printed. 
(optional) Select the Zoom In icon [image: ] and, while holding down the left click button, draw a rectangle around the area that you want to appear when the map is printed.

On the QGIS menu bar 
Select Project > New Print Layout
Type NDVI-Crop in the Create print layout Title box
OK

On the side menu bar select the Adds a new Map to the layout icon [image: http://www.qgis.org/en/_images/mActionAddMap.png] 
Hold down the left click button, draw a rectangle around the area where you want to the map to appear
If the map does not appear the way you want, 
Go back to the main map to adjust the view 
Return to Layout Manager

If the map is not in the position you want
Click Move item content [image: ]icon
Left click on the map and drag to reposition

If the map does not render clearly or sharply
Click on the Refresh view icon [image: http://www.qgis.org/en/_images/mActionDraw.png]

To keep the map from being accidentally moved, lock its position
Click anywhere inside the map
Right click inside the map
Select Item Properties
In the Layers section, check mark Lock Layers

Select menu option Layout  
Select Save as template
Browse to folder = Monroe 
File Name = NDVI-Crop (add date)
Save

Step 3: Add Legend: 

A useful feature for formatting the legend titles is the “wrap” feature. You can define a “wrap character” and insert it in the legend title to force the text following the wrap character to move onto the next line.

On the menu bar
[bookmark: _Hlk8808249]Select Add Item > Add Legend
Click in the map at the position where you want the title to appear
[bookmark: _Hlk8808425]In Height box, type 20 or a height of your choice
OK

[bookmark: _Hlk8808519]Right click with the cursor inside the Legend box > Item Properties
In Main Properties section
In Title box type Coverage

[bookmark: _Hlk8809409]Define a Word wrap character (one-time only)
In Item Properties
Select Wrap Text On box and type any character, such as @

Open Legend Items section 
Click to remove the check mark in the Auto Update box
Click on any layer you do not want to appear in the legend
Select Delete [image: ] icon

Open Fonts section
Click on Title Font
Font > Arial > Font Style > Bold > Size 24 > OK
Click on Subgroup Font 
Font > Arial > Font Style > Bold > Size 16 > OK

In Item Font select a font of your choice > OK

Resize the frame of the text box by dragging the edges to fit text

Drag the legend to the lower right corner of the map, then use the arrow keys for fine-tuning position adjustments

Step 4: Add Scale Bar:

On the menu bar, 
Select Add Item > Add Scale Bar
Click in the map at the position where you want the title to appear
[bookmark: _Hlk8809701]In Height box, type 20 or a height of your choice
OK

In the Item Properties section
In Scalebar units box, select Meters
In the Label unit multiplier box, type 1.0	
In the Label for units box, type meters
In Segments, select Left 0 and Right 3

Check Frame and Background boxes

Resize the frame of the text box by dragging the edges to fit text

If you have not already done so, drag the scale bar to the lower left corner of the map, then use the arrow keys for fine-tuning position adjustments

Step 5: Add Map Title:

On the menu bar
Select Add Item > Add Label
Click in the map at the position where you want the title to appear
In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type an appropriate title for the map, such as:

NDVI – Corn Field – date 2018

Select Font 
Font > Arial > Font Style > Bold > Size 28 > OK

Select Horizontal alignment = Left 

Uncheck Frame and Background boxes

Resize the frame of the text box by dragging the edges to fit text

Step 6: Add Data Source Labels:

On the menu bar
Select Add Item > Add Label
Click in the map at the position where you want the text box to appear
In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type an appropriate title for the data sources, and add a list of them:

Data Sources:
- USGS

Select Font 
Font > Arial > Font Style > Bold > Size 12 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes

Position the Data Source text box in the lower center of the map

Resize the frame of the text box by dragging the edges to fit text

Step 7: Add Date and Author Label:

On the menu bar
Select Add Item > Add Label
Click in the map at the position where you want the text box to appear
In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type your name and the date the map was created

Select Font 
Font > Arial > Font Style > Bold > Size 10 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes

You can resize the frame of the text box by dragging the edges to fit text

Position the date label box in any part of the map.

Step 8: Add North Arrow

On the menu bar
Select Add Item > Add Picture 
Left click in the lower right corner of the map at the position where you want the North Arrow to appear -> OK

On the right panel select Main Properties tab 
Click on Search directories section to expand 
Choose the north arrow you prefer from icon table 
In the Placement dropdown box, select Top Left 

Uncheck the Background box 

You can resize the frame of the text box by dragging the edges to fit text

Position the north arrow box above the scale bar.
[image: ]

Step 9: Create image file of map 

Select menu option Layout 
Select Export as Image 
Browse to folder 14-May-2018 (or other folder)
In Save as type choose JPG format (*. Jpeg)
Name file with an appropriate name
Save > Save

Step 10: Print your map from the saved image

Select menu option Layout > Page Setup
Choose Orientation = Landscape
OK

Select menu option Layout 
Select Print
Select printer
Print

Step 11: Save as Template:

Select menu option Layout > Save as Template
Browse to folder = Monroe 
File name = NDVI-Crop
Save > Yes

Select menu option Layout > Close

Step 12: Save Project
	
On the QGIS menu bar 
Select Project > Save 
On the QGIS menu bar 
Select Project > Exit QGIS > Save

[bookmark: _Toc4643836][bookmark: _Toc9345690][bookmark: _Toc369960543]Chapter 17:
Telling the Story

This chapter includes:
· Creating a PowerPoint of the story the data is telling
· Preparing spoken presentation

PowerPoint outline

Introduction
Purpose and significance of the study
Materials and Methods
Study area
Data resources
Methodology
Results
Status at baseline
Change over time
Discussion
Expectations
Timing
Anomalies
Conclusions
Acknowledgements

Guidelines on speaking presentation




[bookmark: _Toc9345691]Part 5: 
Useful Tools

[bookmark: _Toc369960548][bookmark: _Toc517424046][bookmark: _Toc9345692][bookmark: _Toc369960545]Chapter 18:
Creating a Study Area
Using Google Earth

This chapter includes:
· Instructions for creating a study area using Google Earth features

Now that you have some map layers in your GIS project file, you may want to study a different area of special interest. Let’s define a new study area that is a subset of the full image area.

Step 1: Run the Google Earth program and locate your area of interest

	Install Google Earth from google website (if needed)

Start Google Earth

Navigate to the general area you wish to define as your study area.

Step 2: Set the Google Earth coordinate system to match your QGIS project coordinate system

The coordinate system you use for your QGIS project must be the same as the coordinate system defined in Google Earth so that the file created in Google Earth will register correctly when you bring it into your QGIS project.

Select menu item Tools > Options 
Select the 3D View tab 
In the Show Lat/Long box
If you plan to work with Landsat images
Choose the Universal Transverse Mercator button
If you plan to work with GADM administrative boundary maps
Choose the Decimal Degrees button
Apply > OK

Step 3: Draw a polygon around your study area
Select the Add Polygon [image: ] icon

In the Name box, type StudyAreaGE

Move the cursor outside the polygon parameters box to the upper left corner of your desired study area. You may need to move the parameters box out of the way by left clicking in the title bar, then, while holding the left click button down, drag the box to an unused position on your screen.

Position the cursor at the upper left corner of your study area and left click
Move the cursor to the upper right corner of your area and left click
Move the cursor to the lower right corner of your area and left click
Move the cursor to the lower left corner of your area 
If your study area is not a rectangle, you can left click on as many points as you need
OK

[image: ]

The polygon will look similar to this

Step 4: Save your study area polygon as a KML file

On the menu File > Save > Save Place As 
browse to folder named Monroe 
type File Name = StudyAreaGE
select File Type = KML
Save

Step 5: Add the KML file of your study area to QGIS project

Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to the folder where your project is located
Select your project file
Open
[bookmark: KML]On the QGIS side tabs, select Add Vector Layer icon [image: ]
For Dataset, browse to folder where your project is located
In the box to the right of File Name select file type KML
Select the file named StudyAreaGE
Open > Open

Step 6: Create a shapefile of your study area

Right click the layer StudyAreaGE 
Select Save as option
Choose Format = ESRI shapefile 
In Encoding, choose Layer CRS
Browse CRS 
Select in the Coordinate Reference Systems of the World box the same reference system that you are using for your reference map project > OK
Click to put a check in the box Add saved file to map
In Save As box, browse to folder where your project is located
In File Name box type, StudyAreaGE > Save
OK 

Right click on the layer StudyAreaGE
Select Zoom to Layer 

Right click the layer StudyAreaGE > Properties
Select Style tab 
Click on Simple fill
For Fill style, select No Brush 
For Border color, select black > OK
For Border style, select Solid Line 
For Border width, type 1
Apply > OK

Right click the layer StudyAreaGE for the KML file
Select Remove > OK

Step 7: Save the Project

The new shapefile named StudyAreaGE defining your study area has already been saved in folder Monroe.

On the QGIS menu bar 
Select Project > Save 
On the QGIS menu bar 
Select Project > Exit QGIS
[bookmark: _Toc9345693]Chapter 19:
Adding Photos to a Map

This chapter includes:
· How to add photos to a map

If you have photos from your ground truthing work, you can add the photos to your map if the photos contain geotagging information.

Mobile phone settings required to enable geotagging of photos:

iPhone: 
One way to know if an iPhone is set to geotag photos is:
open Photos app > Albums > Places and see if the photo of interest is displayed. If you see the photo in Places, then the photo was geotagged
Settings > Privacy > Location Services (set to on) > Camera > Select While using

Android phones:
One way to know if an Android phone is set to geotag photos is to:
open Files app > Images > Camera > select your photo > Info and see if the location shows up. 
If you see a small map with the appropriate location, then the photo was geotagged
Camera app > Settings > Save Location (set to on)
If “Allow Camera to access this device’s location?” shows up, select Allow

Step 1: One-time activation of a Plugin

On the QGIS menu bar 
Select Plugins > Manage and Install Plugins
Select ImportPhotos > Install plugin > Close

Step 2: Select photo folder

On the QGIS menu bar 
Select Plugins 
Select ImportPhotos > Import Photos
In Input folder location browse to your photos folder
Click on Select Folder button
In Output file location browse to the folder Monroe
In the File Name box, type PhotosGeoLoc
Save 
OK > OK > Close

Step 3: View photos
Click on Photo icon [image: ]on toolbar
or
On the QGIS menu bar 
Select Plugins 
Select Import Photos > Click Photos

Double left-click any photo icon on the map to view the photo
[bookmark: _Toc9345694]Chapter 20:
Using Model Builder

This chapter includes:
· Definition of Model Builder
· Instructions for creating the model
· Instructions for running the model

Clipping Landsat images and performing NDVI analysis requires performing QGIS tasks in order and repetitively. We can use the QGIS Model Builder to organize the tasks and perform the steps again and again using only a few keystrokes.

Begin by clipping the Landsat images. Once the clip function is finished, then perform the NDVI analysis. 

Step 1: Building the model

Start QGIS

On the QGIS menu bar 
Select Project > New 

On the QGIS menu bar 
Select Processing > Graphical Modeler

In the Name box, type Clip and NDVI
In the Group box, type Monroe

In the lower left corner, select the tab Inputs

Click on Raster Layer and drag it onto the main screen
In the box Parameter Name, type Band4
Check the box Mandatory
OK

Repeat that step changing the name to Band5

In the lower left corner, select the tab Algorithms

Click on the plus sign to the left of GDAL
Click on the plus sign to the left of Raster Extraction
Drag Clip Raster by Mask Layer onto the main screen
In Description box, type Clipped Band4
In Input Layer box, select Band4
In Mask Layer box 
Browse to folder Monroe
Select CropArea.shp
Open
In the Assign a specified nodata value…. box
Type 0 
In the Match the extent of the clipped raster… box
Select Yes
OK

Repeat that step changing the names to Band5

Click on Save Model As icon on top left of screen
Browse to the folder Landsat
In the Name box, type Clip2NDVI
Save

Now we will use the clipped file as input to the NDVI calculation. 

Note: I tried using the algorithm Raster Calculator under Raster Analysis but could not get it to work. The following method is not the most efficient, but it works.

Click on the plus sign to the left of SAGA
Click on the plus sign to the left of Raster Calculus
Drag Raster Difference onto the main screen
In the box named A, select …ClippedBand5
In the box named B, select …ClippedBand4
In the box Parent Algorithms select Select All > OK
OK 

Drag Rasters Sum onto the main screen
In the box named Grids
Select the two bands that start with Clipped (mask) …
In the box Parent Algorithms 
Select ClippedBand4 and ClippedBand5
OK > OK

Drag Raster Division onto the main screen
In the box named Dividend
Select the band that start with Difference …
In the box named Divisor
Select the band that start with Sum …
In the box named Quotient type NDVI-Crop
In the box Parent Algorithms select Raster Difference and Raster Sum
OK > OK

Click on Save icon on top left of screen

Your model should look similar to this:

[image: ]

Click on the X in the upper right corner to exit Model Builder

Step 2: Running the model

Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder Monroe
Select File Name CropMonitoring
Open
On the QGIS side bar select the Add Raster Layer icon [image: ]
Browse to the folder 19-Apr-2018 in folder Landsat
Select the file ending in sr-band4 (band 4)
Select the file ending in sr-band5 (band 5)
Open > Add
Close

On the QGIS menu bar 
Select Processing > Graphical Modeler
Click on the folder icon [image: ] in the upper left corner
Browse to the folder Landsat
Select the Model Builder file named Clip2NDVI
Open

Click on the Run model arrow on the menu bar
In the box named Band4 select the raster image ending in ..sr_band4
In the box named Band5 select the raster image ending in ..sr_band5
Run

The process may take up to a minute depending on the speed of your computer.

When the calculations are complete, Close

Return to your main QGIS screen and you should see your NDVI analysis of the crop area. 

Apply the color ramp style to view the vegetation categories.
[bookmark: _Toc9345695]Chapter 21:
Looking for Clouds

This chapter includes:
· Analyze Landsat images for clouds

One of the problems with Landsat images is the presence of clouds which obscure the earth’s surface. Several techniques for overcoming this problem have been developed but are beyond the scope of this document. However, the following process will help identify the areas that are obscured by clouds. This chapter is a work in process. There are some problems with the plugin which, hopefully, will be resolved in the times ahead.

Install the Plugin Cloud Mask

As of 13 Nov 2018, this plugin causes QGIS 3.4/6 to crash. But it works well in QGIS 3.2 
This plugin is not working in QGIS 3.2 for Landsat Level 2 images downloaded using EarthExplorer.

Start QGIS

On the QGIS menu bar 
Select Plugins > Manage and Install Plugins
Select Cloud Masking > Install plugin > Close

Download Landsat image -- all bands - 14 June 2018 – Level 1 only

On the QGIS menu bar 
Select Plugins > Cloud mask for Landsat products > Cloud Masking
Move cloud masking panel to middle of screen by dragging heading bar 

Select Open and Load tab
Browse for MTL format file in folder 15-Jun-2018
Open
Select Load button
Select Load Stack button

Select Filters and Mask tab
Select FMask check box
Select Water check box
Select Generate Mask button

“QGIS Not responding” message is normal – be patient—a long delay at 70% is normal. This is heavy computation time – this step can take as much as 10-12 minutes. Wait for blue wheel to stop spinning. The word DONE will display next to the Generate Mask button

Result will be a new layer named Cloud Mask

Note: as of 13 Nov 2018 selected area and shape area options cause QGIS to error – so don’t use those options

Select Apply and Save tab
Click on Save Mask button > Save
In Select output file for save result box
Click Select button
Browse to Jun-14 folder
In File Name box type FMaskClouds
Save

Click Apply mask button

Close Cloud mask panel

Select layer Study Area – zoom to layer

[image: ]

Save QGIS project

Convert raster layer Cloud Mask to vector layer
Select menu option Raster > Conversion > Polygonize
In Input Layer box, select the raster with file name ending in …Enmask.tif
In Vectorized box, select Save to file
browse to folder 14-Jun-2018
change file type to SHP
in file name box
Type VectorClouds 
Save
Click on Run in background button

– this took about 10 minutes for entire image – clip image ??

[image: ]

Use vector layer to clip and save as TIF
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1. Introduction to Remote Sensing, Fifth Edition, Campbell and Wynne, The Guilford Press, 2011

2. GIS Ag Maps, http://www.gisagmaps.com/
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Appendix B: NDVI ColorRamps

Text for NDVIColorRamps

# QGIS Generated Color Map Export File – Landsat Level-1
INTERPOLATION:DISCRETE
0.07,0,76,255,255,Water
0.16,191,163,124,255,Bare Surface / Clouds
0.25,177,223,171,255,Scattered Vegetation
0.4,61,166,89,255,Moderate Vegetation
0.99,0,87,27,255,Dense Vegetation

# QGIS Generated Color Map Export File – Landsat Level-2
INTERPOLATION:DISCRETE
0.0,0,76,255,255,Water
0.2,191,163,124,255,Bare Surface / Clouds
0.7,177,223,171,255,Scattered Vegetation
0.8,61,166,89,255,Moderate Vegetation
0.99,0,87,27,255,Dense Vegetation

How color ramps work in QGIS

[image: ]

When the value falls between two numbers, the color of the higher number in the range will be rendered.

To learn how these values were selected, read the section entitled “Developing a Color Ramp” in Chapter 11, Ground Truth Sampling.
[bookmark: _Toc9345699]
Appendix C: Landsat Image Specifications

Write some Text here

	Date
	Path
	Row
	Level
	Image ID

	19 Apr 18
	47
	26
	1
	LC08_L1TP_047026_20180419_20180502_01_T1

	Crop condition: untilled and unplanted

Analysis: 








	Date
	Path
	Row
	Level
	Image ID

	
	47
	26
	1
	

	Crop condition: 
Analysis: 
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