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Part 1:
General Principles of Remote Sensing
Chapter 1:
About Remote Sensing 
This chapter includes:

· Description of the study of remote sensing
Definition: Remote sensing is the science of deriving information about an object from measurements made at a distance from that object. 
Examples of methods of acquiring remote-sensed data include: aerial photography, satellite-captured images, RADAR, LIDAR, etc. 
Uses of remote sensing include: agriculture crop monitoring, forestry management, weather forecasting, military intelligence, urban planning, mapping, and many other fields.
Equipment used for remote sensing includes: satellites, airplanes, drones, cameras, GPS, computers, and a variety of other devices.

Software used in remote sensing includes: GIS software, Google Earth, internet websites, computer data archives of images, etc.

It is important to understand that many components of the remote sensing process act as parts of a system and cannot be isolated from one another.

For a more complete understanding of remote sensing, a search of the Internet will uncover many sources of current information.  An instructional course, either online or at a local university, will develop understanding and provide hands-on opportunities to work with remote-sensed data.

It is not the intent of this text to develop a thorough understanding of remote sensing. Instead, the purpose of this text is to give the student step-by-step instructions for using GIS software to acquire and manipulate remote-sensed data. By completing the case study in this text, the student will develop a basic understanding of some of the processes involved in analyzing remote-sensed data and learn to draw conclusions from that analysis. Hopefully, this text will motivate students toward more in-depth study of this interesting and expanding field. 
It also is not the intent of this text to be a tutorial on the use of GIS software or, specifically, QGIS, the most popular open source GIS software in use at the time of writing. Although this text will guide the student through the steps of using QGIS to process remote-sensed images, explanations regarding the functions of GIS are brief. Again, an online class or university course is needed to gain a full understanding of GIS software.
Chapter 2:
Defining the Project 
This chapter includes:

· Description of the study project and its goals
A few years ago, in Redmond, Washington, I watched a forest patch be clear-cut for a future housing development. This change presented an opportunity to examine satellite images acquired by Landsat satellites to determine how the vegetation coverage change was “observed” using satellite data.
The following is an aerial view of our study area in Redmond, taken from a drone in March 2015, showing the current state of conversion of a forested area into a housing development.
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View from drone over study area, looking south – March 2015

Properly studying the changes over time requires multiple steps of analysis:

First, the location of the clear-cut forest needs to be identified by parameters consistent with Landsat image georeferencing. Latitude and longitude coordinates will be noted by GPS. 
The next step will be to get a view of the area with Google Earth using latitude and longitude. Identifying a Google Earth image date “before” forest clearing helps us choose a date range for finding a suitable Landsat image. It will be necessary to take into consideration the years during which the Landsat 7 satellite was operating with a degraded scanner.
Then, we will analyze Landsat images using NDVI analysis method of “before” and “after” images. Comparing visible imagery from Google Earth and NDVI raster images will help us visualize pattern correlation between different types of remotely-sensed images.
After performing the NDVI analysis, we can use “raster math” to calculate the differences in the values of each pixel in the “before” and “after” NDVI raster images.

Next, the image of NDVI difference image will be compared to the University of Maryland’s Global Forest Coverage Gain / Loss analysis. Since the time span of this UMGFC project was 2000 to 2016, our selection of dates for Landsat images to analyze was influenced by the need to coincide with UMGFCC data.
Finally, we will draw some conclusions from our many observations.

Part 2:
Creating Maps
Using GIS
Chapter 3:
Installing QGIS and 7-Zip
This chapter includes:

· Instructions to download and install QGIS 
· Instructions to download and install 7-Zip for uncompressing files
Step 1: QGIS Installation for Windows PC
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:
http://www.qgis.org/en/site/forusers/download.html
Choose Standalone Installer Version 3.8.
To see whether your computer has a 32 or 64 bit processor go to Control Panel > System and view the “System type” in the System section. 
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If you are unsure as to whether to install a 32 or 64-bit version of QGIS, select the 32 bit version.
Open the QGIS installer and follow the instructions.
NOTE: At the time this curriculum was prepared, the current version of QGIS was 3.8, dated June 2019.
Configure the coordinate projection options:
Start QGIS
On the QGIS menu bar

Select Settings > Options
Select General tab

Select Style that corresponds to your computer operating system

Change Icon Size to 32
Change Font to Arial (or your choice)

Change Size to 12 (or your choice)
OK
On the QGIS menu bar

Select View > Toolbars > Manage Layers Toolbar

To correctly display foreign language characters

On the QGIS menu bar

Select Settings >Options >Data Sources
In the Data source handling section

Uncheck the box next to Ignore shapefile encoding declaration
OK

On the QGIS menu bar 
Select Project > Exit QGIS
Step 2: QGIS Installation for Mac
Time to complete: 10-20 minutes (depends on your download speed)

Download QGIS from this website:

http://www.qgis.org/en/site/forusers/download.html
Choose QGIS macOS Installer Version 3.8.

Perform same instructions as in Step 1

In addition, this change is needed to solve a bug related to clipping raster files

On the menu bar select QGIS 3 > Preferences > System 

Open Environment section

Click on the plus sign

In Apply column, select Append
In Variable column type PATH
In Value column copy / paste the following text

:/Library/Frameworks/GDAL.framework/Programs: /Library/Frameworks/PROJ.framework/Programs: /Library/Frameworks/SQLite3.framework/Programs:/Library/Frameworks/UnixImageIO.framework/Programs

When you are finished, your screen should look like this:
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OK
On the menu bar select QGIS 3 > Quit QGIS 3
Step 3: Software Installation - 7-Zip XE "7-Zip"  

Download and install 7-Zip from this website:

https://www.7-zip.org
Open the 7-Zip installer and follow the instructions.


Any similar program, such as WinRAR, can be used as well.
Step 4. Learn about QGIS software

You may want to search the Internet for resources to learn about QGIS.

Chapter 4:
Locating GIS Maps 
	Chapter Objectives  
· Learn where to find appropriate GIS map data 




One useful source of digital maps for GIS systems is the website for GADM (Database of Global Administrative Areas), which can be accessed at http://www.gadm.org/  
  GADM XE "GADM"  is a spatial database of the location of the world's administrative areas (or administrative boundaries) for use in GIS software.  The coordinate reference system is “latitude/longitude” and uses the datum WGS84. These maps can contain up to 5 levels of administrative subdivisions. A general understanding of the concept of “administrative areas” is presented on Wikipedia at http://en.wikipedia.org/wiki/Administrative_division
Other useful sites containing data for roads, rivers, population data, etc.:

http://www.diva-gis.org/gdata 
https://nationalmap.gov/small_scale/

Chapter 5:
Choosing a Study Region
and Creating a Reference Map
This chapter includes:

· Purpose and definition of a study region
· Purpose and definition of the reference map XE "reference map" 
· Tips on creating a reference map

· Sources and examples of reference maps

Purpose
We need to define a primary study region for our project. For our study region, we will use an area bounded by administrative boundaries. One possibility is to use the boundaries of a county in the US (the same as a province or district in many other countries). We will use this method in the exercise in this chapter.

A second option is to define an area by explicitly specifying its boundaries ourselves. We might define a rectangle by specifying the coordinates of its four corners, or draw a rectangle of the study region in a map layer of our project. We will learn how to do this later in chapters 6, 18 and 19.
The purpose of creating a reference map is to provide a starting point for displaying data related to the main topic of our study project. 
Tips on creating a reference map
Use care in selecting how many detailed features to include on the reference map. Features that should be included are those that will assist the user in interpreting the main topic of the map – the theme of the map. Features that do not add to the user’s understanding should be omitted. The simpler the map, the better; maps cluttered with too much detail can detract from the message you want to communicate. 
Exercise
The GADM website is an excellent starting point that provides digital reference maps of regional boundaries (also called administrative areas). We will download a map from this website to begin the work of defining our study region.

Step 1: Define our study region XE "study region" 
For our study region, we will use King County in western Washington. Since we will be using Landsat images, which use Universal Transverse Mercator (UTM) coordinates, we need to know the UTM zone of the study region. There are several conversion programs on the internet (Google “lat to UTM”) that will make the conversion for you. In the case of our study region, we determine that this area is located in UTM zone 10 N. 
Step 2: Locate and download map files that include our study region
Create a folder on the C: drive for your work - name the folder GIS Remote Sensing. 

In the GIS Remote Sensing folder, create a sub-folder named Redmond.
Download the administrative maps from the GADM website 
Follow the link at http://www.gadm.org/ 

Select Data button
Click on the word country
Select United States from the dropdown menu
Select Shapefile

The file will now download.
NOTE: At the time this curriculum was prepared, the GADM website maps are version 3.6, dated May 2018. 

We now have map files for the country, states, and counties saved in the Downloads folder. 
Step 3: Start QGIS 
Start QGIS

On the QGIS menu bar 
Select Project > New

Step 4: Create a map layer of your study region
In QGIS, add a vector layer for all the counties in the US.
On the QGIS menu bar 
Select Layer > Add Layer > Add Vector Layer
For Vector Dataset 
Select folder gadm36_USA_shp in the folder Downloads
Open
Add
Select the file named gadm36_USA_2.shp
OK

Close

The county in our study region is named King. However, there are two counties in the US named King, so we will have to select the one in Washington. The following steps will select King County in Washington from all the counties in the United States. 
Right click the layer gadm36_USA_2 > Properties
Select Source tab 
Select Query Builder button in the Provider feature filter section
Double click NAME_2 in the Fields box to insert in the Provider specific filter expression box

Single click Operator “=” to insert in the Provider specific filter expression box

Choose “All” in the Values box

In the Values box, double click King (halfway down the list) to insert in the Provider specific filter expression box

Single click Operator “AND”

Double click NAME_1 in the Fields box to insert in the Provider specific filter expression box

Single click Operator “=” to insert in the Provider specific filter expression box

Choose “All” in the Values box

In the Values box, double click Washington (near the end of the list) to insert in the Provider specific filter expression box

OK > Apply > OK
Right click the layer gadm36_USA_2 > Zoom to layer
Next we will eliminate all the counties that we will not be using. The following steps will clip XE "clip:vector"  the layer to remove all data except data for the county of our study region. This will make the QGIS project file load and redraw much, much faster. 
On the QGIS menu bar 
Select Vector > Geoprocessing Tools > Clip
Choose Input vector layer ending in USA_2
Choose Overlay layer ending in USA_2
In the Clipped box, click the browse icon at the right end of line

Select Save to file 
Browse to the folder named Redmond
In File Name box type StudyRegion 
In Save as type box, select SHP files
Save 
Click on Run button
Close
Right click the layer named Clipped > Rename layer
Type StudyRegion over the name Clipped > Enter
Right click the layer ending in USA_2 > Remove layer > OK
Step 5: Change the coordinates for the project to UTM
The administrative area map file we downloaded uses the “latitude/longitude” Coordinate Reference System (CRS). In cases where all the map files use the same coordinate system, no change is necessary. However, we will need to be ready to work with Landsat image files, which use UTM coordinates. Therefore, we need to change the CRS of our project from latitude/longitude to the UTM geographic coordinate system. 
On the QGIS menu bar 

Select Project > Properties

Select CRS menu item
In the Filter box type 10N

In the Coordinate reference systems of the world box
Select WGS 84 / UTM Zone 10N
Apply > OK
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Step 6: Adjust layer properties

Change the study region to be transparent so that the layer only shows the borders as an outline.

Right click the StudyRegion layer > Properties
Select Symbology tab 
Click on Simple fill
For Fill style select No Brush 
For Stroke color select black 
For Stroke width type 0.5

For Stroke style select Dash Line
OK 
You could use these instructions to define a different study area in the United States by changing the names of the counties in the Query Builder step. To work in regions outside the US, download the appropriate country map from the GADM website as instructed in Step 2 of this chapter.
Our QGIS project file is now optimized to contain only data for our study region of King County.
Example: the reference map of our study region should now look like this:
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Step 7: Save the project and exit
On the QGIS menu bar 
Select Project > Save 
On the QGIS menu bar 
Select Project > Exit QGIS
Chapter 6:
Adding a Study Area
to the Reference Map
This chapter includes:

· Purpose and definition of a study area

· Adding the study area to the reference map

Purpose
We need to define a primary study area for our project. The study area should be within our study region, which we defined when creating our reference map.
A study region is a broad area that contains our study area. The study region gives us some general orientation to the geography around our study area. Our study area focuses narrowly on specific features we are investigating. The surrounding characteristics of the study region may provide some helpful clues for our analysis.

We will define our study area by specifying its boundaries ourselves. We can define a rectangle by specifying the coordinates of its four corners, or we can draw a rectangle of our study area in a map layer of the project. 
As we discussed in Chapter 2, the purpose of our study is to analyze remote-sensed satellite images to observe changes in vegetation coverage of an area in Redmond, Washington, USA. For our study area, we have chosen an area where the trees have recently been cut down and houses are now being built. Some nearby neighborhoods were developed for housing several years before.  

Step 1: Start QGIS
Start QGIS

On the QGIS menu bar 
Select Project > Open 
Browse to folder Redmond
Select File Name = ReferenceMap > Open

(You can also access ReferenceMap from Project > Open Recent)
Step 2: Define the study area
We can define our study area using either of the following two methods. The first method uses only QGIS and coordinate points. The second method uses Google Earth as a visual guide.
Method 1 – create study area using QGIS

Define the four corners of our study area by UTM coordinates (UTM will be necessary when we start working with Landsat images). For this study, the boundaries are provided for you using coordinates determined by GPS. For your own projects, you will need to set your own boundaries for your study area.
We will create a vector layer in QGIS using the corners of our study area in UTM coordinates which are:

Easting, Northing

565125, 5284566
565125, 5283773
566225, 5283773
566225, 5284566
Copy and paste the five lines above into a text (.txt) file using Notepad and name the file CornerPoints and save the file in the folder Redmond.
On the QGIS menu bar 
Select Layer > Add Layer > Add Delimited Text Layer
In the File Name box, click the browse icon at the right end of line

Browse for the file CornerPoints in the folder Redmond
Open
In the File format section
Select CSV
Open Record and fields option
Select 0 in Number of header lines to discard

Check box next to First record has field names

Open the Geometry definition section

Select Point coordinates
In Geometry CRS
Select WGS 84 / UTM zone 10N
Add > Close
Now, follow the instructions in Chapter 18 to create a study area layer by connecting the corner points of the study area layer.
Right click on the layer CornerPoints

Select Remove Layer > OK

The outline of the study area should look like the one below.
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Method 2 – create study area using Google Earth
The center point of the area we want to study is: 10N 565675 5284170  
Copy and paste these coordinates into the search line of Google Earth.
Follow the instructions in Chapter 19 and create a vector layer in Google Earth. 
The outline of the study area in Google Earth should look like the following figure: 
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Study area outlined in red, coordinates of center point displayed
Step 3: Save the project and exit
On the QGIS menu bar 
Select Project > Save 

On the QGIS menu bar 
Select Project > Exit QGIS
Part 3:
Adding Remote Sensed Data in GIS
Chapter 7:
Locating Remote Sensed Data
This chapter includes:

· Identifying sources of remote sensed images

· Understanding the data available in the Landsat archive

Identifying sources of remote sensed images
The Landsat archive is one of the largest and most accessible sources of remote sensed images. For our exercises, we will use Landsat images. However, after you become familiar with the process of using remote sensed images in GIS, you should research and bookmark other sources of images to provide a strong variety of tools for your future remote sensing and GIS needs.
The Landsat XE "Landsat"  satellite imaging program was designed by scientists and sponsored by the US government to make large-scale, continuous surveys of the Earth's land areas. Today, the Landsat image library contains the longest continuous record of environmental conditions of land areas covering our world.

To date, eight Landsat satellites have been launched, beginning with Landsat 1 in 1972, up to Landsat 8 in 2013. Currently, both Landsat 7 and 8 are operational. Each satellite makes a complete orbit every 99 minutes, completes about 14 full orbits each day, and crosses every point on Earth once every 16 days. The satellites’ orbits are offset to allow 8-day repeat coverage of any Landsat scene area on the globe. Between the two satellites, more than 1,000 scenes are added to the USGS archive each day.
Although sensing equipment has been continuously improved, great effort has gone into keeping the format, resolution, and spectral sampling parameters consistent. This consistency allows for comparison of land area characteristics to analyze changes during the 40+ years of Landsat data collection.

For our purposes, one of the most attractive features of Landsat images is that the US government has made all 40+ years of data available on the internet for downloading at no cost to the public. We will make use of the Landsat image data in this textbook as one of our primary sources in learning about remote sensing.

This textbook is meant to give you only a very brief introduction to Landsat imagery; a complete discussion of the history and specifications of Landsat are beyond the scope of this textbook. For more information on Landsat, visit the USGS website at www.usgs.gov.  Another excellent source of Landsat information can be found in Chapter 6 of Introduction to Remote Sensing, Fifth Edition, by James B. Campbell and Randolph H. Wynne. Wikipedia also contains useful information about Landsat at https://en.wikipedia.org/wiki/Landsat_program.
EarthExplorer XE "EarthExplorer"  XE "USGS website:EarthExplorer" 
The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. 
In order to download files using EarthExplorer, you must first create a login. 
If you have not already set up an account, do so now.

Go to http://earthexplorer.usgs.gov
On the bar near the top of the page, select Register and complete the form. You may need to ask an instructor to provide some answers. When you are done, a registration confirmation will be sent to your email address. Follow the link to activate your account.
Be sure to record your username and password for future use.
Return to EarthExplorer’s main page. If you are not already logged in, on the bar near the top of the page, select Login > Sign in with your username and password.
In the Address/Place box > type Redmond, WA > Show
Select Redmond, WA, USA
In the Coordinates box, select the Decimal tab.
Record the latitude and longitude, which will be used in the next step. Note that the longitude has a negative sign.

On the EarthExplorer menu bar, select Logout.
GLOVIS XE "GLOVIS"  (USGS Global Visualization Viewer)
GLOVIS is another format for viewing Landsat images. 
Go to http://glovis.usgs.gov
Click on the Launch GLOVIS button.
In the upper right corner of the screen, click on the [image: image11.png]


button and select Lat/Lng.
Type the latitude and longitude from the previous step.
Click on the Jump to Location button

You can explore the many features of GLOVIS later.
LandsatLook XE "LandsatLook"  XE "USGS website:LandsatLook"  
Another place to search for remote sensed image data is on the easy-to-use USGS website http://landsatlook.usgs.gov This site allows you to search for a location and then zoom in to see the full resolution data of all Landsat scenes available. When you select an image to download, the request will be processed by EarthExplorer.

You can explore the many features of LandsatLook later.
Chapter 8:
Acquiring Remote Sensed Data
This chapter includes:

· Researching available data for your study area 
· Downloading Landsat data

· Some useful facts about Landsat data

The EarthExplorer website, operated by the US Geodetic Survey, is one of the most useful and complete sources of remote sensing data. You will use it to download Landsat images covering your study area. A good description of the Landsat program can be found at http://en.wikipedia.org/wiki/Landsat_program
Two versions of Landsat images are available. Level 1 images are not corrected for atmospheric conditions, Level 2 images have atmospheric corrections applied to produce surface reflectance measurements. Level 2 images must be ordered for later deliver; Level 1 images are available for immediate download. We will use Level 1 images for our project.
Step 1: Create a folder for saving Landsat images

In the Redmond folder, create a sub-folder named Landsat.
Step 2: Log into the USGS website

Go to http://earthexplorer.usgs.gov/
On the EarthExplorer menu bar, select Login > Sign in with your username and password. If you have not already set up an account, follow the instructions in the previous chapter.   
Step 3: Define the parameters for request for Landsat images
Note: Because the Landsat 7 satellite developed a problem with its scanner in 2003 that caused each image to have strips of missing data, we will use images from before the scanner problem developed.  Normally, we would have used more recent images, but for our example, we are choosing images that are not missing data.

In the box Address/Place > type Redmond, WA > Show

Select Redmond, WA, USA from the list displayed in the Address/Place box.
Select a Date Range 
For this exercise, choose the date range of 05/01/2002 to 6/30/2002.
When choosing date ranges for images, think carefully about the vegetation condition of crops at various times of the year - planting, growing, harvest, fallow. 
Select the Data Sets button 
Click the + box next to Landsat 
Click the + box next to Landsat Collection 1 Level 1

Click the box next to Landsat 7 ETM+ C1 Level-1
Click on the Additional Criteria button

Under Scene Cloud Cover, select Less than 20%
Click on the Results button. 
If done correctly, there should be one result, dated June 11, 2002 (11-JUN-2002). 
Select Download Options icon [image: image12.png]


 for the correct data set.
Select the Level-1 GeoTIFF Data Product option (TIFF format containing all bands of sensors)

Select the Download button 
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Browse to locate the downloaded file. It is probably in the folder Downloads.
Copy the file and paste it into the folder Landsat. Leave the name of the Landsat file unchanged.
After the Landsat file download completes, on the EarthExplorer menu bar, 
Select Logout 
Step 4: Uncompress the Landsat file

Uncompress the downloaded Landsat file using 7-Zip, or whatever other program you use to uncompress files.
Start 7-Zip program

Browse to the folder Landsat
Select the Landsat gz file
Select Extract icon > OK
Double click on the tar folder

Select the tar file 

Select the Extract icon > OK 
Close the 7-Zip program
Step 5: Cleanup files

When you are finished, you can delete the .gz and .tar files to save disc space
Part 4:
Analyzing
Remote Sensed
Data
Chapter 9:
Image Interpretation

This chapter includes:

· Interpreting single images
· Interpreting analyzed images
Interpreting single images

 XE "Interpretation" Photos and satellite images are useful primarily because we can use them to identify the positions and properties of features that interest us. Interpreters use size, shape, color, brightness, texture, and location to identify features and derive information from images. Image interpreters must have some familiarity with the features of interest. This process, known as ground truthing, is essential to developing the local knowledge required for accurate image interpretation. 
The practice of image interpretation is a well-developed discipline and uses many specialized techniques. A detailed description of image interpretation is beyond the scope of this handbook. Books and internet resources are available that explain this skill in detail. 
Satellite images are like maps: they are full of useful and interesting information, provided you can interpret them. It is important to remember that satellite images are an overhead view—an uncommon perspective. The following is a review a few of the highlights of image interpretation focusing on satellite images. 
Look for a scale: One of the first things people want to do when they look at a satellite image is to identify the places that are familiar to them: their home, school, or place of business; a favorite park or tourist attraction; or a natural feature like a lake, river, or mountain ridge. The level of detail depends on the image’s spatial resolution. Like digital photographs, satellite images are made up of little dots called pixels. The width of each pixel is the satellite’s spatial resolution. For the Landsat images we will be using, the resolution for one pixel is 30 meters on each side (900 sq meters).

Look for patterns, shapes, and textures: Bodies of water—rivers, lakes, and oceans—are often the simplest features to identify, because they tend to have unique shapes and are large enough to show up on maps. Other obvious patterns come from the way people use the land. Farms usually have geometric shapes—usually circles or rectangles—that stand out against the more random patterns seen in nature. When people cut down a forest, the clearing is often square or has a series of herring-bone lines that form along roads. A straight line is almost certainly human-made, and may be a road, a canal, or some type of boundary made visible by land use.

Define colors: The colors in an image will depend on what kind of light the satellite instrument measured. True-color images use visible light—red, green, and blue wavelengths—so the colors are similar to what a person would see from space. False-color images incorporate infrared light and may take on unexpected colors.

Water absorbs light, so it is usually black or dark blue. 
Plants come in different shades of green. Grasslands tend to be pale green, while forests are very dark green. Land used for agriculture is often much brighter in tone than natural vegetation. In some locations (high and mid latitudes), plant color depends on the season. Spring vegetation tends to be paler than dense summer vegetation. Fall vegetation can be red, orange, yellow, and tan; leafless and withered winter vegetation is brown. For these reasons, it is helpful to know when the image was collected.

Find North: If you know which direction north is, you can figure out if a mountain range is running north to south or east to west, or if a city is on the east side of the river or the west. These details can help match features to a map.
Consider your prior knowledge: Perhaps the most powerful tool for interpreting an image is knowledge. If you know that a wildfire burned through a forest last year, it’s easy to figure out that a dark brown patch of forest is probably a burn scar, not a volcanic flow or shadow.

Interpreting analyzed images

Because most of us are not trained or experienced interpreters of remote sensed images, we will use some automated image analysis techniques to help us understand the image data we are seeing. One specialized analysis technique we will learn in the next chapter is Normalized Difference Vegetation Index (NDVI). Instead of attempting to interpret individual images, we will use QGIS software to analyze two images and produce a visualization that is customized for the interpretation of vegetation health. 
Using established processes such as NDVI transfers our interpretation requirements from examining raw remote sensed image data to understanding and interpreting automated analysis methods and outputs. More on this topic in the next chapter.
Chapter 10:
Normalized Difference
Vegetation Index (NDVI)
This chapter includes:

· Definition of NDVI

· Instructions for completing NDVI analysis

· Examples of NDVI outputs

The Normalized Difference Vegetation Index (NDVI XE "NDVI" ) has been used for many years to measure and monitor plant growth (vigor), vegetation cover, and biomass production from multispectral satellite data. We will create NDVI image maps using 30 meter-resolution Landsat spectral data in the visible red and near-infrared regions of the electromagnetic spectrum. 
NOTE: – For images from Landsat satellites 1-7, band 3 is used for red and band 4 for near-infrared. For Landsat 8, XE "Landsat 8"  the band designations are different; red is now band 4 and near-infrared is now band 5.
For Landsat satellites 1-7, NDVI is calculated as follows: 
NDVI = (Band 4 – Band 3) / (Band 4 + Band 3)
Band 3 is in the visible red-light region of the electromagnetic spectrum where chlorophyll causes considerable absorption of incoming sunlight. Band 4 is in the near-infrared region of the spectrum where a plant's spongy mesophyll leaf structure creates considerable reflectance.  As a result, vigorously growing healthy vegetation has low red-light reflectance and high near-infrared reflectance, and hence, high NDVI values. 
For Landsat 8, use Bands 4 and 5 instead of 3 and 4.

This relatively simply algorithm produces NDVI values in the range of -1.0 to 1.0. 
· Negative values of NDVI (values approaching -1.0) correspond to deep water.

· Values near zero (-0.1 to 0.1) generally indicate non-vegetated features such as barren surfaces (i.e. rock and soil), water, snow, ice, and clouds. 
· Low, positive values (approximately 0.2 to 0.4) represent shrub and grassland. 
· High values (approaching 1.0) indicate temperate and tropical rainforests. 
· Typically, values range between about -0.1 (for a not very green area) to 0.6 (for a very green area)
Step 1: Define our study area
In Chapter 6 we defined our study area and created a shapefile named StudyArea that we will use in this exercise. If you have not already created the study area map, follow the instructions in Chapter 6 now.
Step 2: Start QGIS and load the study area reference map layer
For this exercise we will use QGIS. If you have not already downloaded and installed QGIS, refer to Chapter 3 for instructions about how to download and install this software. 
Start QGIS

On the QGIS menu bar 
Select Project > Open Recent
In the Source section browse to folder Redmond
Select File Name = ReferenceMap
Open

Step 3: Load the Landsat images into QGIS 
Next, we will load into QGIS the Landsat images downloaded in Chapter 8. Only images from spectral bands measuring red and near-infrared (NIR XE "NIR" ) will be used to calculate NDVI. 
The following instructions assume you are using images from Landsat 1-7. If you are using images from Landsat 8, change the band numbers from 3 and 4 to 4 and 5.
On the QGIS side bar
Select the Add Raster Layer icon [image: image13.png]



Browse to the folder Landsat
Select the folder with name beginning with LE07

Open
Select the file ending in B3 (band 3)
Hold down the shift key and select the file ending in B4 (band 4)
Open > Add 
Close

On the QGIS menu bar 
Select Project > Save As
Browse to the folder Redmond 
Name your project Redmond-NDVI
Save
Step 4: Clip the raster image to study area size
Clip XE "clip:raster"  XE "clip"  the Landsat images to the size of the study area.
On the QGIS menu bar 
Select Raster > Extraction > Clip raster by mask layer
In the Input layer box, select the file ending in B3 (band 3)

In the Mask layer box, select StudyArea
Check box Match the extent of the target dataset to the extent of the cutline

In the Clipped (mask) box
Select Save to File
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Browse to the folder Landsat
Type b3-2002 in File Name
 box
Save

Click on Run button

Close
In the Layers panel

Right click on layer Clipped (mask)

Select Rename Layer
Type b3-2002 as the layer name
Repeat the above clipping instructions for the file ending in B4 (band 4)

Right click the first Landsat image layer with the name ending in B3
“LE07_L1TP_046027_20020611_20160929_01_T1_B3”

Remove > OK
Right click the second Landsat image layer with the name ending in B4
“LE07_L1TP_046027_20020611_20160929_01_T1_B4”

Remove > OK
Right click on the layer StudyArea
Select Zoom to Layer 
On the QGIS menu bar 
Select Project > Save 
Your Landsat data displayed on your computer screen should display one of these two images: 
Raster images for bands 3 and 4 for June 11, 2002

[image: image14.png]



Step 5: Create a new raster image showing NDVI
Each Landsat image is a single band grayscale raster with integer pixel values (1-255). Since NDVI is “normalized,” the values are always fractions. Therefore, it is necessary to first multiply the raster b4 by 1.0 to convert it to a real value. Otherwise the result will be an integer, leaving the whole computed NDVI raster with values rounded to 0. 
On the QGIS menu bar 
Select Raster > Raster calculator XE "calculator" 
Click on the box to the right of Output layer box

Browse to the folder Redmond
In File Name box, type NDVI-11-Jun-2002
Save
Type the following expression in the Raster calculator expression box

( "b4-2002@1" * 1.0 - "b3-2002@1" ) / ( "b4-2002@1" + "b3-2002@1" ) 

(optional: try manually entering this formula by clicking on each item and operator on the screen)

OK
Right click b3-2002 layer > Remove Layer > OK
Right click b4-2002 layer > Remove Layer > OK
Step 6: Create an NDVI color ramp
This one-time action is needed to create a custom NDVI color ramp XE "color ramp"  in QGIS. The text required is contained in Appendix B of this document. This step creates a custom color ramp file that you will use in the following steps.
Start Word (or compatible program such as Notepad)

Open this document in Word and browse to Appendix B
Copy the text under Text for NVDIColorRamp
File > New to create a blank document

Paste the copied text into the blank document

File > Save As 
Browse to the folder Landsat
Name the file NDVIColorRamp
Select Save as type Plain Text 
Save > OK
File > Close
Note: for a discussion of the methodology of creating a custom color ramp, see Volume 3, Chapter 11.

Step 7: Adjust the colors of the NDVI raster map
Positive NDVI values, shown in increasing shades of green in an NDVI image, indicate increasing amounts of healthy vegetation. NDVI values near zero and negative values indicate non-vegetated features such as barren surfaces (i.e. rock and soil), water, snow, ice, and clouds. 
In QGIS, uncheck all the layers except the layer named NDVI-11-Jun-2002
Right click layer NDVI-11-Jun-2002
Select Properties > Symbology 
In Render type 
Select Singleband psuedocolor 
Click on the file folder icon [image: image15.png]



Browse to the folder Landsat
Select NDVIColorRamp
Open

In Interpolation box

Select Discrete
OK
Your image should look something like this:
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NDVI analysis for June 11, 2002

Step 8: Update metadata for the NDVI layer
Right click layer NDVI-11-Jun-2002 

Select Properties > Metadata 

In the Title box of the Identification tab, copy and paste the following text

NDVI June 11, 2002

In the Abstract box, copy and paste the following text

Data source: USGS, Landsat 7, Path 46 / Row 27

Acquisition Date: 11-JUN-02
Landsat Scene ID: LE70460272002162EDC00
In the Rights box of the Access tab, click the addition icon [image: image17.png]



Copy and paste the following text:
Landsat images courtesy of the U.S. Geological Survey

OK
Step 9: Save your project
On the QGIS menu bar 
Select Project > Save 
Step 10: Interpretation

Recall from the definition of NDVI that the more intense green is, the more complete coverage of healthy vegetation. Conversely, using our custom color ramp, grey indicates buildings and brown indicates non-vegetative surfaces. 

Technically speaking, when we referred to “forest coverage” in earlier chapters, we should have used the term “vegetation coverage” since NDVI is an analysis of all vegetation—not just forests. A football field would show up as green because it is healthy vegetation even though it is definitely not a forest. 
Look at the area in the lower left corner of your study area in the NDVI image. Then locate this same area in your Google Earth view.  In Google Earth we see that this is an area where homes have been built. In Google Earth, click on View and then Historical Imagery.  Use the time slider in the upper left of the screen to see what this area looked like in the past.  We can see that most houses were built after 2004 which is later than the date of our NDVI image (2002). Hence, we can conclude that in our NDVI image, we are seeing mostly bare land in this area of the image. However, a few homes had been built at the time of our NDVI image. 

[image: image18.jpg]



Google Earth view of study area on May 31, 2002
In QGIS 
Uncheck all layers except NDVI-11-Jun-2002 

Select the NDVI-11-Jun-2002 layer
Click on the Identify Features [image: image19.png]


 icon
Click anywhere inside the raster

In the lower left corner of the Feature panel

In the View box, choose Table
Move the cursor over a green raster cell and click on it.
You should read values in the range of 0.4 to 0.5. 

In the lower left corner of the study area, move the cursor over the gray raster cells, which should have values in the range of -0.45 to -0.15. These are probably roofs of houses, concrete driveways, or a combination of both.  In contrast, the brown cells in that area, which are bare ground, have values in the range of -0.15 to +0.15. Areas with vegetation range from +0.15 to +0.5. We will try to use these approximate value ranges in the next chapter when we interpret cell values in the Landsat 8 images captured in 2016.
When finished, click the X in the upper right corner of the Identify Results panel.
Chapter 11:
Create NDVI from a
Raster Image
Acquired by Landsat 8
This chapter includes:

· Download of Landsat 8 image

· Create NDVI using Landsat 8 image

· Interpret the results of the NDVI analysis

Now, let’s jump ahead to 2016 after the forest has been cleared and house construction has begun. We’ll try to look for Landsat 8 images to analyze from the month of June so that seasonal variations in vegetation will be minimal – June was the month that the images from the previous chapter that were analyzed in 2002. For our project, however, none of the data from June 2016 matches the conditions from June 2002. If we search for Landsat 8 images without cloud cover over our study area, we find the closest date of a useful image is 27 July 2016.
Step 1: Download a raster image from Landsat 8 acquired on July 27, 2016
Repeat Steps 2-5 of Chapter 8 to download Landsat 8 image acquired on July 27, 2016.
Change your selection from Landsat 7 ETM+ C1 to Landsat 8 OLI/TIRS C1-Level-1, and choose the date range 7/01/2016 to 7/31/2016. Choose the Landsat image dated 27-JUL-2016.
Step 2: Create a second raster image showing NDVI for Landsat 8 remote-sensed image dated July 27, 2016
Repeat Steps 3, 4, 5 and 7 of Chapter 10 using the Landsat 8 image dated July 27, 2016 that you downloaded following the instructions in Chapter 8. The file names of bands 4 and 5 that you select begin with “LC08” indicating that they are products of Landsat 8.
Recall that the bands’ identifiers have been changed for Landsat 8. See the Note at the beginning of Chapter 10.

This means the final expression to enter in the Raster calculator expression box is:
( "b5-2016@1" * 1.0 - "b4-2016@1" ) / ( "b5-2016@1" + "b4-2016@1" )
When clipping the raster files, you cannot re-use file names.  For the file ending in B4, use the name b4-2016, and for the file ending in B5, use the name b5-2016.
Name this NDVI layer NDVI-27-Jul-2016.
Step 3: Example

After performing the NDVI analysis, your image should look similar to this:
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NDVI analysis for July 27, 2016
Step 4: Update metadata for the NDVI layer
Select layer NDVI-27-Jul-2016 > Properties > Metadata 

In the Title box of the Identification tab, copy and paste the following text:
NDVI July 27, 2016
In the Abstract box, copy and paste the following text:
ID:LC08_L1TP_046027_20160727_20170222_01_T1

Acquisition Date:27-JUL-16

Path:46

Row:27
In the Rights box of the Access tab, click the addition icon [image: image21.png]



Copy and paste the following text:

Landsat images courtesy of the U.S. Geological Survey

OK
Step 5: Interpretation  
Look at the area in the lower left corner of your study area in the NDVI image. Then locate this same area in your Google Earth view of July 2016.  In Google Earth we see that this is an area where homes have been built, and the vegetation is now well established – lawns and trees have been planted. Now look at the area in the lower middle of the study area. This area is where homes have been built most recently. This area differs from the lower left in that vegetation is not yet well established. This difference can also be seen in Google Earth.
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Google Earth view of study area on July 27, 2016
In QGIS 
Uncheck all layers except NDVI-27-Jun-2016
Select the NDVI-27-Jun-2016 layer
Click on the “Identify Features” [image: image23.png]


 icon
Click anywhere inside the raster

In the lower left corner of the Feature panel

In the View box, choose Table
Move the cursor over a green raster cell and click on it. 
You should read values in the range of 0.4 to 0.5. 

In the lower middle of the study area, move the cursor over the brown raster cells, which should have values in the range of -0.15 to +0.15. These are probably house roofs. Areas with vegetation range from +0.15 to +0.5.
When finished, click the X in the upper right corner of the Identify Results panel.
Chapter 12:
Analyze Images for
Vegetation Changes
This chapter includes:

· Create a new raster that calculates the changes between the two NDVI analyses

· Interpret the results of the change analysis

We can analyze the change of vegetation coverage between June of 2002 and July of 2016 by subtracting the values of the earlier image from the values of the later image, cell by cell. Fortunately, the QGIS software will do this math work for us. Then we will analyze the meaning of the results.  
Step 1: Create a new raster image showing the change between the two NDVI images
On the QGIS menu bar 
Select Raster > Raster calculator XE "calculator" 
Click on the box to the right of Output layer box 
Browse to folder Landsat
In File Name box type NDVI-Change
Save

Type the following expression in the Raster calculator expression box

"NDVI-27-Jul-2016@1" - "NDVI-11-Jun-2002@1" 

(optional: try manually entering this formula by clicking on each item and operator on the screen)

OK

Step 2: Create a custom NDVI color ramp to visualize changes
This one-time action is needed to create a custom NDVI color ramp XE "color ramp"  in QGIS for use with the change analysis. The text required is contained in Appendix B of this document. This step creates a custom color ramp file that you will use in the following steps.

Start Word (or compatible program such as Notepad)

Open this document in Word and browse to Appendix B
Copy the text under Text for NDVIChangeColorRamp
File > New to create a blank document

Paste the copied text into the blank document

File > Save As 

Browse to the folder Landsat
file name NDVIChangeColorRamp
Select Save as type Plain Text 
Save > OK
File > Close

Step 3: Adjust the colors of the NDVI change raster map
Positive NDVI values, shown in green in the NDVI image, indicate increasing amounts of healthy vegetation. Negative NDVI values indicate loss of vegetation indicated by the red cells. Area of little change in NDVI values are shown in yellow.
In QGIS, uncheck all the layers except the layer named NDVI-Change
Select layer NDVI-Change > Properties > Symbology 
In Render type select Singleband Psuedocolor 

Click on the file folder icon [image: image24.png]



Browse to folder Landsat
Select NDVIChangeColorRamp
Open
In Interpolation box 
Select Discrete

OK

On the QGIS menu bar 
Select Project > Save 
Step 4: Example

After performing the NDVI change analysis, your image should look similar to this:
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NDVI change from 2002 to 2016
Step 5: Interpretation

In the image above, the red areas indicate loss of vegetation, the tan areas indicate little change in vegetation, and the green areas indicate an increase in vegetation, all between 2002 and 2016.

Remember that our scale of observation is 30 by 30 meters, so some cells will have a mix of vegetation, house roofs, concrete driveways, streets, and trees. 

The areas of most interest are the red ones, which clearly indicate the areas where trees were replaced by either bare ground or houses. 
If you happen to see cells that are white, that means that the value of the cell falls beyond what was specified in the color ramp. You may need to adjust the color ramp to account for all of the data. Use the information icon [image: image26.png]


 to see what sorts of values are being missed.

If we compare the Google Earth images from 2002 and 2016, we interpret the green areas in the lower left and right corners to mean that the house construction is complete, and now yards with grass and trees have caused an increase of vegetation from the bare ground of 2002.
Chapter 13:
Comparison with Results of
Other Researchers

This chapter includes:

· Examine the results produced by the University of Maryland Global Forest Coverage Change project
· Interpret the results of the comparison
In 2013 the University of Maryland’s Department of Geographical Sciences conducted an analysis of global forest coverage change. In this study, satellite data observing the entire Earth were used to map global forest loss (2.3 million square kilometers) and gain (0.8 million square kilometers) from 2000 to 2012 at a spatial resolution of 30 meters. The results obtained were derived from time-series analyses of Landsat images characterizing forest extent and change. The maps were updated in 2016 and 2018.
Step 1: Visit the Global Forest Coverage Change (GFCC) website

You can access the results of this study at:

http://earthenginepartners.appspot.com/science-2013-global-forest
In July of 2019 the website homepage looked like this:
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Step 2: Locate the Global Forest Coverage Change (GFCC) image for our study area

We can use the location of our study area to zoom in and see the analysis performed by the team from University of Maryland (UM).
On the GFCC website home page:
In the Data Products box

select Forest Cover Loss 2000-2018 (transparent)

Move the transparency slider to the middle of the bar

In the box at the top left of the screen titled Enter a location 
type Northeast 117th Way, Redmond, WA and press the Enter key

Click once on the minus sign of the Zoom In/Out slider in the lower left corner of the screen

The image should look similar to this:
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Study Area Forest Coverage Loss (2000-2018)
Step 3: Compare our NDVI change image to the Global Forest Coverage Change (GFCC) image for our study area

The following images compare the gain and loss from our NDVI analysis with the results produced by the University of Maryland researchers in the Global Forest Coverage Change project.
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Our Vegetation Coverage Change (2002-2016)
    GFCC Forest Coverage Loss (2000-2019)
Step 4: Interpretation

Comparing our NDVI analysis above with the UM GFCC forest loss image, we see relatively good agreement between shapes and area of coverage of forest “loss”. 

It is important to note the reasons why the two images might differ. First, the dates of images used to the produce the analysis are slightly different. University of Maryland used the date range of 2000 to 2019, while we used a date range of 2002 to 2016. A second reason for variance is that the UM analysis was of “forest coverage” with “forest” being defined as trees over 5 meters in height. However, our NDVI analysis was more general – we analyzed all vegetation not just forest. A third reason for differences is that the University of Maryland project performed corrections to the Landsat images related to atmospheric conditions – these corrections are beyond the scope of this text. 
Chapter 14:
Printing Maps and Images
This chapter includes:

· Learning how to prepare maps for distribution

· Creating template for the map

· Adding titles, legends and text boxes to the map

These instructions will help you create a template that will make it much easier to recreate a map with the same legend and symbology. This will save you a lot of time; you will not have to recreate the legend and symbology again for each map.

Step 1: Start QGIS

Start QGIS
On the QGIS menu bar 
Select Project > Open Recent
Browse to folder Redmond
Select File Name = Redmond-NDVI 
Open

Step 2: Create a new template for printing the map

Select the map layers you want to appear on the printed map. 
In the Layers Panel 

Uncheck layers you don’t want to print
Select the layer named NDVI-Change
Position the map in the screen as you want it to appear when printed. 

(optional) Select the Zoom In icon [image: image31.png]


 and, while holding down the left click button, draw a rectangle around the area that you want to appear when the map is printed.

On the QGIS menu bar

Select Project > New Print Layout
In the Create print layer Title box type NDVI-Diff 

OK

On the Layout icon panel 

Select the Add New Map icon [image: image32.png]


 
While holding down the left click button, draw a rectangle around the area where you want the map to appear.
If the map does not appear the way you want, 

Go back to the main map to adjust the view 

Return to Layout Manager
If the map does not render clearly or sharply

Click on the Refresh icon [image: image33.png]



To keep the map from being accidentally moved, lock its position

Click anywhere inside the map

Right click inside the map

Select Item Properties

In Layers section, check Lock layers
Select Layout on the menu bar
Select Save as template

Browse to folder Redmond 

File Name = NDVI-Diff

Save 

Step 3: Add a legend XE "legend" 
A useful feature for formatting the legend titles is the “wrap” feature. You can define a “wrap character” and insert it in the legend title to force the text following the wrap character to move onto the next line.

On the menu bar
Select Add Item > Add Legend
Click in the map at the position where you want the legend to appear
OK
Right click with the cursor inside the Legend box

Select Item Properties tab on the right
In Main Properties section

In Title box type Landsat 2002-2016
Define a Word wrap character (one-time only)
In Item Properties

Select Wrap Text On box and type any character, such as @
Open Legend Items section 

Uncheck the Auto Update box
Click on any layer you do not want to appear in the legend

Select Delete [image: image34.png]


 icon
Open Fonts section
Click on Title Font
Font > Arial > Font Style > Bold > Size 24 > OK

Click on Subgroup Font 
Font > Arial > Font Style > Bold > Size 16 > OK
In Item Font select a font of your choice > OK
Resize the frame of the text box by dragging the edges to fit text
Drag the legend to the upper left corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 4: Add a scale bar XE "scale bar" 
On the menu bar, 
Select Add Item > Add Scale Bar
Left click in the lower right corner of the map at the position where you want the Scale Bar to appear
In Height box, type 20
OK
In the Item Properties section

In Scalebar units box select Meters
In the Label unit multiplier box type 1.0

In the Label for units box type meters
In Segments select Left 0 and Right 3
Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Drag the scale bar to the lower right corner of the map, then use the arrow keys for fine-tuning position adjustments
Step 5: Add a map title XE "title" 
On the menu barSelect Add Item > Add Label
Click in the map at the position where you want the title to appear

In Height box, type 20
OK
In the Item Properties section
In the Main Properties box type an appropriate title for the map, such as:
NDVI Change from 2002 to 2016
Select Font 
Font > Arial > Font Style > Bold > Size 28 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes
Resize the frame of the text box by dragging the edges to fit text
Step 6: Add data source labels

On the menu bar
Select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type an appropriate title for the data sources, and add a list of them:
Data Sources:

- USGS

- Google Earth
Select Font 
Font > Arial > Font Style > Bold > Size 12 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes
Position the Data Source text box in the lower left corner of the map.

Resize the frame of the text box by dragging the edges to fit text
Step 7: Add a date and author label

On the menu bar
Select Add Item > Add Label

Click in the map at the position where you want the text box to appear

In Height box, type 20
OK

In the Item Properties section
In the Main Properties box type your name and the date the map was created
Select Font 
Font > Arial > Font Style > Bold > Size 10 > OK
Select Horizontal alignment = Left 

Check Frame and Background boxes
You can resize the frame of the text box by dragging the edges to fit text
Position the date label box in any part of the map.
Step 8: Add North Arrow XE "north arrow" 
On the menu bar
Select Add Item > Add Picture 
Left click in the lower right corner of the map at the position where you want the North Arrow to appear -> OK
On the right panel select Main Properties tab 

Click on Search directories section to expand 

Choose the north arrow you prefer from icon table 

In the Placement dropdown box, select Top Left 

Uncheck the Background box 

Step 9: Create image file of map 

Select menu option Layout 

Select Export as Image 
Browse to folder Redmond
In Save as type choose JPG format (*.jpg)
Name file with an appropriate name

Save > Save
Step 10: Print your map from the saved image

Open the JPG Image of your map using any program that will open a .jpg file

File > Print
uncheck fit picture to frame
Print

Step 11: Save the template:

Return to QGIS
Select menu option Layout > Save as Template

Browse to folder = Redmond 

File name = NDVI-diff

Save > Yes

Select menu option Layout > Close
Step 12: Save the project

On the QGIS menu bar
Select Project > Save 

On the QGIS menu bar
Select Project > Exit QGIS
Chapter 15:
Ground Truth Sampling
for Remote Sensing
This chapter includes:

· Definition of ground truthing

· Using GPS in ground truthing data collection

Ground truthing XE "Ground truthing"  is a term used in remote sensing to refer to collecting information on location, by visually confirming that the claims of a map are accurate. Ground truthing information allows digital image data to be related to real features and materials on the ground.

Ground truthing is usually done on site, by performing observations and measurements of various properties of the features of the ground resolution cells that are being studied on the remotely sensed digital image. 
Tips on using a GPS for ground truthing data collection
When using a GPS to determine the coordinates of a location, set the GPS datum to the same datum used by the digital maps in your GIS. One of the most common datums is WGS 84, which is used in this textbook. You can determine the datum used in your digital map by using your GIS software to look in the map’s metadata.

Set the GPS’s coordinate unit format to meet the input requirements of your GIS software. For example, QGIS input requires that latitude and longitude be formatted as a decimal number, so you must set the GPS coordinate unit’s format to degrees and decimals of degrees.

Part 5: 
Useful Tools
Chapter 16:
Adding Digital Elevation
Contour Lines
This chapter includes:

· About Digital Elevation Model (DEM) data 
· Instructions for adding elevation contour XE "elevation contours"  lines to a map

· Example of contour lines on a map
The goal of this exercise is to learn how to draw elevation contour XE "contours:elevation"  lines on a map.

The Shuttle Radar Topography Mission (SRTM) obtained elevation data on a near-global scale to generate the most complete high-resolution digital topographic database of Earth. SRTM consisted of a specially modified radar system that flew onboard the Space Shuttle Endeavour during an 11-day mission in February of 2000. 
Again we will use the EarthExplorer website operated by the US Geodetic Survey as the source of our data 
Step 1: Download Digital Elevation Model (DEM) data file
http://earthexplorer.usgs.gov/
If you have not already set up an account, do so now. Instructions can be found in Chapter 7.
On the Menu bar, select Login > Sign in with your username and password
In the box Address/Place > type Redmond, WA > Show
Select Redmond, WA, USA from the list displayed in the Address/Place box
Select the Data Sets button 
Click the + box next to Digital Elevation
Click the + box next to SRTM
Check the box SRTM Void Filled
Select the Results button at the bottom of the pane

Select Download Options icon [image: image35.png]


 for the map you want. For this example, choose Resolution:1-ARC
Select the GeoTIFF 1 Arc-second option
Click the Download button

Browse to locate the downloaded file in the folder Downloads.
Copy the file and paste it into the folder Redmond.
After the download completes

on the EarthExplorer Menu bar, select Logout
Step 2: Run QGIS and load your NDVI map
Start QGIS
On the menu bar select Project > Open Recent 
Select the project Redmond-NDVI
Right click the StudyArea layer > Zoom to Layer 
On the menu bar select Project > Save As
Browse to the folder Redmond 
In File Name box type Redmond-Elevation
Save
Step 3: Create the elevation contours 
On the menu bar 
Select Raster > Extraction > Contour
For Input layer > Select > browse to folder Redmond
choose file n47_w123_1arc_v2

Open
Select Interval between contour lines = 10 (this is meters)
For Contours > Select > Save to File > browse to folder Redmond
Select Save as type = SHP files 

Type File Name = Contours > Save
Check box Open output file after running algorithm
Click on Run button
Close

Step 4: Clip the contour image to study area size
In QGIS, uncheck all the layers except the layer named NDVI-11-Jun-2002

On the menu bar 

Select Vector > Geoprocessing Tools > Clip 
In the Input layer box, 

Browse to folder Landsat
Select the file Contour.shp
In the Overlay Area box
Select StudyArea
In the Clipped box

Select Save to File

Browse to the folder Landsat
Type StudyAreaContours in File Name box

Save

Click on Run button

Close
In the Layers panel

Right click on layer Clipped

Select Rename Layer

Type Contours as the layer name

Step 5: Label the elevation contour lines
Select the layer Contours
On the menu bar 
Select Layer > Labeling
On the dropdown menu that defaults to No layers
Select Single labels
In the Layer with box select ELEV
In Style box, select Bold
In Size box, type 10

In Color box, select Yellow
Select Placement [image: image36.png]


  tab

Select Curved 
Select on line
Select Symbology [image: image37.png]


 tab

Click on Simple line

In Color box, select Yellow
In Stroke width box, type 3.0

Apply
On the menu bar select Project > Save 
Step 6: Example
Your map should look similar to the following map:
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If the contours are behind the map, move Contours ahead of NDVI-Change in the Layers tab
Step 7: Add your elevation contours as a layer in Google Earth (optional)
In QGIS, right click on the layer named Contours
Select menu option Save as
In the Format box, choose Geography Markup Language [GML]
In the File name box,

browse to the folder Redmond
In the File name box type GEcontours
Save > OK
Start Google Earth
Drag and drop the file GEcontours onto the Google Earth display.

Google Earth will rotate to the location covered by your elevation contour file and overlay your elevation contours on the Google Earth display.
Chapter 17:
Coordinate System Conversion

This chapter includes:

· Understanding the need to convert coordinate systems

· Instructions for coordinate system conversion
If your map data is in different coordinate systems XE "coordinate systems conversion" , layers will not display properly in QGIS. You can know if you have a coordinate mismatch by right clicking on a layer and selecting Zoom to Layer. If another layer disappears, the two layers may be projected in different coordinate systems. A classic example is a mismatch between Landsat images, which use UTM coordinates, and an administrative boundaries layer using latitude/longitude coordinates. In this situation, the administrative boundary layer should be converted to UTM coordinates.

The following instructions show you how to convert map layers coordinate systems.

Step 1: Start the GIS program

Start QGIS
Step 2: Add a raster layer of a Landsat image 
On the QGIS side bar select Add Raster Layer icon [image: image39.png]



Browse to folder Landsat 
Select the file ending in B4 (band 4)
Open 
Right click the Landsat B4 layer > Properties
Select Source tab 
In the Set source coordinate reference system box
Make a note of coordinate system being used
Cancel
Step 3: Add a vector layer for the country 
On the QGIS side bar select Add Vector Layer icon [image: image40.png]



For Dataset, browse to folder Redmond and find file: USA_adm2.shp
Open > Open

Step 4: Decide if coordinate conversion is needed

Right click USA_adm2 layer > Properties
Select Source tab 

In the Set source coordinate reference system box

Compare the coordinate system to that of B4
If there is a difference, coordinate conversion is needed
Cancel
Step 5: Create a new shapefile layer with adjusted coordinates

Right click the USA_adm2 layer 
Select Save as option

Choose Format = ESRI Shapefile 
In File name box browse to the folder Redmond
In File name box type Country_UTM > Save

Browse CRS to find the UTM zone that matches the coordinate system from Step 2

In Encoding, choose Selected CRS
OK
Click to put a check in the box Add saved file to map
OK
Step 6: Remove the vector layer that is no longer needed

Right click the USA_adm2 layer 
Remove

Step 7: Verify that the conversion worked correctly

Right lick on the Landsat layer ending in b4
Click Zoom to Layer
Drag the Landsat layer to the top of the layer list

The conversion worked correctly if you see both the vector layer and the Landsat layer on the screen.
Chapter 18:
Creating a Study Area
Using QGIS
This chapter includes:

· Instructions for creating a study area layer as a vector file using QGIS
Purpose
Now that you have some map layers in your GIS project file defining the overall study region, you may want to study an area of special interest. Let’s define a new smaller area that is a subset of the full image area. The instructions in this chapter will assume you have completed up to the first part of Chapter 6.
Step 1: Start QGIS and load a previously saved project
Start QGIS
On the QGIS menu bar 
Select Project > Open 
Browse to the folder Redmond
Select the project ReferenceMap > Open
Step 2: Create a new shapefile layer 
On the QGIS menu bar 
Select Layer > Create Layer > New Shapefile Layer
Choose Geometry type Polygon
Click Select CRS button [image: image41.png]



Choose WGS 84 / UTM zone 10N in Selected CRS box

OK
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Each shapefile has an attribute table where data about its features are stored. Add any attribute fields you want in the New Attribute section. Adding fields is optional; fields can always be added later
In Name box type Name
Select Text data in Type box

In Length box type 48
Click on the Add to Fields List box
In File Name box 

Browse to the folder Redmond 
Type StudyArea
Save
OK
Your new StudyArea layer will automatically be added to the navigation menu on the left of your screen. In addition, the shapefile named StudyArea will now be saved in the folder Redmond.
Step 3: Define the boundaries of your study area 
On the QGIS menu bar 
Select View > Toolbars > click Digitizing Toolbar so that a check [image: image43.png]


 appears next to it
Right click on the CornerPoints layer

Left click on Zoom to Layer
Left click on the StudyArea layer
Select the Toggle Editing icon [image: image44.png]


  on the toolbar to turn editing “on”
Select the Add Polygon Feature icon [image: image45.png]


 
Draw a polygon around your study area 
Position the cursor at the upper left corner of your area and left click

Move the cursor to the upper right corner of your area and left click

Move the cursor to the lower right corner of your area and left click

Move the cursor to the lower left corner of your area and left click
Right click to finish the polygon
Type “1” in the id box

Type Corners in the Name box
OK
Select the Toggle Editing icon [image: image46.png]


 on the toolbar to turn editing “off”

Save
Right click the StudyArea layer > Properties
Select Symbology tab 
Left click on Simple fill
For Fill style select No Brush 
For Stroke color select red > OK
For Stroke width type 1
For Stroke style select Solid Line 
Apply > OK
Step 4: Adjust the boundaries of your subset area 
To refine the boundaries of the study area:

Left click on the StudyArea layer
Select the Toggle Editing icon [image: image47.png]


 on the toolbar to turn editing “on”
Select the Vertex Tool icon [image: image48.png]


 on the toolbar

(the cursor will change to a cross)

Move the “cross” cursor over the corner point you want to move 
Left click on the point and release the mouse button

Move the crosshairs to the desired location 
Click the left mouse button

When you are finished moving the corner points of your Study Area polygon

Select Toggle Editing icon [image: image49.png]


on the toolbar to turn editing “off” 
Choose Save 
Step 5: Save the Project

The new shapefile named StudyArea defining your study area has been saved in the folder Redmond.

On the QGIS menu bar 
Select Project > Save 
The vector shapefile named StudyArea can now be used to “clip” images so that they only contain data for the defined study area. Instructions for clipping can be found in Chapter 10, Step 3
Chapter 19:
Creating a Study Area
Using Google Earth
This chapter includes:

· Instructions for creating a study area using Google Earth XE "Google Earth"  features

Now that you have some map layers in your GIS project file, you may want to study a different area of special interest. Let’s define a new study area XE "study area"  that is a subset of the full image area.

Step 1: Run the Google Earth program and located your area of interest
Start Google Earth
Navigate to the general area you wish to define as your study area.
Step 2: Set the Google Earth coordinate system to match your QGIS project coordinate system
The coordinate system you use for your QGIS project must be the same as the coordinate system defined in Google Earth so that the file created in Google Earth will register correctly when you bring it into your QGIS project.

Select menu item Tools > Options 
Select the 3D View tab 
In the Show Lat/Long box

If you plan to work with Landsat images

Choose the Universal Transverse Mercator button

If you plan to work with GADM administrative boundary maps
Choose the Decimal Degrees button

Apply > OK

Step 3: Draw a polygon around your study area
Select the Add Polygon [image: image50.png]


 icon
In the Name box, type StudyAreaGE
Move the cursor outside the polygon parameters box to the upper left corner of your desired study area. You may need to move the parameters box out of the way by left clicking in the title bar, then, while holding the left click button down, drag the box to an unused position on your screen.

Position the cursor at the upper left corner of your study area and left click

Move the cursor to the upper right corner of your area and left click

Move the cursor to the lower right corner of your area and left click

Move the cursor to the lower left corner of your area 
If your study area is not a rectangle, you can left click on as many points as you need
OK
Step 4: Save your study area polygon as a KML file XE "KML file" 
On the main menu File > Save > Save Place As 
browse to folder named Redmond 
type File Name = StudyAreaGE
select File Type = KML
Save

Step 5: Add the KML file of your study area to QGIS project
Start QGIS
On the main menu select Project > Open 
Browse to the folder where your project is located
Select your project file

Open
On the QGIS side tabs select Add Vector Layer icon [image: image51.png]



For Dataset, browse to folder where your project is located
In the box to the right of File Name select file type KML
Select the file named StudyAreaGE
Open > Open

Step 6: Create a shapefile of your study area
Right click the StudyAreaGE layer 
Select Save as option

Choose Format = ESRI shapefile 
In Encoding, choose Layer CRS
Browse CRS 
Select in the Coordinate Reference Systems of the World box the same reference system that you are using for your reference map project > OK
Click to put a check in the box Add saved file to map
In Save As box, browse to folder where your project is located
In File Name box type, StudyAreaGE > Save

OK 
Right click on the layer StudyAreaGE
Select Zoom to Layer 
Right click the StudyAreaGE layer > Properties
Select Style tab 
Click on Simple fill
For Fill style select No Brush 
For Border color select black > OK
For Border style select Solid Line 
For Border width type 1
Apply > OK
Right click the StudyAreaGE layer for the KML file

Select Remove > OK
Step 7: Adjusting the boundaries of your study area

If you need to adjust the boundaries of your study area, follow the instructions in Step 4 of Chapter 18.
Step 8: Save the Project

The new shapefile named StudyAreaGE defining your study area has already been saved in folder Redmond.

On the menu bar select Project > Save 
On the menu bar select Project > Exit QGIS
Chapter 20:
A Challenge
This chapter includes:

· Challenge to define your own project and practice 

Challenge yourself by using what you’ve learned to study a different area. You can define your own project by following this workflow to analyze and document your results. Refer to the chapter numbers for each step of the workflow.
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Appendix A: References

1. Satellite Archeology, National Geographic Magazine, February, 2013, pp 60-61

2. Introduction to Remote Sensing, Fifth Edition, Campbell and Wynne, The Guilford Press, 2011
3. Users Guide, QGIS 2.14, Forestry Application

https://docs.qgis.org/2.14/en/docs/training_manual/forestry/index.html
Appendix B: NDVI ColorRamps
Text for NDVIColorRamp
# QGIS Generated Color Map Export File

INTERPOLATION:DISCRETE

-0.45,0,76,255,255,Water

-0.15,116,126,153,255,Structures

0.15,191,163,124,255,Bare Surface / Pavement

0.25,177,223,171,255,Scattered Vegetation

0.4,61,166,89,255,Moderate Vegetation

0.6,0,87,27,255,Dense Vegetation

How color ramps work in QGIS

[image: image53.png]



When the value falls between two numbers, the color of the higher number in the range will be rendered.

Click the check mark next to layer name so that the map will be render each time a value is changed

Text for NDVIChangeColorRamp
# QGIS Generated Color Map Export File

INTERPOLATION:DISCRETE

-0.01,210,45,37,255,Loss

0.15,252,233,134,255,Neutral gain/loss

0.500000,16,153,27,255,Gain

 Index
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QGIS - perform NDVI analysis (10-13)





QGIS - print maps (14)





Download Admin maps (4)





Ground Truthing (15)





Download QGIS software (3)
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